Subject: [v6ops] JAMES: Just Another Measurement of Extension header Survivability

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 4 Mar 2022 17:04:01 +0000

Please find below a -00 (so really draft) of "Just Another Measurement of Extension header Survivability (JAMES)".

Copying the introduction below:

   In 2016, [RFC7872] has measured the drop of packets with IPv6

   extension headers on their transit over the global Internet.  This

   document presents a slightly different methodology with more recent

   results.  Since then, [I-D.draft-ietf-opsec-ipv6-eh-filtering] has

   provided some recommendations for filtering transit traffic, there

   may be some changes in providers policies.

   It is still work in progress, but the authors wanted to present some

   results at IETF-113 (March 2022).

Justin, Raphaël, and I are looking forward to reading your comments and suggestions.

Fred and Ron, we would appreciate to get a 10-minute slot to present this work at IETF-113 (even hoping for an improved -01 by that time).

Finally, let me repeat the acknowledgements section:

   The authors want to thank Sander Steffann and Jan Zorz for allowing

   the free use of their labs.  Other thanks to Fernando Gont who

   indicated a nice IPv6 hosting provider in South America.

Regards

-éric

PS: and yes, I am proud of the JAMES acronym ;)

-----Original Message-----

From: "[email-masked]" <[email-masked]>

Date: Friday, 4 March 2022 at 17:55

To: Raphaël Léas <[email-masked]>, Eric Vyncke <[email-masked]>, Eric Vyncke <[email-masked]>, Justin Iurman <[email-masked]>, Raphaël Léas <[email-masked]>

Subject: New Version Notification for draft-vyncke-v6ops-james-00.txt

    A new version of I-D, draft-vyncke-v6ops-james-00.txt

    has been successfully submitted by Éric Vyncke and posted to the

    IETF repository.

    Name:                              draft-vyncke-v6ops-james

    Revision:          00

    Title:                  Just Another Measurement of Extension header Survivability (JAMES)

    Document date:           2022-03-04

    Group:                              Individual Submission

    Pages:                               15

    URL:            https://www.ietf.org/archive/id/draft-vyncke-v6ops-james-00.txt

    Status:         https://datatracker.ietf.org/doc/draft-vyncke-v6ops-james/

    Html:           https://www.ietf.org/archive/id/draft-vyncke-v6ops-james-00.html

    Htmlized:       https://datatracker.ietf.org/doc/html/draft-vyncke-v6ops-james

    Abstract:

       In 2016, [RFC7872] has measured the drop of packets with IPv6

       extension headers.  This document presents a slightly different

       methodology with more recent results.  It is still work in progress.

    The IETF Secretariat

---

From: Warren Kumari <[email-masked]>
Date: Fri, 4 Mar 2022 14:35:45 -0500

On Fri, Mar 4, 2022 at 12:04 PM Eric Vyncke (evyncke) <evyncke=
[email-masked]> wrote:

> *   In 2016, [RFC7872] has measured the drop of packets with IPv6*
>
> *   extension headers on their transit over the global Internet.  This*
>
> *   document presents a slightly different methodology with more recent*
>
> *   results.  Since then, [I-D.draft-ietf-opsec-ipv6-eh-filtering] has*
>
> *   provided some recommendations for filtering transit traffic, there*
>
> *   may be some changes in providers policies.*
>
> *   It is still work in progress, but the authors wanted to present some*
>
> *   results at IETF-113 (March 2022).*
>
>
>
> Fred and Ron, we would appreciate to get a 10-minute slot to present this
> work at IETF-113 (even hoping for an improved -01 by that time).
>
>
>
> *   The authors want to thank Sander Steffann and Jan Zorz for allowing*
>
> *   the free use of their labs.  Other thanks to Fernando Gont who*
>
> *   indicated a nice IPv6 hosting provider in South America.*
>
>
>
> Regards
>
>
>
> -éric
>
>
>

Nod, as you should be.

On a related note, on the IEPG agenda we have:
"IPv6 Fragmentation and EH behaviours" by Geoff Huston and Joao Damas.

The IEPG is an informal gathering that meets on the Sunday prior to IETF
meetings. The intended theme of these meetings is essentially one of
operational relevance in some form or fashion - although the chair will
readily admit that he will run with an agenda of whatever is on offer at
the time!

IEPG will be meeting at IETF 113 -- it is on the agenda (
https://datatracker.ietf.org/meeting/113/agenda/), but for
convenience: Sunday, March 20, 2022 - 18:00-20:00 (Local Vienna time -- the
agenda has helpful conversion to other timezones).

W

> To: Raphaël Léas <[email-masked]>, Eric Vyncke <
> [email-masked]>, Eric Vyncke <[email-masked]>, Justin Iurman <
> [email-masked]>, Raphaël Léas <[email-masked]>
>
>     URL:
> https://www.ietf.org/archive/id/draft-vyncke-v6ops-james-00.txt
>
>     Status:
> https://datatracker.ietf.org/doc/draft-vyncke-v6ops-james/
>
>     Html:
> https://www.ietf.org/archive/id/draft-vyncke-v6ops-james-00.html
>
>     Htmlized:
> https://datatracker.ietf.org/doc/html/draft-vyncke-v6ops-james
>
>
>
>
>
>     Abstract:
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

-- 
The computing scientist’s main challenge is not to get confused by the
complexities of his own making.
  -- E. W. Dijkstra

---

From: Tom Herbert <[email-masked]>
Date: Fri, 4 Mar 2022 13:36:16 -0800

Eric,

Thanks for this data!

One thing that stands out to me is that 99% of Destination Options
with size eight reached the destination, but when that goes up to 256
bytes that drops to 2.6%. I would infer that the good news is that
routers don't seem to be arbitrarily dropping packers just because
they carry an extension header. The precipitous drop going to 256
bytes size might be related to the size of the parsing buffer being
exceeded. Is there any chance to run the experiment for varying sizes
between eight and 256 bytes?

Thanks,
Tom

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 4 Mar 2022 21:46:25 +0000

Tom

This is indeed the plan to get an estimate of the 'right' size

-----Original Message-----
From: Tom Herbert <[email-masked]>
Date: Friday, 4 March 2022 at 22:36
To: Eric Vyncke <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [v6ops] JAMES: Just Another Measurement of Extension header Survivability

    Eric,

    Thanks for this data!

    Thanks,
    Tom