Subject: Re: [v6ops] Fwd: New Version Notification for draft-xie-v6ops-reqirements-multi-domain-ipv6only-00.txt

From: Giuseppe Fioccola <[email-masked]>
Date: Thu, 3 Mar 2022 09:34:57 +0000

Hi Chongfeng,
Thank you for proposing this draft.
I think that a document about the requirements of multi-domain IPv6-only network make a lot of sense, especially if we consider large-scale operators composed of multiple ASes.

I also read draft-ietf-bess-ipv6-only-pe-design and it aims to address a similar issue. It would be good to have cross-reference and collaboration between these documents.

Regarding Section 8 on Requirements, I think these can be further discussed in the WG based on the experience of network operators. I would suggest to distinguish between Basic Requirements, that a solution must satisfy, and Optional Requirements, that are instead desirable. The rationale is that some requirements may not be easily addressed in every operator networks but this would not prevent to have a multi-domain IPv6-only network.

Regards,

Giuseppe

From: v6ops <[email-masked]> On Behalf Of Chongfeng Xie
Sent: Sunday, January 30, 2022 3:37 AM
To: V6Ops-Chairs <[email-masked]>; [email-masked]
Subject: [v6ops] Fwd: New Version Notification for draft-xie-v6ops-reqirements-multi-domain-ipv6only-00.txt

Hi, all,
We have submitted a new draft as below. It mainly specifies requirements of multi-domain IPv6-only network from the perspective of operators.  Mutli-domain herein means a network is compose of multiple ASes and serves multiple scenarios, which is a common model for large-size operators.  This is only -00 draft and a start point, we are looking forward to receiving more comments and suggestions.   Thank you!

Best regards
Chongfeng

A new version of I-D, draft-xie-v6ops-reqirements-multi-domain-ipv6only-00.txt
has been successfully submitted by Chongfeng Xie and posted to the
IETF repository.

Name:                draft-xie-v6ops-reqirements-multi-domain-ipv6only
Revision:            00
Title:                   Requirements to multi-domain IPv6-only network
Document date:              2022-01-29
Group:                Individual Submission
Pages:                 13
URL:            https://www.ietf.org/archive/id/draft-xie-v6ops-reqirements-multi-domain-ipv6only-00.txt
Status:         https://datatracker.ietf.org/doc/draft-xie-v6ops-reqirements-multi-domain-ipv6only/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-xie-v6ops-reqirements-multi-domain-ipv6only

Abstract:
  Dual-stack requires IPv4 and IPv6 are deployed in parallel, as it
  costs more to run two technologies than one.  IPv6-only is considered
  to be the next stage of IPv6 development from dual-stack.  This
  document specifies requirements when deploying IPv6-only in multi-
  domain networks.

The IETF Secretariat

---

From: Chongfeng Xie <[email-masked]>
Date: Fri, 4 Mar 2022 17:00:13 +0800

Hi，Giuseppe，
Your comments are really appreciated. Pls find my answer inline.

Chongfeng

> 2022年3月3日 下午5:34，Giuseppe Fioccola <[email-masked]> 写道：
> 
> Hi Chongfeng,
Thanks
> I also read draft-ietf-bess-ipv6-only-pe-design and it aims to address a similar issue. It would be good to have cross-reference and collaboration between these documents.

[Chongfeng]: OK, I will reference the draft you mentioned. The two drafts are related, however, they address different issues, the draft of draft-ietf-bess-ipv6-only-pe-design mainly provides a solution for Internet Exchange Point that are facing IPv4 address depletion at large peering points.  The draft of draft-xie-v6ops-reqirements-multi-domain-ipv6only mainly highlight the requirements when implementing IPv6 in multi-domain network.  
 
> Regarding Section 8 on Requirements, I think these can be further discussed in the WG based on the experience of network operators. I would suggest to distinguish between Basic Requirements, that a…

[Chongfeng], I agree. We will do this in the future versions based on your suggestion.

>  
>  
> From: v6ops <[email-masked] <mailto:[email-masked]>> On Behalf Of Chongfeng Xie
> To: V6Ops-Chairs <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> URL:            https://www.ietf.org/archive/id/draft-xie-v6ops-reqirements-multi-domain-ipv6only-00.txt <https://www.ietf.org/archive/id/draft-xie-v6ops-reqirements-multi-domain-ipv6only-00.txt>
> Status:         https://datatracker.ietf.org/doc/draft-xie-v6ops-reqirements-multi-domain-ipv6only/ <https://datatracker.ietf.org/doc/draft-xie-v6ops-reqirements-multi-domain-ipv6only/>
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-xie-v6ops-reqirements-multi-domain-ipv6only <https://datatracker.ietf.org/doc/html/draft-xie-v6ops-reqirements-multi-domain-ipv6only>
> 
> 
> Abstract: