Subject: [VCARDDAV] Support for MLS (multiple name entries of the same person attributes in different languages)

From: Shankar Gowda MBN <[email-masked]>
Date: Mon, 24 Oct 2011 13:58:53 +0530

Hi ,

xCard: vCard XML Representation 
<http://tools.ietf.org/html/rfc6351>should support the MLS ( multiple 
name entries of the same person attributes in different languages), I 
want to know how these attributes are described for FN element for a user ?

*Assumed xcard FN example for different languages,

Scenario 1:

*

<fn>
	<lang>
		<parameters>
			<perf>
				<interger>3</interger>
			</perf>
		</parameters>
		<language-tag>en</language-tag>
	</lang><text>Billy Ray</text>
</fn>

<fn>
	<lang>
		<parameters>
			<perf>
				<interger>2</interger>
			</perf>
		</parameters>
		<language-tag>ja</language-tag>
	</lang>
	<text>日本太郎</text>
</fn>

<fn>
	<lang>
		<parameters>
			<perf>
				<interger>1</interger>
			</perf>
		</parameters>
		<language-tag>fr</language-tag>
	</lang>
	<text>Rayon de Facture</text>
</fn>

*Scenario 2:

*

<fn>
	<lang>
		<parameters>
			<perf>
				<interger>3</interger>
			</perf>
		</parameters>
		<language-tag>en</language-tag>
	</lang>
	<text>Billy Ray</text>
	<lang>
		<parameters>
		<perf>
			<interger>2</interger>
		</perf>
		</parameters>
	<language-tag>ja</language-tag>
	</lang><text>日本太郎</text>

	<lang>
		<parameters>
			<perf>
				<interger>1</interger>
			</perf>
		</parameters>
	<language-tag>fr</language-tag>
	</lang>
	<text>Rayon de Facture</text>
</fn>

*
*

***
Please let us know, Which one of above representations of data is correct ?

As per the xCard Relax NG Schema,
*

# 6.2.1
property-fn = element fn {
     element parameters { param-language, param-altid, param-pid,
                          param-pref, param-type }?,
     value-text
   }

*
*Regards,
Shankar

---

From: Arnaud Quillaud <[email-masked]>
Date: Mon, 24 Oct 2011 14:28:21 +0200

On 24/10/2011 10:28, Shankar Gowda MBN wrote:
> 	<text>????</text>
> 	</lang><text>????</text>

None of them as far as I understand. I think you mixed 2 different things:

There is a lang *property* which is defined in 
http://tools.ietf.org/html/rfc6350#section-6.4.4 and corresponds to 
"language(s) that may be used for contacting the entity associated with 
the vCard."
Then there is a language property *parameter*(defined in 
http://tools.ietf.org/html/rfc6350#section-5.1 ) which can be put on 
most properties and defines the language a particular property value is 
expressed in.

In other words, what you want to use looks more like:

<fn>
		<parameters>
			<language>

			</language>
		</parameters>
		
		<text>Billy Ray</text>
</fn>

<fn>

		<parameters>
			<language>

			</language>
		</parameters>

	<text>????</text>
</fn>

Arnaud Quillaud
> _______________________________________________
> VCARDDAV mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/vcarddav

---

From: Shankar Gowda MBN <[email-masked]>
Date: Mon, 24 Oct 2011 18:12:27 +0530

Hi Arnaud,

Got It.  Thanks for the snippet.

Regards,
Shankar
On 10/24/2011 5:58 PM, Arnaud Quillaud wrote:
> "language(s) that may be used for contacting the entity associated 
> with the vCard."
> most properties and defines the language a particular property value 
> is expressed in.
>

-- 
Regards, Shankar

Oracle India Pvt. Ltd.
Shankar Gowda MBN | Senior Member Technical Staff
Phone: +918066927179 <tel:+918066927179> | Fax: +918022231794 
<fax:+918022231794> | Mobile: +919972544226 <tel:+919972544226>
Oracle Server Globalization Technology

ORACLE India | IDC, Divyasree Chambers, Off Langford Road, | 560025 
Bengaluru
Green Oracle <http://www.oracle.com/commitment> Oracle is committed to 
developing practices and products that help protect the environment