Subject: [vnfpool] GitHub repository for "RSerPool for vnfpool" document

From: Thomas Dreibholz <[email-masked]>
Date: Mon, 07 Oct 2013 21:23:13 +0200

Hi,

I have started to create the draft on RSerPool for vnfpool applicability. For 
that purpose, I have created a GitHub repository here: 
https://github.com/dreibh/rserpool4vnf .

The deadline for 00-version drafts is Monday, October 21 at 24:00 (i.e. in a 
little bit more than 2 weeks from now). This should be fine.

I can continue with writing a short introduction of RSerPool in section 3, 
with the things it provides (pool management, session handling, etc.), the 
things it does not intend to provide by itself (i.e. state sharing) and some 
notes on implementation and deployment.

Section 2 could be a short introduction to vnfpool, with its requirements to 
the pooling infrastructure. Does anybody want to write this section?

Section 4 would then contain the information about using RSerPool for vnfpool. 
We could discuss the details here once section 2 and 3 are (almost) complete.

-- 
Best regards / Mit freundlichen Grüßen / Med vennlig hilsen

=======================================================================
 Thomas Dreibholz

 Simula Research Laboratory
 Simula Innovation AS, Network Systems Group
 Visiting address: Martin Linges vei 17, 1364 Fornebu, Norway
 Mailing address:  P.O.Box 134, 1325 Lysaker, Norway
-----------------------------------------------------------------------
 E-Mail:     [email-masked]
 Homepage:   http://simula.no/people/dreibh
=======================================================================

---

From: Melinda Shore <[email-masked]>
Date: Mon, 07 Oct 2013 11:41:07 -0800

> We could discuss the details here once section 2 and 3 are (almost) complete.

Thanks for taking the initiative on this. I'd be happy to
contribute security considerations, plus review.

Melinda

---

From: Thomas Dreibholz <[email-masked]>
Date: Wed, 16 Oct 2013 18:43:51 +0200

Mandag 7. oktober 2013 11.41.07 skrev Melinda Shore:
> > things it does not intend to provide by itself (i.e. state sharing) and
> > some notes on implementation and deployment.
> > 
> > Section 2 could be a short introduction to vnfpool, with its requirements
> > to the pooling infrastructure. Does anybody want to write this section?
> > 
> > Section 4 would then contain the information about using RSerPool for
> > vnfpool. We could discuss the details here once section 2 and 3 are
> > (almost) complete.

Great!

I have pushed the updated document including Section 3 onto the GitHub 
repository. Please have a look. I have added a section for security 
considerations. Just add your text there.

In Section 4, I have added some items that could be discussed.

Who would like to write Section 2 with some details on VNF?

---

From: Zongning <[email-masked]>
Date: Fri, 18 Oct 2013 03:19:16 +0000

Hi, Thomas,

Thanks for writing the draft.
I am not good at using GitHub (yet!). Anyway, I will send you a short introduction to vnf and vnfpool today, so you could have an initial draft by deadline I suppose. :)

-Ning

> -----Original Message-----
> From: Thomas Dreibholz [mailto:[email-masked]]
> Sent: Thursday, October 17, 2013 12:44 AM
> To: Melinda Shore; [email-masked]; Zongning
> Cc: [email-masked]
> Subject: Re: GitHub repository for "RSerPool for vnfpool" document
> 
> > > I can continue with writing a short introduction of RSerPool in
> > > section 3, with the things it provides (pool management, session
> > > handling, etc.), the things it does not intend to provide by itself
> > > (i.e. state sharing) and some notes on implementation and deployment.
> > >
> > > Section 2 could be a short introduction to vnfpool, with its
> > > requirements to the pooling infrastructure. Does anybody want to write
> this section?
> > >
> > > Section 4 would then contain the information about using RSerPool
> > > for vnfpool. We could discuss the details here once section 2 and 3
> > > are
> > > (almost) complete.
> > Thanks for taking the initiative on this. I'd be happy to contribute
> > security considerations, plus review.
> 
> Great!
> 
>  Simula Innovation AS, Network Systems Group  Visiting address: Martin
> Linges vei 17, 1364 Fornebu, Norway  Mailing address:  P.O.Box 134, 1325
> Lysaker, Norway

---

From: Thomas Dreibholz <[email-masked]>
Date: Fri, 18 Oct 2013 21:12:26 +0200

Fredag 18. oktober 2013 03.19.16 skrev Zongning:
> I am not good at using GitHub (yet!). Anyway, I will send you a short
> introduction to vnf and vnfpool today, so you could have an initial draft
> by deadline I suppose. :)

Great! I have added your text and you as co-author into the draft document in 
the GitHub repository.