Subject: Doubt regarding ARP cache updation

From: basila <[email-masked]>
Date: Thu, 15 Jan 98 14:46:00 PST

Hi,

We have a doubt in the ARP cache updation in the hosts which affects load 
sharing

Lets consider the following cofiguration specified in 
"draft-ietf-vrrp-spec-04.txt" (Section 4.2) for explaining load sharing.

>   The following figure shows a configuration with two virtual routers
>   with the hosts spitting their traffic between them.
>
>                       VRID=1       VRID=2
>                      +-----+      +-----+
>                      | MR1 |      | MR2 |
>                      |  &  |      |  &  |
>                      | BR2 |      | BR1 |
>                      +-----+      +-----+
>         IP A ---------->*            *<---------- IP B
>                         |            |
>                         |            |
>                         |            |
>       ------------------+------------+-----+--------+--------+--------+--
>                                            ^        ^        ^        ^
>                                            |        |        |        |
>                                          (IP A)   (IP A)   (IP B)   (IP B)
>                                            |        |        |        |
>                                         +--+--+  +--+--+  +--+--+  +--+--+
>                                         |  H1 |  |  H2 |  |  H3 |  |  H4 |
>                                         +-----+  +-----+  +--+--+  +--+--+
>
>      Legend:
>               ---+---+---+--  =  802 network, Ethernet or FDDI
>                            H  =  Host computer
>                           MR  =  Master Router
>                           BR  =  Backup Router
>                            *  =  IP Address
>                         (IP)  =  default router for hosts

In the above configuration,

Virtual router VRID 1 will send gratuitous ARP for IP A as well as IP B 
since the specification says the gratuitous arp should be sent for all the 
IP address it owns. In this case all the four hosts ARP cache will be 
updated with virtual MAC "00 00 5E XX XX 01".

When the hosts H1 and H2 send data to IP A its MAC address will be the one 
that of virtual router VRID1 (00 00 5E XX XX 01) and when the hosts H3 and 
H4 send data to IP B its MAC address will also be the one that of virtual 
router VRID1 (00 00 5E XX XX 01)

So in the above configuration all the four hosts will effectively send data 
to virtual router VRID 1 and Load sharing will not happen.

We would appreciate if someone in the mailing list could help us in
clarifying the doubt.

Regards,
Rao & Basil

V.R.N. Rao & Anton Basil
Future Software Pvt., Ltd.,
481, Nandanam,
Madras - 600 035.

Voice : 91-44-4340323, 4330550 (Extn : 331)
Fax : 91-44-4344157, 4834551, 4834661
Email : [email-masked], [email-masked]

---

From: Peter Hunt <[email-masked]>
Date: Thu, 15 Jan 1998 08:56:00 -0800

Rao & Basil,

> Virtual router VRID 1 will send gratuitous ARP for IP A as well as
> IP B since the specification says the gratuitous arp should be
> sent for all the IP address it owns. In this case all the four
> hosts ARP cache will be updated with virtual MAC "00 00 5E XX XX 01".

	The router on the left owns IP A, and the router on the
right owns IP B.

	When the left router comes up, it will become master of
virtual router 1, and will send a gratuitous ARP for IP A, with
MAC address 00 00 5E XX XX 01. When the router on the right comes
up, it will become master of virtual router 2, and will send a
gratuitous ARP for IP B, with MAC address 00 00 5E XX XX 02.

	So the MAC address used by H1 and H2 to reach IP A will
be different from the MAC address used by H3 and H4 to reach IP B.

	If the router on the right fails, router A will become
master of virtual router 2, and will adopt its address (IP B).
It will then send out a gratuitous ARP for IP B, with MAC address
00 00 5E XX XX 02. It will also respond to ARP requests for IP B
with 00 00 5E XX XX 02. That is, it has taken over the whole virtual
router, including the IP address and the VRID (which determines
the MAC address).

	So the hosts' ARP entries for IP A and IP B will always
valid, regardless of which VRRP router is master.

-- 
| Peter Hunt                              |  Phone: +1 408 990 2093
| Ipsilon Networks Inc.                   |  Fax:   +1 408 743 5677
| 232 Java Drive, Sunnyvale CA 94089-1318 |  Email: [email-masked]