Subject: vrrpOperProtocol attribute

From: Scott Barvick <[email-masked]>
Date: Tue, 14 Apr 1998 10:52:03 -0400

>From the DECnet VRRP discussion and other ideas about the use of VRRP,
it seems that we might need a vrrpOperProtocol attribute to distinguish
among various protocols which might be backed up through VRRP.

How about:

vrrpOperProtocol OBJECT-TYPE
   SYNTAX   INTEGER {
       ip (1),
       bridge (2),
       DECnet (3),
       other (4)
   }
   MAX-ACCESS read-create
   STATUS     current
   DESCRIPTION
       "The particular protocol being controlled by this Virtual
        Router."
   DEFVAL { ip }
   ::= {vrrpOperEntry X}

-- 
Scott Barvick
[email-masked]
(978) 952-6000 x162

---

From: Acee Lindem <[email-masked]>
Date: Tue, 14 Apr 1998 13:02:40 -0400

> vrrpOperProtocol OBJECT-TYPE

There are already host-transparent mechanisms for multiple bridge paths
to back one another up. 

>        "The particular protocol being controlled by this Virtual

I think this is going overboard since to do it consistently you'd need
to associate addresses from the non-IP protocols to a VRID. This 
wouldn't preclude a vendor from using VRRP "router-awareness" to
provide backup of other protocols - it just keeps it out of the 
base specificaition. 

-- 
Acee