Subject: Doubt

From: basila <[email-masked]>
Date: Fri, 22 May 98 11:18:00 PDT

Hi,

I have the following doubt regarding the VRRP operation:

Consider the following topology:

                 +-----+
                 |     |
          (IP C) | H3  |
                 |     |
                 +--+--+
                    |
                    | Network C
   -----------------+------------------
                    |
                    |
                 +--+--+
                 |     |
                 | VR3 |
                 |     |
                 +-----+
                   --
                 /    \
            /----       ----\
           |       IP        |
            \____       ____/
                 \    /
                   --
    +--+--+                    +--+--+
    |     |                    |     |
    | VR1 |                    | VR2 |
    |     |                    |     |
    +--+--+                    +--+--+
       |                          |
       |                          |
   ----+--+--------------------+--+----
Network A |                    | Network B
          |                    |
       +--+--+              +--+--+
       |     |              |     |
(IP A) | H1  |              | H2  | (IP B)
       |     |              |     |
       +-----+              +-----+

    Assumptions:
    VR1, VR2 and VR3 are Virtual routers connected by IP network.
    VR2 is backing up VR1.
    H1, H2 and H3 are hosts connected through VRRP routers

   Problem Description:
    Let's consider a scenario where there is a active FTP session
    between H1 and H3 through Virtual routers VR1 <-> VR3. When
    virtual router VR1 is down, its forwarding responsibility
    should be taken over by VR2. So the FTP session between H1 and
    H3 should be through VR2<->VR3.

    But the information about forwarding responsibility changeover
    between VR1 and VR2 is not available VR3. Since this information
    is not available with VR3, it will route the packets to VR1
    where the packets will get dropped, as it is in backup state now.
    To avoid this situation, the information about the forwarding
    responsibility changeover between VR1 and VR2 should be made
    available to VR3.

    Doubt:
    In this case, do the VRRP need to have control over the routing
    protocol so that the routing updates are appropriately sent when
    there is a transition within VRRP?

    In the abovementioned scenario, VR1 should send routing update
    specifying Network A is unreachable through VR1 when it transits
    to backup. Similarly VR2 should send a routing update specifying
    its reachability to Network A when it transits to master.

    I would appreciate if someone in the mailing list could help me
    in clarifying this doubt.

    Regards

    Basil

/*-----------------------------------------------------------*/
R. Anton Basil
Future Software Private Limited.
480-481, Anna Salai, Nandanam,
Chennai - 600 035,
INDIA.
Tel : +91-44-4330550
Fax : +91-44-4344157, 4834551, 4834661
email : [email-masked]
/*-----------------------------------------------------------*/

---

From: Acee Lindem <[email-masked]>
Date: Fri, 22 May 1998 10:11:31 -0400

basila wrote:
   Pruned
     o
     o 
>     responsibility changeover between VR1 and VR2 should be made

Anton, 

VRRP's primary goal is to provide transparent default gateway backup for
hosts. 	It is not meant to be routing protocol - use RIP or OSPF between
routers VR1, VR2, VR3. Let's take this a step further - if the VR1 
connection to VR3 goes down but it is still active on the LAN with
the H1, you will need to run an IGP (e.g., RIP or OSPF) on the LAN 
with VRRP so that VR1 has the correct routes and can send redirects
to hosts using it as a default gateway. 

-- 
Acee