Subject: RE: Gratuitous ARP

From: David Whipple <[email-masked]>
Date: Tue, 2 Jun 1998 17:51:05 -0700

Gratutious ARP is supported on Windows NT, not 9X.  I am not real sure about
which Unix versions support it.

Thanks.
David Whipple.

-----Original Message-----
From: Apoorva Bhatt [mailto:[email-masked]]
Sent: Tuesday, June 02, 1998 4:43 PM
To: [email-masked]'
Subject: Gratuitous ARP

Sorry guys if this topic has already been discussed before.
I am doing a collective survey and it would be great to know which
endhost vendors support Gratuitous ARP and which ones do not.

I got a message from Acee Lindem (Thanks to Acee!) that BSD 4.3/4.4
honors Gratuitous ARPs. If Gratuitous ARP is not supported on all
platforms, then can somebody convince me why VRRP is a practical and a
great implementation and not proprietary ones like Cisco's HSRP, etc.

Thanks,
Apoorva Bhatt

---

From: Tony Li <[email-masked]>
Date: Tue, 2 Jun 1998 17:57:57 -0700 (PDT)

|  Gratutious ARP is supported on Windows NT, not 9X.  I am not real sure about
|  which Unix versions support it.

So how does that help the legacy systems that VRRP/HSRP was trying to fix?

Tony

---

From: Carol Iturralde <[email-masked]>
Date: Thu, 04 Jun 1998 11:09:33 -0400

Tony:

I don't see that the Gratuitous ARP 'fix'es anything with VRRP.
In VRRP, when a router dies and is replaced, the new master
uses the same IP:MAC binding (same IP address AND same MAC
as the failed router).  I conclude that the gratuitous ARP
does not do any re-mapping of host's ARP entries.

Carol