Subject: Vrrp Query.

From: Rajnish Madan <[email-masked]>
Date: Mon, 20 Nov 2000 15:42:52 -0000

Hi All,

I have a basic query regarding how the VRRP works.

As I understand, the router have its physical MAC address, say X,
which a host uses for the communication. The ethernet card will be having
this MAC address onto it. All the packets which have this MAC address are
being picked and forwarded by the router.

Now consider the case in which the VRRPd starts running on R1 as master and is backed up by R2. 
At this moment R1 starts picking up the packets destined for the Virtual MAC Address, 
say V (by telling to the hosts thru gratituous ARP).

Does this mean that the hardware address of the Ethernet card to be changed to V.
If YES
	1. What about the hosts which do not have (for any reason) the ARP table modified with IP mapping to V.
	2. In case a Router is acting as master for two (the virtual routers), which virtual MAC address the Ethernet card 
	    to be set, as both the virtual router will be having their seperate Virtual MAC addresses.
If NO
	1. Do we need to set the Ethernet card in the promiscuous mode to accept all the packets and filter out depending 
	    on the Virtual MAC address.
	2. Only the packets with the destination link MAC address as the Virtual address need to be picked by the VRRPd 
	    other packets with the physical MAC address or any other MAC address will be handled the same way as they 
       	   were previuosly when no VRRPd was running.

Thanks in advance
Rajnish

---

From: "Aruneesh Salhotra" <[email-masked]>
Date: Mon, 20 Nov 2000 16:25:59 +0530

Hi Rajnish
There is no activity on the ethernet card, and no physical modifications are
made.
When the VRRP is up on a running router, the router responds back to ARP
request for the VRRP IP with the VRRP MAC address.
Whenever a source router wants to send a packet to a machine on its local
LAN, it sends a IP ARP to obtain the MAC address of that machine. In this
case, it will receive the VRRP MAC.
I presume as suggested by you that the ethernet card would be working in the
promiscous mode, but i cant guarantee that it true at all.
Aruneesh
Nortel Networks

----- Original Message -----
From: "Rajnish Madan" <[email-masked]>
To: <[email-masked]>
Sent: Monday, November 20, 2000 9:12 PM
Subject: Vrrp Query.

> 2. In case a Router is acting as master for two (the virtual routers),
which virtual MAC address the Ethernet card

---

From: Sumandra Majee <[email-masked]>
Date: Mon, 20 Nov 2000 12:01:17 -0800

>Does this mean that the hardware address of the Ethernet card to be 

In the implementation I know of the ethernet address is indeed changed to 
the virtual MAC. There are variant of VRRP where the card is
essentially in promiscuous mode.

>         2. In case a Router is acting as master for two (the virtual 
> routers), which virtual MAC address the Ethernet card
>         1. Do we need to set the Ethernet card in the promiscuous mode to 
> accept all the packets and filter out depending
>         2. Only the packets with the destination link MAC address as the 
> Virtual address need to be picked by the VRRPd
>             other packets with the physical MAC address or any other MAC 
> address will be handled the same way as they