Subject: Skew_Time

From: Amnon Even-zohar <[email-masked]>
Date: Thu, 23 Nov 2000 15:38:36 +0200

Hi !
Can Anyone explain to me what is the meaning of the term Skew_Time ? .
I saw how it's computed but I don't understand what it is udes for.

Thanks in advance,

Amnon Even Zohar
Atidim Technological Park, Bldg.4
Tel-Aviv 61131, Israel
Tel:    972-3-645-8595
Fax:  972-3-648-7368
E-mail: [email-masked]

---

From: Yaron Presente <[email-masked]>
Date: Thu, 23 Nov 2000 17:00:45 +0200

Hi Amnon,
A Backup router decides that it has to move to Master state in case that
it didn't get any advertisements for a Master_Down_Interval period. if
this interval had been a constant value, then theoretically all backup
routers would try to move to Master state on the same time, and we would
get a longer period of unstabilized LAN.
However, by adding a variable period of time (the Skew time is a value
between 0 and 1 second), a higher priority Backup router (which has a
smaller skew time according to the formula in the RFC) would change state
into Master before a lower one. if the differences in the Backup routers
priorities are configured properly, there is a good chance that the lower
priority backup router would get the new Master's advertisement before
his timer fires.
Hope it made a little sense,
yaron

--
==============================================
Yaron Presente
Optical Access (http://www.opticalaccess.com/)
E-mail:  [email-masked]
Phone:   +972-4-9936237
Fax:     +972-4-9890564
==============================================
www.net2linux.com:
Helping You Master Tomorrow's Open Source Networking Technology Today.