Subject: RE: A VRRP Scenario

From: "Adnan Onart" <[email-masked]>
Date: Sun, 19 Nov 2000 10:56:38 -0800

Bob,

1) Doesn't this depend also on the value of pre-emption flag?
2) Although there is nothing wrong with Ammon's example, isn't advisable to
"spread out"
	priority numbers to avoid unintended race conditions?

Clarifications are appreciated.

Best regards,

Adnan

-----Original Message-----
From: Bob Hinden [mailto:[email-masked]]
Sent: Sunday, November 19, 2000 12:26 PM
To: Amnon Even-zohar
Cc: 'Vrrp mailing list'
Subject: Re: A VRRP Scenario

Amnon,

In your example if the "original master" had a higher priority than 100, it 
would be come master again.  It does not remember it used to be the 
original master.

Bob

At 04:45 PM 11/19/2000 +0200, Amnon Even-zohar wrote:
>Hi !
>Suppose a virtual router is configured with more then one backUp.Since 
>none of the VRRP routers is the IP Address owner ,none of them has a 
>priority of 255 but any other value.Lets say  they own a consecutive 
>priority.(like 100,101,102).
>Now the master is down.The router with priority 100 is declared as the 
>master.After a while the original master is up again.
>
>My question :  With what priority will the original master send its 
>advertisment ?.Why ?
>                   Does it remember it used to be the original master ?.If 
> so. how ?

---

From: Bob Hinden <[email-masked]>
Date: Sun, 19 Nov 2000 11:25:12 -0800

Adnan,

>1) Doesn't this depend also on the value of pre-emption flag?

Yes.

>2) Although there is nothing wrong with Ammon's example, isn't advisable 
>to "spread out"

The finite state machine in the protocol doesn't care.  To avoid 
configuration errors it is a good idea.

Bob

---

From: "Aruneesh Salhotra" <[email-masked]>
Date: Mon, 20 Nov 2000 12:36:06 +0530

Hi Amnon,
Ya, it would be a good idea if you send your questions, and i can answer
them, taking one at a time.
Regarding the priorities, it really does not matter what the priority of a
particular router is. The important factor is the time period in which a
router has to receive VRRP adevrtisments from a VRRP router (acting as
Master), and its own priority.
Suppose the master goes down, that means, it wont be able to send any VRRP
advertisments. Now, the FSM of the backup VRRP routers, will time out not
receiving any VRRP advertisments, and thus feel that there are no other
routers in picture, and will send VRRP advertisments. Now if a particular
time goes by, and it receives no VRRP advertisments from any other VRRP
router, it will take on the responsibility of the master VRRP router.
It is similar to saying, who takes it first, obviously on basis of VRRP
priority.
Please feel absolutely free to ask.
Cheers
Aruneesh

----- Original Message -----
From: "Amnon Even-zohar" <[email-masked]>
To: "Salhotra, Arunesh " <[email-masked]>
Sent: Monday, November 20, 2000 12:24 PM
Subject: RE: A VRRP Scenario

> Hi Aruneesh !
> In the scenario I described ,I specificaly wrote that none of the VRRP
routers has a priority of 255.Eventhough , u said that (and I quote) :
> "..When the original VRRP Master router (priority 255)
> comes up again...".Why priority 255 ? Why not priority 102 like it was
confgiured originally ?.
>
> P.S - I have some more questions I gathered during my learning of the
VRRP.
> Will it be Ok if I'll send u them summerized so u can inspect and answer
them ?
> Thanks a lot,
> Amnon Even Zohar
> Atidim Technological Park, Bldg.4
> Tel-Aviv 61131, Israel
> Tel:    972-3-645-8595
> Fax:  972-3-648-7368
> E-mail: [email-masked]
>
>
>
>
>
> From: Aruneesh Salhotra [mailto:[email-masked]]
> Sent: Monday, November 20, 2000 6:33 AM
> To: Amnon Even-zohar; 'Vrrp mailing list'
> Hi Amnon
> The scenario you have described in your query is a basic example of VRRP
in
> action.
> When the master is up, it keeps sending VRRP advertisments declaring its
> priority. Every VRRP router, listens to the advertisments, and whenever
one
> detects that it hasnt received a VRRP advertisments in a configurabe time
> period, it starts sending adevertisments. No VRRP router remembers the
> status of the router at any point of time. The only FSM it maintains is
the
> last VRRP operation, slave or master.
> Now when the router with priority 102 becomes the master router, it is in
> control of VRRP IP. When the original VRRP Master router (priority 255)
> comes up again, it sends a VRRP advertisment, and takes on the VRRP master
> router.
> If you have any more questions in this respect, please do let me know.
> Aruneesh
> Nortel Networks
>
> ----- Original Message -----
> From: "Amnon Even-zohar" <[email-masked]>
> To: "'Vrrp mailing list'" <[email-masked]>
> Sent: Sunday, November 19, 2000 8:15 PM
> Subject: A VRRP Scenario
>
>
> > Hi !
> >           Does it remember it used to be the original master ?.If so.
how
> ?
> >
> > 10x for your time,
> > Regards,
> >
> > Amnon Even Zohar
> > Atidim Technological Park, Bldg.4
> > Tel-Aviv 61131, Israel
> > Tel:    972-3-645-8595
> > Fax:  972-3-648-7368
> > E-mail: [email-masked]
> >
> >
> >
> >
>