Subject: RE: [VRRP] Diffs for the drafts

From: Radia Perlman - Boston Center for Networking <[email-masked]>
Date: Fri, 23 May 2003 14:52:03 -0400

Seems convincing for today's technology, but might
it be worthwhile to allow more granularity in case
there's some much faster technology that this would
be deployed on in the future? Since this would
be an incompatible change, it probably isn't worth it,
but maybe for the IPv6 draft?

Radia

"Bob Hinden" <[email-masked]> wrote:
>Esa,
>
>At 10:35 PM 5/22/2003, [email-masked] wrote:
>>Hi ,
>>
>>  I've been wondering why the Advertisement_interval is in  seconds and 
>> default as 1.
>>  How can smaller than one (1) second Advertisement_interval be
>>  specified, in order to reach smaller than 3 sec. switch over time?
>>
>>Should the granularity of Advertisement_interval be e.g.
>>100ms, with 8-bit field we still get max 25 sec interval if
>>somebody needs that long interval. Smaller than 100ms
>>granularity would be preffered.
>
>The defaults of the 1 second advertisement and 3 second switch over was 
>picked to make sure the switch over mechanism was stable and to have the 
>switch over happen before TCP connections would break.  Three seconds is 
>not noticeable to most users.
>
>The reason for a one second advertisement interval instead of one in the 
>millisecond range, was to insure that the switch over mechanism was 
>stable.  Going to 100ms (or below) would increase the likelihood that the 
>switch over would occur due to congestion on the LAN, large queues of 
>packets on routers interface, or excessive processor load on one of the 
>routers, instead of a real failure of the master router.   In general 
>having reliability mechanisms that are not stable isn't a good thing.
>
>Bob
>
>
>
>_______________________________________________
>vrrp mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/vrrp

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: Bob Hinden <[email-masked]>
Date: Fri, 23 May 2003 12:08:35 -0700

Radia,

>but maybe for the IPv6 draft?

I agree it would be too big an incompatible change for the IPv4 version and 
makes sense to discuss for the IPv6 version.

I suggest that the folks proposing the change explain why it would be 
beneficial and show that it isn't harmful.  The current design seems to work.

Bob