Subject: Re: [VRRP] Re: comments on vrrp-ipv6-spec-04.txt

From: [email-masked]
Date: Thu, 29 May 2003 22:05:06 -0700

--- Gurudeep Kamat <[email-masked]> wrote:
> Thus, breaking the understanding that if backups have
> equal priorities, then the backup with the higher
> interface IP will become the Master.

this statement doesn't match my understanding of the
protocol.  if the administrator has setup two backup
routers with the same priority then there has not been
any preference expressed for routerA or routerB.  all 
that the protocol deterministically guarantees is that 
the Master is always from the set of available vrrp routers 
with highest priority (assuming the 'no-preempt' flag
is not in effect).  the ip address tie breaker is purely 
to eliminate the pathological case described in radia
last email that could lead to non-convergence.  if the
administrator really has a preference that the vrrp Master
deterministically converge to routerA over routerB then
this is done trivially by setting routerA priority
higher than routerB.

danny
_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: Gurudeep Kamat <[email-masked]>
Date: Fri, 30 May 2003 01:07:55 -0700 (PDT)

Hi Danny,

Thanks for the clarification. However, it is a simple
one line change and I believe can be considered
atleast for the Ipv6 version. The protocol then
presents a consistent behavior.. assuming everything
is configured properly, the router with the highest
priority is the Master or if the priorities are equal,
then the router with the highest IP address becomes
the Master (in both cases assuming that 'no-preempt'
is not enabled)

Regards,
Gurudeep

> this is done trivially by setting routerA priority

__________________________________
Do you Yahoo!?
Yahoo! Calendar - Free online calendar with sync to Outlook(TM).
http://calendar.yahoo.com
_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp