Subject: [VRRP] comments, questions, on vrrp-spec-v2-07.txt

From: Radia Perlman - Boston Center for Networking <[email-masked]>
Date: Sat, 24 May 2003 22:09:15 -0400

1) Section 2.3...the conflicting goals of determinism vs
minimizing disruptions...

The mechanism seems to be, based on section 6.1, that
there is a parameter private to each VRRP router, and
not passed in protocol messages. Unless I'm confused,
this seems dangerous. If you have higher priority
than me and you think you should preempt, and I have
lower priority and I think people shouldn't preempt,
wouldn't this wind up with two masters?

A way of doing this that is backward compatible is what
was done in NLSP for DR election. (NLSP is IS-IS
for IPX, but with some improvements like what I'm
about to mention). The exact thing NLSP did was have routers
add 20 to their priority once they were DR for a minute.
This, it turns out, gives all the functionality one
could want...one can configure things to be deterministic
or disruption-minimizing, or anything in between, such
as having a set of most preferred routers that, if any
of those are up, would preempt from less preferred, but
they wouldn't preempt from each other..But I'd think it
would be confusing to people to know how to set priorities
to get the desired behavior. So alternatives are to
use the Preempt-Mode flag to indicate whether 20 ought
to be added to the priority, or change Preempt-Mode to
be "master-increment", which is what to add to your
priority if you have been master for some time (like
a minute).

2) I still don't understand why VRRP allows multiple IP
addresses per VRID. Given that there's only a single
MAC address per VRID, you wouldn't get load splitting
by using multiple IP addresses. And having multiple
IP addresses gives another opportunity for misconfiguration.

I believe there's another possibility of multiple master
election here. If the owner of the IP address is dead, so
there are two routers advertising priority < 255, and
they have different sets of IP addresses, I believe they
will ignore each other's messages and both believe
they are that VRID.

3) minor typos...page 23, paragraph starting "Due to these..."
line 7 has the word "addresses" duplicated

page 24, paragraph starting "Additionally, routers MAY...",
3rd to last line "need have to"...remove "have"

section 10, "do to" should be "due to" on lines 5 and 7

Radia

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: danny mitzel <[email-masked]>
Date: Tue, 27 May 2003 11:55:29 -0700 (PDT)

--- Radia Perlman - Boston Center for Networking
<[email-masked]> wrote:

> Unless I'm confused,

the message processing rules converge election to
the vrrp router sending out advertisement with 
highest priority.  the effect of a misconfiguration
on the higher priority router not setting
'no_preempt' is that the router does preempt.

I think the dynamic priority scheme described may
be worth some consideration.  but from user
perspective I think it takes a bit more effort to
understand and is at least as configuration error
prone as the current flag.

danny

__________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com
_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp