Subject: [VRRP] Diffs for the drafts

From: [email-masked]
Date: Wed, 21 May 2003 14:56:05 -0500

Folks,

The new drafts for VRRPv2 and VRRPv3 have been submitted. The major change is that we have removed the security from both the drafts. Please review the drafts. I will soon issue a last call for draft-ietf-vrrp-spec-v2-07.txt if I don't hear any comments.

Just to facilitate the review process, I am attaching the html version of the diffs between the old drafts and the new drafts. People who don't have time can at least review the changes using these html files.

Thanks !!

- Mukesh

---

From: [email-masked]
Date: Fri, 23 May 2003 08:35:07 +0300

Hi ,
 
 I've been wondering why the Advertisement_interval is in  seconds and default as 1.
 How can smaller than one (1) second Advertisement_interval be 
 specified, in order to reach smaller than 3 sec. switch over time?

Should the granularity of Advertisement_interval be e.g. 
100ms, with 8-bit field we still get max 25 sec interval if 
somebody needs that long interval. Smaller than 100ms 
granularity would be preffered.

br esa

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: 21 May, 2003 22:56
> To: [email-masked]
> Subject: [VRRP] Diffs for the drafts
> 
> 
> Folks,
> 
> The new drafts for VRRPv2 and VRRPv3 have been submitted. The 
> major change is that we have removed the security from both 
> the drafts. Please review the drafts. I will soon issue a 
> last call for draft-ietf-vrrp-spec-v2-07.txt if I don't hear 
> any comments.
> 
> Just to facilitate the review process, I am attaching the 
> html version of the diffs between the old drafts and the new 
> drafts. People who don't have time can at least review the 
> changes using these html files.
> 
> Thanks !!
> 
> - Mukesh
> 
_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: Bob Hinden <[email-masked]>
Date: Fri, 23 May 2003 10:53:58 -0700

Esa,

>granularity would be preffered.

The defaults of the 1 second advertisement and 3 second switch over was 
picked to make sure the switch over mechanism was stable and to have the 
switch over happen before TCP connections would break.  Three seconds is 
not noticeable to most users.

The reason for a one second advertisement interval instead of one in the 
millisecond range, was to insure that the switch over mechanism was 
stable.  Going to 100ms (or below) would increase the likelihood that the 
switch over would occur due to congestion on the LAN, large queues of 
packets on routers interface, or excessive processor load on one of the 
routers, instead of a real failure of the master router.   In general 
having reliability mechanisms that are not stable isn't a good thing.

Bob

---

From: Mathur Sonum-CSM109 <[email-masked]>
Date: Fri, 23 May 2003 13:51:47 -0500

We have been dealing with milli seconds granularity for Advert Interval. The
only problem with this is - we cannot check for wrongly configured routers
with milliseconds granularity. This is because the receiving router will
match the locally configured value with the one specified in Advert
Interval. Right now, even if we configure a router to some milliseconds (say
300 msecs), we send out the truncated value (0). So receiving router will be
ok with any value from 0 msec to 999 msecs.

We can use one of the bits in the reserved field, which can indicate that
the time specified in Advert Interval is multipe of 1 second or 100
milliseconds. That way, we can have configurations with milli seconds range
from 100 to 1000 milliseconds or the existing range in seconds.

--
Sonum

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, May 22, 2003 10:35 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [VRRP] Diffs for the drafts

Hi ,
 
 I've been wondering why the Advertisement_interval is in  seconds and
default as 1.
 How can smaller than one (1) second Advertisement_interval be 
 specified, in order to reach smaller than 3 sec. switch over time?

br esa

---

From: [email-masked]
Date: Mon, 26 May 2003 09:28:13 +0300

Hi Bob,

the need for subsecond convergence time in VRRP does not come from TCP traffic but from
"realtime" traffic like voice.
3 sec cut in voice is not catastrophic, but at least annoying.
Traditional voice signaling (ss7) applications do not like long (i.e. 800ms) breaks, if we want to run those application (unmodified) over IP/Ethernet, something should be done.

As pointed out VRRP for IPv4 should stay as is, but for IPv6 there should be away to reduce the convergence time. Should the some of the reserved bits used to indicate the granularity?

br esa

> From: ext Bob Hinden [mailto:[email-masked]]
> Sent: 23 May, 2003 22:09
> To: [email-masked]
> Cc: [email-masked]
> Radia,
> At 11:52 AM 5/23/2003, Radia Perlman - Boston Center for 
> Networking wrote:
> >Seems convincing for today's technology, but might
> >it be worthwhile to allow more granularity in case
> >there's some much faster technology that this would
> >be deployed on in the future? Since this would
> >be an incompatible change, it probably isn't worth it,
> >but maybe for the IPv6 draft?
> 
> I agree it would be too big an incompatible change for the 
> IPv4 version and 
> makes sense to discuss for the IPv6 version.
> 
> I suggest that the folks proposing the change explain why it would be 
> beneficial and show that it isn't harmful.  The current 
> design seems to work.
> 
> Bob
>