Subject: [VRRP] Granularity of Advertisement_interval

From: [email-masked]
Date: Thu, 22 May 2003 16:54:43 -0500

Anyone has any comments on what Esa says ??

-----Original Message-----
From: Sarkama Esa (NET/Espoo) 
Sent: Wednesday, May 21, 2003 10:38 PM
To: Gupta Mukesh (IPRG/MtView)
Subject: RE: [VRRP] Diffs for the drafts

Hi Mukesh,

I've been wondering why the Advertisement_interval is in seconds and default as 1.
How can smaller than one (1) second Advertisement_interval be specified, in order to reach smaller than 3 sec. switch over time?

Should the granularity of Advertisement_interval be e.g. 100ms, with 8-bit field we still get max 25 sec interval if somebody needs that long interval. Smaller than 100ms granularity would be preffered.

br esa

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: 21 May, 2003 22:56
> To: [email-masked]
> Subject: [VRRP] Diffs for the drafts
> 
> 
> Folks,
> 
> The new drafts for VRRPv2 and VRRPv3 have been submitted. The 
> major change is that we have removed the security from both 
> the drafts. Please review the drafts. I will soon issue a 
> last call for draft-ietf-vrrp-spec-v2-07.txt if I don't hear 
> any comments.
> 
> Just to facilitate the review process, I am attaching the 
> html version of the diffs between the old drafts and the new 
> drafts. People who don't have time can at least review the 
> changes using these html files.
> 
> Thanks !!
> 
> - Mukesh
> 
_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: Vikram Pendharkar <[email-masked]>
Date: Fri, 23 May 2003 14:03:27 -0400

While minimizing the failover time is definitely desirable I see two 
issues here:

1) VRRP may be deployed for VLAN interfaces configured over 
GigabitEthernet interfaces. Numbers for edge-routers could potentially 
be in range of ~8K VLANS per GigE interface. What am driving at is that 
at these numbers the amount of VRRP traffic from the board processor to 
control processor at 1 sec adver_intervals itself could cause 
scalability issues.

2) The total failover time is a sum of 3*adver_interval and time needed 
to synchronize the state of master with backup.
 Depending on whether the interface belongs to a host or to an 
edge-router and how easy/difficult is it to synchronize state, the 
latter could be a non-trivial value. Point is, failover time is not just 
a function of advertisement_interval.

So in summary, the problem is how to minimize failover time. Having a 
finer granularity is one way but the solution potentially introduces a 
lot of scalability issues for solutions deployed over say gigabit-class 
edge-aggregation routers.
So it should be analyzed if a finer granularity is really needed and how 
trivial would the scalbility problem be in that case before proceeding 
ahead.

- Vikram

-- 
Vikram Pendharkar			
Ericsson IP Infrastructure