Subject: [VRRP] OK. What's with the IPv6 mib draft?

From: Radia Perlman - Boston Center for Networking <[email-masked]>
Date: Sun, 15 Jun 2003 21:26:35 -0400

I'm jumping in new here and I'm keeping up with
the regular drafts, but I don't see any email
about the IPv6 mib (And Mukesh is out of town).

Apparently we are past due on the milestone for
that draft (ipv6 mib). Who is working on it? What state
is it in?

Speaking of which...I'm not quite sure why WGs have
two documents...one for IPv6 and one for IPv4.
Wouldn't there be cases where IPv6 and IPv4 were
coexisting on the same LAN, so therefore there might
be routers performing VRRP for both IPv6 and IPv4
simultaneously? I'd think it would be easier for
an implementer if there were one spec, that told
you how to do both simultaneously, since there
also might be some interactions that would have
to be thought about when doing both IPv6 and IPv4
simultaneously.

Thanks...

Radia

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: [email-masked]
Date: Mon, 16 Jun 2003 11:13:23 -0700

There has been some work going on for the VRRP V6 MIB in background. The intention was to post it to the Mailing List soon. But, we've all been pretty busy, so I think the draft has fallen a little behind. 

Here's the list of authors:

[email-masked];  [email-masked]; [email-masked];

Thanks.

-Brian

-----Original Message-----
From: Radia Perlman - Boston Center for Networking
[mailto:[email-masked]]
Sent: Sunday, June 15, 2003 6:27 PM
To: [email-masked]
Subject: [VRRP] OK. What's with the IPv6 mib draft?

Thanks...

Radia

---

From: [email-masked]
Date: Mon, 16 Jun 2003 12:07:06 -0700

hi Radia,
	Brian Jewell, Karlekar Kripakaran  and myself are working on this draft.
	The draft is almost ready except for some minor corrections and formatting 
	issues. We are working on this and should be ready in a week.
	We are expected to submit this by june 26th (that is the date given by Mukesh).
	
	On the question of why we need two documents, We did investigate the possibility
	of having one VRRP MIB that would work with both VRRP over IPv4 and IPv6.
	
	From what we understood from RFC 3291, MIB modules that are inherently IP version 
	specific should be separate documents. We verified this with Bob Hinden and he 
	confirmed that VRRPv2 is dependant on IPv4 and VRRPv3 is dependant on IPv6 and 
	that these are two separate (though similar) protocols. 

	I also talked to some VRRP protocol developers regarding the
	implementation of VRRPv6, and they too seem to agree that VRRP over IPv6
	and the corresponding MIB should be separate from the existing protocol/
	MIB.

	So our agenda was:
	Defining a completely new MIB for VRRP-IPv6 (which is to a 
	large extent similar to RFC 2787)
	- which uses inetAddress / inetAddressType,
	- Add any new objects that IPv6 specific,
	- Remove any objects that are not relevant to IPv6 (there are some)
	- Add more clarifications to the existing objects if needed.

Thanks
kalyan

-----Original Message-----
From: ext Radia Perlman - Boston Center for Networking
[mailto:[email-masked]]
Sent: 15 June, 2003 18:27
To: [email-masked]
Subject: [VRRP] OK. What's with the IPv6 mib draft?

Thanks...

Radia

---

From: [email-masked]
Date: Mon, 16 Jun 2003 12:17:39 -0700

hi, the due date is June 23rd not 26 as I mentioned in my previous mail.
thanks
kalyan

-----Original Message-----
From: Tata Kalyan (NIC/MtView) 
Sent: 16 June, 2003 12:07
To: [email-masked]'; [email-masked]
Cc: Karlekar Kripakaran (NIC/MtView); [email-masked]'
Subject: RE: [VRRP] OK. What's with the IPv6 mib draft?

hi Radia,

	So our agenda was:

Thanks
kalyan

-----Original Message-----

Thanks...

Radia