Subject: Re: [VRRP] Query on Associated IP address and Primary IP address

From: Radia Perlman - Boston Center for Networking <[email-masked]>
Date: Tue, 22 Jul 2003 16:35:26 -0400 (EDT)

Multiple IP addresses is something that confuses me in VRRP.
Danny says below that "in typical deployments it's just
a single address, but it becomes a set of addresses
when alias/multinetting is deployed".

What functionality does "alias/multinetting" give over having
a single IP address for the routers?

I could imagine wanting two router IP addresses for
path splitting, but then I'd think you'd want two VRIDs,
so two different routers would be elected, one for each
VRID (and each VRID would be a different IP address).

But I can't think of an advantage of having multiple IP
addresses for a single VRID. If there isn't any advantage,
then perhaps it would be nice in the spec to strongly suggest
that only a single IP address be used, and in the VRRP for IPv6
spec perhaps simplify the protocol by only allowing one?

Thanks,

Radia

	From: [email-masked]

	--- Gunaseelan V <[email-masked]> wrote:
	
	> 1) What are the Associated IP addresses?
	> is it the multiple IP addresses assigned to the same
	> Physical Interface (means alias or multinetting) or doe 
	> sit belong to diff physical interfaces of a Virtual Router
	
	it's all addresses on the interface running vrrp
	that are backed up using same vrid.
	typical deployments I've seen this is just a single
	address, but it becomes a set of addresses when
	alias/multinetting is deployed.

	> 2) What is Primary IP address?
	> Is it one of the associated IP addresses within a
	> router selected based on
	> the some algorithm (say first one or least one etc)
	
	you're correct that it's one of the associated ip addresses.
	the selection algorithm is vendor specific
	(explicitly tagged 'primary' address, first added,
	lowest numbered, etc.).  the protocol specification
	just mandates whatever address is picked as the
	primary is also placed in the ip source address of
	any Advertisement.  this ensures proper convergence
	if the master election tie breaker based on primary 
	ip address comes into play.

	> 3)I understood the concept of switchover from Master
	> to Back up on Failure/Master Down timer event etc, but
	> how the router which is on the other side (say WAN) 
	> knows about route to Hosts governed by VRRP?
	> 
	> Here the Back up router once becomes the Master will
	> forward the IP packets,
	> if so does this router propagates on WAN Side thru
	> any routing protocol
	> about the Hosts reachability on the LAN side.
	> If Yes When it should start propagating (only after
	> becoming the Master or even during Back Up)
	
	the protocol specification makes no recommendations
	or requirements on the routing infrastructure when
	a dynamic routing protocol is used to advertise
	reachability to the vrrp backed up LAN.  in the
	simplest case all of the vrrp routers advertise
	reachability.  this may result in asymmetric forwarding,
	but that's not too uncommon in the current Internet 
	routing architecture.  if a vendor&customers desires
	to force symmetric forwarding path then they could 
	tie reachability advertisement to vrrp master status,
	as you describe above, and market that as 'value added'/
	differentiating feature of their product.

	danny

	_______________________________________________
	vrrp mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/vrrp

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: danny mitzel <[email-masked]>
Date: Tue, 22 Jul 2003 14:24:32 -0700 (PDT)

--- Radia Perlman - Boston Center for Networking
<[email-masked]> wrote:

> What functionality does "alias/multinetting" give
> over having a single IP address for the routers?

I've never conducted any type of network manager
survey on why anyone deploys alias/multinetting.
maybe their network started as multiple segments
each with different ip subnet and over time they
collapsed it into one jumbo switched ethernet and
didn't want to have to renumber hosts, OR they
needed more than 255 hosts on a segment and only
had some non-aggregatable/non-contiguous class C
address ranges OR as you suggested maybe some
type of traffic splitting based on ip subnet, OR ...?

the one thing I do know is that products I've
worked on seem to have alias/multinetting support
in the list of requirements and pretty much every
router product does support alias/multinetting.
so I'm assuming someone out there is finding
that feature of use for some purpose.  then
within the working group there was some desire
expressed to support this alias/multinetting
while minimizing number of virtual routers that
must be configured and minimizing packet send/
receive and protocol processing overhead.
which lead to the current design.

danny

__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
http://sitebuilder.yahoo.com

---

From: "Gunaseelan V" <[email-masked]>
Date: Fri, 25 Jul 2003 12:42:53 +0530

Hi Radia and Danny
In the same thread I wish to bring up my findings, like I found an
implementation where the Associated IP addresses are configured with the
values of IP address pertaining to the Back up routers' interface IP
addresses. Though the Alias or multinetting are not getting supported in
that implementation . Am not sure whether this is what being globally
followed, Also I find there is a Specific Configuration for Primary IP
address and this is used to determine the Master, is this a config parameter
or an learned one.

In the former case , the need of IP address info of Back up routers ,I feel
for an election process of Master form pool of Backup routers, if Priority
happens to be same on all then the tie breaker with IP address should take
place. For this to happen the back up routers should know about the Ip
address of others, is this need Justified or commonly followed .

If you can throw some light on this that would be helpful.

Wish to Thank you very much for all your efforts in clarifying my doubts
earlier

Best Regards
Gunaseelan V

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Radia
Perlman - Boston Center for Networking
Sent: Wednesday, 23 July 2003 2:05 AM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [VRRP] Query on Associated IP address and Primary IP
address

Thanks,

Radia

	From: [email-masked]

	danny

***************************************************************************
This message is proprietary to Future Software Limited (FSL) 
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information 
and should not be circulated or used for any purpose other than for 
what it is intended. 

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. 
FSL accepts no responsibility for loss or damage arising from 
the use of the information transmitted by this email including
damage from virus.
***************************************************************************