Subject: RE: [VRRP] Query on Associated IP address and Primary IP address

From: "Gunaseelan V" <[email-masked]>
Date: Fri, 18 Jul 2003 18:49:49 +0530

Hi
Thanks you very much for the answers and it cleared the basics for me, also
I wish to put forth few more queries in the same line

1) Does the Back up router disable IP forwarding ?
      If Yes , is it totally on the i/f where VRRP is enabled or only
Selectively like not forwarding the frames which has Virtual MAC Address .
In the second case can Backup respond to Pings from hosts to its Primary IP
address

2) In case of switch over from Master to Back up, how Backup will come to
know about the IP address it should take care of (like how Backup will
handle the IP packets not destined to its Primary IP address, here though it
may be an implementation dependent, am wondering whether the new IP will
ever be registered by VRRP module in its IP ,)

Sorry for the disturbance caused

Best Regards
Gunaseelan V

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of [email-masked]
Sent: Friday, 18 July 2003 12:54 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [VRRP] Query on Associated IP address and Primary IP
address

--- Gunaseelan V <[email-masked]> wrote:

> 1) What are the Associated IP addresses?
> is it the multiple IP addresses assigned to the same
> Physical Interface (means alias or multinetting) or doe
> sit belong to diff physical interfaces of a Virtual Router

it's all addresses on the interface running vrrp
that are backed up using same vrid.
typical deployments I've seen this is just a single
address, but it becomes a set of addresses when
alias/multinetting is deployed.

> 2) What is Primary IP address?
> Is it one of the associated IP addresses within a
> router selected based on
> the some algorithm (say first one or least one etc)

you're correct that it's one of the associated ip addresses.
the selection algorithm is vendor specific
(explicitly tagged 'primary' address, first added,
lowest numbered, etc.).  the protocol specification
just mandates whatever address is picked as the
primary is also placed in the ip source address of
any Advertisement.  this ensures proper convergence
if the master election tie breaker based on primary
ip address comes into play.

> 3)I understood the concept of switchover from Master
> to Back up on Failure/Master Down timer event etc, but
> how the router which is on the other side (say WAN)
> knows about route to Hosts governed by VRRP?
>
> Here the Back up router once becomes the Master will
> forward the IP packets,
> if so does this router propagates on WAN Side thru
> any routing protocol
> about the Hosts reachability on the LAN side.
> If Yes When it should start propagating (only after
> becoming the Master or even during Back Up)

the protocol specification makes no recommendations
or requirements on the routing infrastructure when
a dynamic routing protocol is used to advertise
reachability to the vrrp backed up LAN.  in the
simplest case all of the vrrp routers advertise
reachability.  this may result in asymmetric forwarding,
but that's not too uncommon in the current Internet
routing architecture.  if a vendor&customers desires
to force symmetric forwarding path then they could
tie reachability advertisement to vrrp master status,
as you describe above, and market that as 'value added'/
differentiating feature of their product.

danny

**********************************************************************
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the system manager.

This footnote also confirms that this email message has been swept by
MIMEsweeper for the presence of computer viruses.

www.mimesweeper.com
**********************************************************************

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: danny mitzel <[email-masked]>
Date: Fri, 18 Jul 2003 16:01:03 -0700 (PDT)

--- Gunaseelan V <[email-masked]> wrote:

>    If Yes , is it totally on the i/f where VRRP
>    is enabled or only Selectively like not
forwarding 
>    the frames which has Virtual MAC Address .

typically no need to disable any forwarding.  
if router is in vrrp backup role then it should not 
have the VMAC programmed into NIC so it won't see
any of the packets destined to the vrrp master.
if for some reason an implementation does have the
NIC programmed to accept VMAC even while in vrrp
backup then it would need to filter out those 
packets or else it would trigger duplicates.

> In the second case can Backup respond to Pings from
> hosts to its Primary IP address

the 'primary ip address' of a router is always 'owned'
by the router when it is up&running so it should 
definitely respond to pings or any other requests
directed to that address.

> 2) In case of switch over from Master to Back up,
> how Backup will come to know about the IP address 
> it should take care of (like how Backup will
> handle the IP packets not destined to its Primary IP
> address, here though it may be an implementation 
> dependent, am wondering whether the new IP will

the router learns the list of ip address to backup
as part of the VR configuration process.  when a
backup transitions to vrrp master state for a VR
then it assumes arp response and data forwarding
responsibilities for those 'adopted' address.
however it will not respond to any pings or other
requests directed to those 'adtoped' address.

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

---

From: "Gunaseelan V" <[email-masked]>
Date: Mon, 21 Jul 2003 18:17:47 +0530

Hi
Thanks for the response and the efforts, it gave a good concept of VRRP.

Thanks

Best Regards
Gunaseelan V

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of danny
mitzel
Sent: Saturday, 19 July 2003 4:31 AM
To: [email-masked]; [email-masked]
Subject: RE: [VRRP] Query on Associated IP address and Primary IP
address

forwarding 

***************************************************************************
This message is proprietary to Future Software Limited (FSL) 
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information 
and should not be circulated or used for any purpose other than for 
what it is intended. 

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. 
FSL accepts no responsibility for loss or damage arising from 
the use of the information transmitted by this email including
damage from virus.
***************************************************************************

---

From: [email-masked]
Date: Thu, 17 Jul 2003 12:23:50 -0700

danny