Subject: RE: [VRRP] Separate MIBs or Unified MIB

From: [email-masked]
Date: Sat, 29 Nov 2003 14:54:51 -0600

Yasu,

VRID can be used as an unique identifier. A router can
run both VRRPv2 and VRRPv3 at the same time but it can't
use the same VRID for both.

So given an interface index and a VRID, you can identify
if the protocol running is VRRPv2 or VRRPv3.

Regards
Mukesh

> -----Original Message-----
> From: ext Yasuhiro Ohara [mailto:[email-masked]]
> Sent: Saturday, November 29, 2003 11:49 AM
> To: Gupta Mukesh (IPRG/MtView)
> Cc: [email-masked]
> Subject: Re: [VRRP] Separate MIBs or Unified MIB
> 
> 
> 
> Just curious, how one can retrieve specific protocol's data
> (either VRRPv2 or VRRPv3) when both enabled on the target router ?
> 
> If vrrp version will be included in the object name (i.e.
> "One MIB" just means that the document is one, MIB datas
> are seperated but mixed in one MIB tree), that will be OK
> but otherwise (e.g. the data retrieved will depend on transport
> protocol family ..., I don't believe you mean this though)
> it will bring operation real hard ...
> 
> regards,
> yasu
> 
> From: [email-masked]
> Subject: [VRRP] Separate MIBs or Unified MIB
> Date: Fri, 28 Nov 2003 22:20:58 -0600
> 
> > Folks,
> > 
> > As you would have read in the meeting minutes, the consensus 
> > of the room in the meeting was to go forward with a unified 
> > MIB for VRRP. (One MIB describing both VRRP for IPv4 and VRRP 
> > for IPv6).
> > 
> > We would like to confirm this on the list.
> > 
> > So please reply and raise your objections if you think that 
> > the separate MIBs will be better than the unified MIB.
> > 
> > If we don't hear anything from anyone within a week, we would 
> > assume that everyone will prefer a unified MIB.
> > 
> > Regards
> > Mukesh
> > 
> > _______________________________________________
> > vrrp mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/vrrp
> 

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: Yasuhiro Ohara <[email-masked]>
Date: Sun, 30 Nov 2003 06:23:15 +0900 (JST)

Why ? I can't understand the problem (of using the same
VRID, say 1, for both VRRPv2 and VRRPv3 running).

I know the VMAC address will be the same. But it doesn't
matter with neither VRRP protocol transaction nor IP packet
forwarding, does it ?
Is it just the specification without any reason ?

Thanks in advance.

regards,
yasu

From: [email-masked]
Subject: RE: [VRRP] Separate MIBs or Unified MIB
Date: Sat, 29 Nov 2003 14:54:51 -0600