Subject: [VRRP] VRRP MIB Question

From: [email-masked]
Date: Fri, 6 Feb 2004 12:12:55 -0800

Hi,
    From a previous email thread, we found out that VRID is not unique across VRRP versions in a multi 
stack (Systems participating in both VRRPv2 and VRRPv3) environment.
Thus ifIndex+VRID cannot be used as index to uniquely identify a VRRP instance in the VRRP 
 MIB tables.
 
We are planning to introduce IP version into the index which will make an entry in VRRP tables 
uniquely identifiable. Another approach would be introduce VRRP version. 
 
We would like to know any views/comments on this.
 
Bert/Dave, I noted down your suggestion during the IETF meeting to change the order of 
indexing from ifIndex-VRID to VRID-ifIndex. 
 
With the introduction of IPversion, I would like to know your views on the following order
IPversion-VRID-ifIndex 
or
VRID-

---

From: [email-masked]
Date: Fri, 6 Feb 2004 13:20:48 -0800

Thanks Dave for the quick response.
 
It would be great if any one with experience managing VRRP routers can share their thoughts on this.
 
Thanks
kalyan

-----Original Message-----
From: ext Dave Thaler [mailto:[email-masked]]
Sent: 06 February, 2004 13:04
To: Tata Kalyan (Nokia-ES/MtView); [email-masked]
Cc: [email-masked]
Subject: RE: VRRP MIB Question

The order should typically take into account a few things:

1)      Is one order significantly easier to implement in a device then another order? 
2)      What order would humans most typically want to see the rows appear in?  (grouped first by IPversion? Or VRID? Or interface?)

3)      Do you expect common management operations to be partial enumerations based on a particular attribute? ("show me all the IPv4 entries" or "show me all the entries for interface X")  If so, the most important one should be first (otherwise the management station must enumerating everything and then filtering itself)

-Dave

From: [email-masked] [ mailto:[email-masked]]
Sent: Friday, February 06, 2004 12:13 PM
To: [email-masked]
Cc: Dave Thaler; [email-masked]
Subject: VRRP MIB Question

Hi,

 MIB tables.

IPversion-VRID-ifIndex 

or

VRID-

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Fri, 6 Feb 2004 23:32:08 +0100

W.r.t. 2) below, pls do also take potential applications into account.
 
And... if you need a different indexing because there are many sorts of applications,
then you can do an other table that has the indexes mapped in another order.

Thanks,
Bert 

-----Original Message-----
From: Dave Thaler [mailto:[email-masked]]
Sent: vrijdag 6 februari 2004 22:04
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: VRRP MIB Question

-Dave

From: [email-masked] [ mailto:[email-masked] <mailto:[email-masked]> ]
Sent: Friday, February 06, 2004 12:13 PM
To: [email-masked]
Cc: Dave Thaler; [email-masked]
Subject: VRRP MIB Question

Hi,

 MIB tables.

IPversion-VRID-ifIndex 

or

VRID-