Subject: [VRRP] [VRRPv3] MAC Address != IPv4 MAC Address

From: Vincent Jardin <[email-masked]>
Date: Thu, 15 Sep 2005 20:10:46 +0200

Hi,

I have been surprised to see that the source MAC address for VRRPv2 and 
VRRPv3 are not the same.  I do not see any good reason. Please could it 
be clarified ?

Virtual Router MAC Address of VRRPv3
  00-00-5E-00-02-{VRID}
versus
  00-00-5E-00-01-{VRID}

It would be more simple to have a same MAC address for the same VRIDs. 
It just requires more ressources to duplicate it.

Thanks,
  Vincent

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: Vincent Jardin <[email-masked]>
Date: Tue, 27 Sep 2005 15:07:05 +0200

Hi all,

just to come-back on my previous email. The main issue with this VRRPv3 
draft and the fact that too much ressources are required is:
  - assume you are doing both VRRPv2 and VRRPv3 on the same physical 
Ethernet Interface ei0,
  - assume that it is for the same VRID = 7.
Then, depending on some implementations it means that ei0 will have 2 
mac addresses:
  - 00-00-5E-00-02-07
  - 00-00-5E-00-01-07

So, for this case you have two exclusif options:
  - either we provide VRRPv2 for the LAN
  - xor either we provide VRRPv3 for the LAN
but you cannot provide both.

We do not have this kind of issue with our implementation, but we double 
the ressources. I was wondering about your experiences with these 2 VMAC 
addresses when you deploy both VRRPv2 and VRRPv3 on a same LAN.

It would be just more simple to have the same MAC address for VRRPv2 and 
VRRPv3.

Regards,
  Vincent

Vincent Jardin wrote:

> Hi,
>
> I have been surprised to see that the source MAC address for VRRPv2 
> and VRRPv3 are not the same.  I do not see any good reason. Please 
> could it be clarified ?
>