Subject: [VRRP] values for VRRP AuthType field

From: Bhargavi Rajaraman <[email-masked]>
Date: Mon, 29 May 2006 16:38:13 +0530

Hi All

RFC 2338 - which is a standards RFC for VRRP has defined values for
authentication type as

0 -  No authentication
1 - Simple text password
2 -  IP Authentication header.

but RFC 2787 which has definitions for all VRRP managed objects has defined
the values for vrrpOperAuthType
 as

1 -  No authentication
2 - Simple text password
3 -  IP Authentication header.

Why is there a conflict between the values specified in RFC 2338 (protocol
RFC) and RFC 2787 (RFC for managed objects). When ethereal is used to
capture and decode packets, it takes the values for AuthType as mentioned in
RFC 2338 .

Thanks
Bhargavi.

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Mon, 29 May 2006 15:55:03 +0200

In principle, when ENUMerated INTEGERs are used in MIB modules,
then we prefer to start the list of enumerations at 1 (and not zero).
So possibly MIB doctor review (or the MIB editor already knew)
has suggested to start at 1. 

If there are good underlying reasons to start at zero, then we
(MIB doctors) tend to accept that (certainly these days). But we
then want some text to the DESCRIPTION clause that explains WHY 
the list starts at zero. Possibly the MIB authors and the WG did
not feel strong that there had to be an exact mapping.

So possibly it would have been OK to map the values from the
protocol (2338) directly onto values in the ENUMerated list.
But since that was not done back when RFC2787 was approved,
I think it is best to live with it. It means you have to add one
to the value in the protocol in order to get to the value in the
MIB and vise versa.

Bert

> -----Original Message-----
> From: Bhargavi Rajaraman
> [mailto:[email-masked]]
> Sent: Monday, May 29, 2006 13:08
> To: [email-masked]
> Subject: [VRRP] values for VRRP AuthType field
> 
> 
> Hi All
>

---

From: "Mukesh Gupta" <[email-masked]>
Date: Mon, 29 May 2006 09:26:38 -0700

Moreover, the whole VRRP authentication mechanism has been obsoleted in
3768 (that obsoletes 2338).  The new values are:

      0 - No Authentication
      1 - Reserved
      2 - Reserved

Regards
Mukesh

> From: Wijnen, Bert (Bert) [mailto:[email-masked]]
> Sent: Monday, May 29, 2006 6:55 AM
> To: Bhargavi Rajaraman; [email-masked]
> Subject: RE: [VRRP] values for VRRP AuthType field
>