Subject: RE: [VRRP] Re: Re: MIB Dr. Review ofdraft-ietf-vrrp-unified-mib-0 5.txt

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Thu, 26 Oct 2006 10:40:23 +0200

RFC4181 is clear about what to do about warnings w.r.t. 
max number of subids in an OID because of INDEX
object that (in theory) can go beyond 128.

See sect 4.6.6 in RFC4181.

And PLEASE DO Keep the specifics in MODULE-COMPLIANCE.
That shows which exact addressTypes and related max lengths
MUST be supported for compliance.

Hope this helps,
Bert

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, October 25, 2006 22:00
> To: [email-masked]; [email-masked]; 
> [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [VRRP] Re: Re: MIB Dr. Review
> ofdraft-ietf-vrrp-unified-mib-05.txt
> 
> 
> Hi Joan,
> I was trying fix the following :
> ===========
> 21)            INDEX    { vrrpOperationsInetAddrType,
> vrrpOperationsVrId,
>                       ifIndex, vrrpAssociatedIpAddr }
> 
> 
> 
>    W: f(VRRP-MIB), (423,8) Row "vrrpAssociatedIpAddrEntry" has
>    indexing that may create variables with more than 128 sub-ids
> 
> The issue here is that the Address (InetAddress) is 0..255 octets,
> but really only need either 4 octets (IPv4 address) or
> 16 octets (IPv6 address).  Please limit the size of this
> using SIZE(0|4|16) (as an example).
> 
> DIFFSERV-MIB (and others) give an
> example of how to limit the size in the conformance (and also
> limit the address type).  This needs to be added to the
> conformance section.
> ===================
> 
> ++ I get the following additional warning if I add 
> vrrpAssociatedIpAddr
> to conformance section.
> ++ vrrpAssociatedIpAddr is part of table index and I cannot add it to
> groups. 
> 
> 
> 433    5    warning: index of row `vrrpAssociatedIpAddrEntry' 
> can exceed
> OID size limit by 142 subidentifier(s)
> 1591    3    refined object `vrrpAssociatedIpAddr' not listed in a
> mandatory or optional group
> 
> 
> 1591           OBJECT        vrrpAssociatedIpAddr
>    (3) refined object `vrrpAssociatedIpAddr' not listed in a mandatory
> or optional group
>                SYNTAX  InetAddress (SIZE(0|4|16))
>                DESCRIPTION  "An implementation is only required to
> support
>                IPv4 and globally unique IPv6 addresses." 
> 
> 
> I am thinking of adding text to description of vrrpAssociatedIpAddr
> limiting the size and removing 
> >From conformance section. This way I will have only level 5 
> Warning and
> no level 3 error.
> 
> 
> I was using simplewebs online MIB compiler for validating it.
> 
> Thanks,
> Kalyan
> 
> 
> _______________________________________________
> vrrp mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/vrrp
> 

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: <[email-masked]>
Date: Thu, 26 Oct 2006 14:50:02 -0500

Thanks Bert,
	I did go through RFC RFC4181 for this but I was not sure if I
can ignore the new warning that is 
	produced by adding vrrpAssociatedIpAddr to MODULE-COMPLIANCE.

	From your mail, I take it that I can ignore the following.

> or optional group

	I will go ahead and keep the specifics in compliance section and
also add text to 
	DESCRIPTION indicating the size constraints.

Thanks,
Kalyan

-----Original Message-----
From: ext Wijnen, Bert (Bert) [mailto:[email-masked]] 
Sent: Thursday, October 26, 2006 1:40 AM
To: Tata Kalyan (Nokia-ES/MtView); [email-masked];
[email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [VRRP] Re: Re: MIB Dr. Review
ofdraft-ietf-vrrp-unified-mib-05.txt

RFC4181 is clear about what to do about warnings w.r.t. 
max number of subids in an OID because of INDEX object that (in theory)
can go beyond 128.

And PLEASE DO Keep the specifics in MODULE-COMPLIANCE.
That shows which exact addressTypes and related max lengths MUST be
supported for compliance.

Hope this helps,
Bert

> The issue here is that the Address (InetAddress) is 0..255 octets, but

> really only need either 4 octets (IPv4 address) or
> 16 octets (IPv6 address).  Please limit the size of this using 
> SIZE(0|4|16) (as an example).
> 
> example of how to limit the size in the conformance (and also limit 
> the address type).  This needs to be added to the conformance section.
> ===================
>

---

From: "Joan Cucchiara" <[email-masked]>
Date: Fri, 27 Oct 2006 14:05:08 -0400

> ----- Original Message ----- 
> From: <[email-masked]>
> To: <[email-masked]>; <[email-masked]>; 
> <[email-masked]>; <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>
> Sent: Thursday, October 26, 2006 3:50 PM

Thanks from me also Bert!

> DESCRIPTION indicating the size constraints.

Hi Kaylan,

As Bert points out,  in this specific case you should ignore the warning 
about the length of the subIds exceeding 128.

vrrpAssociatedIpAddr  OBJECT-TYPE
SYNTAX  InetAddress (SIZE(0|4|16))
MAX-ACCESS not-accessible

Also, adding to the DESCRIPTION clause is fine.

You do not need to include this INDEX in the conformance section because
it is an INDEX.  

Other Objects (which have MAX-ACCESS other than not-accessible) should be
in the Conformance section.

Thanks,
  Joan

---

From: <[email-masked]>
Date: Sat, 28 Oct 2006 13:24:30 -0500

Thanks Joan,
I will remove the not-accessible (index) objects from the conformance
section (this will remove the level 3 error)
and will add text to the description (This will take care of the level 5
warning below)

Thanks Again to you and Bert for all the help.

Thanks,
Kalyan

-----Original Message-----
From: ext Joan Cucchiara [mailto:[email-masked]] 
Sent: Friday, October 27, 2006 11:05 AM
To: Tata Kalyan (Nokia-ES/MtView); Wijnen, Bert (Bert); Dan Romascanu
(E-mail)
Cc: [email-masked]; [email-masked]; Joan Cucchiara
Subject: Re: [VRRP] Re: Re: MIB Dr. Review
ofdraft-ietf-vrrp-unified-mib-05.txt

> I did go through RFC RFC4181 for this but I was not sure if I can 
> ignore the new warning that is produced by adding vrrpAssociatedIpAddr

> to MODULE-COMPLIANCE.
> I will go ahead and keep the specifics in compliance section and also 
> add text to DESCRIPTION indicating the size constraints.
> 

Hi Kaylan,

Other Objects (which have MAX-ACCESS other than not-accessible) should
be
in the Conformance section.

Thanks,
  Joan

>> I was trying fix the following :
but