Subject: [VRRP] VRRPv3 Queries

From: "Suraj R" <[email-masked]>
Date: Tue, 30 Dec 2008 20:46:54 +0530

Hello to all,

Please find time to clarify the below queries, with regard to
draft-ietf-vrrp-unified-spec-02

1) When multiple VRRP groups are configured on an interface, and more than
 one group is a master on that interface, what should be the behaviour of
RA? Should an RA be sent as per each of master link local address?

2) The RFC states that the VRRP advertisement can have multiple virtual IPv6
addresses. How are these addresses used by the VRRP router & host device ?

3) When a VRRP group transits from master to initialize, does the VRRP
device need to send an RA with lifetime zero?

Thanks & Regards,
Suraj R
_______________________________________________
vrrp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vrrp

---

From: Sengottuvelan Srirangan <[email-masked]>
Date: Tue, 30 Dec 2008 19:54:58 -0800 (PST)

Hi Suraj,

Answers inline.

--- On Tue, 12/30/08, Suraj R <[email-masked]> wrote:

From: Suraj R <[email-masked]>
Subject: [VRRP] VRRPv3 Queries
To: [email-masked], [email-masked]
Date: Tuesday, December 30, 2008, 8:16 PM

Hello to all,

Please find time to clarify the below queries, with regard to draft-ietf-vrrp-unified-spec-02

1) When multiple VRRP groups are configured on an interface, and more than  one group is a master on that interface, what should be the behaviour of RA? Should an RA be sent as per each of master link local address?
 
When mutiple VRRP sessions are running on an Interface, atleast one Link local address to be part of a VRID. Master should be part of Solicited-Node multicast address group for the virtual address configured.  Yes, It should send RA for a virtual router and Neighbor Advertisements for each VRID associated.

2) The RFC states that the VRRP advertisement can have multiple virtual IPv6 addresses. How are these addresses used by the VRRP router & host device ? 
 
Atleast one link local address to be part of VRID for Virtual Router for resolving link layer MAC address. Rest can be global unicast ipv6 addresses. ND Neighbor Advertisements & ND Neighbor Solicitation message should be exchanged between Router and host device(s).

3) When a VRRP group transits from master to initialize, does the VRRP device need to send an RA with lifetime zero?
 
When goes to Initialize, Virtual router is not allowed to send any packets until its state transition to master state.  

Thanks & Regards,
Suraj R_______________________________________________
vrrp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vrrp