Subject: [VRRP] RFC 5798 - ipv6 link-local configuration

From: Alexey Razuvaev <[email-masked]>
Date: Thu, 17 May 2012 10:10:49 -0400

Hi,
VRRPv3 for IPv6 specifies that the first address should be a link-local
address. If that is configured by an operator and not generated by
software, how do we make sure that there are no collisions with existing
link local addresses? Since the protocol spec does not mention any
link-local address range dedicated to VRRP, how do
current implementations make sure that it doesn't collide with anyone else
on the network? I understand that IPv4 has similar issues, but in IPv4 case
the network would be statically configured, unlike in IPv6 case where
link-local addresses are generated from MAC.

Additionally what is the reasoning behind not allowing to use Virtual MAC
address to generate link-local address? It seems like it would simplify the
set up, but I think I am missing some crucial detail.

Also, if I were to allow global IPv6 to be configured for virtual router, I
would have to force the operator to also configure a link-local address,
correct?

Thanks,
Alexey.

---

From: "Tim Harrison" <[email-masked]>
Date: Tue, 22 May 2012 10:11:20 -0400

Alexey,

Current implementations for IPv6 (of which I'm aware) do force the operator to manually configure a link-local address along with the global unicast address, which can lead to some hassles - particularly in a multivendor environment.  For example, certain vendors require a hard coded link-local on the interface as well as in the virtual router config; certain vendors utilise the same command for the global unicast and link-local within the VRRP configuration, etc.

We've been working with multiple vendors to find a way to implement auto-generated link-local addresses based on the virtual MAC as an option.  There has been some traction and I haven't heard of any major showstoppers thus far; however, I could be out of the loop on the investigation or progress (or lack thereof).  The big problem is getting a solution that is standarised (if you will) across vendors.

Hopefully there can be some discussion about this particular topic here.

---

Tim Harrison
Manager, Network Engineering
Q9 Networks Inc.
http://www.q9.com/
416-848-3250

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexey Razuvaev
Sent: May 17, 2012 10:11
To: [email-masked]
Subject: [VRRP] RFC 5798 - ipv6 link-local configuration

Hi,
VRRPv3 for IPv6 specifies that the first address should be a link-local address. If that is configured by an operator and not generated by software, how do we make sure that there are no collisions with existing link local addresses? Since the protocol spec does not mention any link-local address range dedicated to VRRP, how do current implementations make sure that it doesn't collide with anyone else on the network? I understand that IPv4 has similar issues, but in IPv4 case the network would be statically configured, unlike in IPv6 case where link-local addresses are generated from MAC.

Additionally what is the reasoning behind not allowing to use Virtual MAC address to generate link-local address? It seems like it would simplify the set up, but I think I am missing some crucial detail.

Also, if I were to allow global IPv6 to be configured for virtual router, I would have to force the operator to also configure a link-local address, correct?

Thanks,
Alexey.