Subject: RE: Versioning: The Next Versioning and Variants meeting

From: Yaron Goland <[email-masked]>
Date: Fri, 11 Sep 1998 15:28:34 -0700

Is this an author's meeting or an open meeting?
	Yaron

> -----Original Message-----
> From: Babich, Alan [mailto:[email-masked]]
> Sent: Friday, September 11, 1998 12:11 PM
> To: 'webdav'
> Cc: Fay, Chuck; Whelan, Dan; Green, Jim; Palmer, Ann; Johnson, Andrew;
> Tucker, Michael; Fink, Evangeline
> Subject: Versioning: The Next Versioning and Variants meeting
> 
> 
> The next V&V meeting will be hosted by FileNET in
> Costa Mesa California, on October 1 and 2 from
> 9 am to 5 pm Pacific time.
> 
> If you plan to attend, please e-mail me ASAP so I
> can order the catered lunches.
> There is a sandwich place called the Business Park Cafe 
> only a couple of minutes walk away. So you will have 
> the option of going there for lunch instead of eating 
> the catered lunch (unless we decide to work through 
> lunch).
> 
> The following file has directions from three airports, 
> hotel information, and local maps. The closest airport
> is John Wayne Orange County airport. Use that airport
> if you can get a flight. The second closest (and
> second choice) is Long Beach airport. Since the following
> file has no directions from Long Beach airport,
> get in touch with me if you want to use the Long
> Beach airport. LAX and Ontario airport are a ways away.
> 
>  <<Directions.doc>> 
> The meeting will be held in "FileNET building 4" of the
> Harbor Gateway business complex on the second floor 
> in room 2349:
> 
>  <<Bldg4.doc>> 
> Enter the lobby, and take the door on the left.
> Both doors have a badge reader. I will prop the left
> door open until 9 am on Monday and Tuesday. If you're
> late, use the phone in the lobby, dial 5883, and ask 
> our sectary Nelsy to please come down and let you in
> to the WEBDAV Versioning and Variants meeting.
> There is no receptionist in building 4. We're not going
> to issue badges.
> 
> Enter the door on the left, turn left, go up the stairs,
> go about half way down the corridor, and it's on
> your right. It's a large room.
> 
> The room has power for laptops, whiteboards,
> an overhead projector, and an LCD screen to project
> what's on your laptop screen using the overhead projector.
> So, it will be possible to presentations without
> printing them out. We can also have the secretaries
> print things out and make copies.
> 
> I am assuming Jim Whitehead will supply the agenda.
> 
> If you have any questions, get in touch with me.
> 
> Alan Babich
> [email-masked]
> 714-966-3403
> 
> 
>

---

From: Jim Whitehead <[email-masked]>
Date: Fri, 11 Sep 1998 16:51:22 -0700

This is a meeting of the Versioning and Variant Authoring Design Team and is
closed to  people who are not members of the Design Team, or invited guests
with specific expertise.  The intent of holding Design Team meetings like
this is to gather a relatively small group of participants who have made
long-term commitments to actively work on the protocol.  This is in contrast
to the open WebDAV meetings where there is typically a much larger set of
attendees, and no long-term commitment to work on specific problems (though
familiarity with drafts under discussion is expected).

The advantage of having a Design Team is that various design alternatives
can be expressed and evaluated more rapidly than in a large group setting.
Furthermore, there is hope that a smaller group will reduce the problems
associated with "design by committee", including lack of conceptual
integrity in the design.

The major drawback to a Design Team approach is that a small group of people
has a disproportionately large impact on the design, and is more susceptible
to making poor design decisions than a larger group.  Since the work of the
design team is performed in closed meetings, the development of the protocol
is not as transparent as if it had totally been developed on a mailing list.
As a result, the decisions of a Design Team are never final, but are subject
to approval by the mailing list.  In IETF working groups, the mailing list
is always the final arbiter of consensus on any topic or proposal.

At present, members of the Versioning and Variant Authoring Design Team are:

John Stracke
Chris Kaler
Bradley Sergeant
Alan Babich
Sam Ruby
Bruce Cragun
David Durand
Jim Whitehead
Sridhar Iyengar

These individuals replied to my public call for volunteers, posted on July
6, 1998:
http://lists.w3.org/Archives/Public/w3c-dist-auth/1998JulSep/0008.html.  If
there are individuals on the list who didn't see this earlier call for
volunteers, and who are committed to working on the versioning and variant
authoring protocol (as in, coming to all design team meetings, writing text
for the protocol, and reading and commenting on existing drafts), then
please let me know.

There is, as yet, no official output of the Versioning and Variant Authoring
Design Team.  The team is currently working on two documents, a protocol
draft, and an extended goals draft (listing versioning goals beyond those
listed in RFC 2291).

At present, the only versioning drafts are:

draft-whitehead-webdav-versioning-00
draft-kaler-webdav-versioning-00

Both of these drafts are available off the WebDAV home page, at:

http://www.ics.uci.edu/pub/ietf/webdav/

The Design Team welcomes any comments or criticisms you have on these
proposals.

Furthermore, I have instructed the design team to hold as much of their
discussions on the WebDAV mailing list, in order to increase the ability for
non-Design Team members to participate.  Alan Babich's message was in this
spirit, as was his call for making the meeting notes from the last meeting
available.  I fully support this.

- Jim

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Yaron Goland
> Sent: Friday, September 11, 1998 3:29 PM
> To: 'Babich, Alan'; 'webdav'
> Subject: RE: Versioning: The Next Versioning and Variants meeting
>
>
*snip*

---

From: Henrik Frystyk Nielsen <[email-masked]>
Date: Fri, 11 Sep 1998 20:28:07 -0400

If you are interested then you may want to have a look at my Web Commander
[1] which is a Win32 app based on libwww [2].

I have just released a new version that shows how to avoid the lost update
problem when saving documents based on HTTP/1.1 PUT with etags, HEAD, and
persistent cache.

It's available in both binary and source form.

Hope this helps,

Henrik

[1] http://www.w3.org/WinCom/
[2] http://www.w3.org/Library/

--
Henrik Frystyk Nielsen,
World Wide Web Consortium
http://www.w3.org/People/Frystyk

---

From: Jim Whitehead <[email-masked]>
Date: Fri, 11 Sep 1998 18:17:24 -0700

Hi Henrik,

So, when are you going to make a WebDAV-enabled version of Web Commander?

- Jim

> [mailto:[email-masked]]On Behalf Of Henrik Frystyk Nielsen
> Sent: Friday, September 11, 1998 5:28 PM
> To: [email-masked]
> Subject: Solving the lost update problem using HTTP/1.1
>
>
>

---

From: Henrik Frystyk Nielsen <[email-masked]>
Date: Fri, 11 Sep 1998 21:52:22 -0400

>So, when are you going to make a WebDAV-enabled version of Web Commander?

I have heard that grad students have plenty of spare time so maybe that's
what I should head for ;)

Seriously, I think it is a matter of taking one step at a time and see how
it turns out. For example, handling collections is of high interest as well
as handling metadata about a resource.

Henrik