Subject: RE: Namespace consistency

From: Yaron Goland <[email-masked]>
Date: Fri, 11 Sep 1998 19:19:29 -0700

Actually no, http://foo/bar does NOT have to be a collection just because
http://foo/bar/blah is a collection. The requirement reads as:

IF http://foo/bar is DAV compliant and
IF http://foo/bar/blah/ exists and is DAV compliant
THEN http://foo/bar must be a collection.

However,

IF http://foo/bar is NOT DAV compliant and
IF http://foo/bar/blah/ exists and is DAV compliant
THEN there is no requirement on http://foo/bar.

The reason the requirement runs this way is that often what appears to be a
single namespace is in fact a whole mishmash of mapped namespaces owned by
separate servers. So even though http://foo/bar/blah may be on a DAV
compliant server there is no guarantee that http://foo/bar is on a DAV
compliant server. Thus our requirements for namespace consistency are
predicated on the parent being DAV compliant.

		Yaron

> -----Original Message-----
> From: Jim Whitehead [mailto:[email-masked]]
> Sent: Friday, September 11, 1998 5:02 PM
> To: Howard Modell; [email-masked]
> Subject: RE: Namespace consistency
> 
> 
> Howard Modell writes:
> > So if I have a personal webspace, ...
> >
> > http://warlok.ds.boeing.com/~howie/
> >
> > .. and I choose I create a "WebDAV collection" in my space, ..
> >
> > http://warlok.ds.boeing.com/~howie/a/b/c
> >
> > .. am I in violation of the rules above since the URL of my 
> personal space
> > is NOT of and by itself the URL of a collection?
> 
> Well, actually, the URL of 
> http://warlok.ds.boeing.com/~howie/ is a > correct
> URL for a 
> collection, since it has a trailing slash.  But, what you're
> probably asking is whether the resource identified by
> http://warlok.ds.boeing.com/~howie/ needs to be of type 
> WebDAV collection.
> The implication of the requirement in section 4.3 (no namespace gaps)
> combined with the requirement in section 4.1 that namespaces 
> must behave as
> DAV collections even if they weren't created with WebDAV, is 
> that yes, the
> resource identified by http://warlok.ds.boeing.com/~howie/ 
> needs to be of
> type WebDAV collection if http://warlok.ds.boeing.com/~howie/a/b/c is
> WebDAV-compliant.
> 
> - Jim
>

---

From: "Larry Masinter" <[email-masked]>
Date: Fri, 11 Sep 1998 23:07:33 PDT

Yaron and Jim seem to disagree on the nature of the requirement,
so it sounds like this needs to get worked out.

> THEN http://foo/bar must be a collection.

Must the intermediaries also be DAV compliant? Well, for one level
it doesn't matter, but suppose:

1)  http://foo/bar is DAV compliant
2)  http://foo/bar/a/b/c/blah/ exists and is DAV compliant
3)  then must http://foo/bar/a/b be a (DAV-compliant) collection?

This would leave out the possibility that http://foo/bar/a might
be some kind of mapping? Or is it that "exists" needs elaboration
to except that case where it's a redirection?