Subject: [weirds] a small proposal toward simplification

From: Andy Newton <[email-masked]>
Date: Thu, 29 Nov 2012 11:36:43 +0000

All,

I have a small proposal to make our drafts a little more readable.

Though we have a draft about JSON responses
(draft-ietf-weirds-json-response) some might not be aware that there are
JSON structures also in draft-ietf-weirds-using-http. This was done to
accommodate a bifurcated response model where both JSON and XML are used.

Since we are no longer talking about XML, I'd like to move the JSON naming
rules and other JSON structures over to draft-ietf-weirds-json-response so
readers will see it all in one place. The rules for compatibility with XML
tag names will remain in case we want to bring XML back in the future.

In my opinion, this makes our documents a bit easier to read and
understand. What does everyone think of this? Comments?

-andy

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 29 Nov 2012 12:08:56 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Andy Newton
> Sent: Thursday, November 29, 2012 6:37 AM
> To: [email-masked]
> Subject: [weirds] a small proposal toward simplification
> 
> All,
> 
> (draft-ietf-weirds-json-response) some might not be aware that there
> are JSON structures also in draft-ietf-weirds-using-http. This was done
> to accommodate a bifurcated response model where both JSON and XML are
> used.
> 
> Since we are no longer talking about XML, I'd like to move the JSON
> naming rules and other JSON structures over to draft-ietf-weirds-json-
> response so readers will see it all in one place. The rules for
> compatibility with XML tag names will remain in case we want to bring
> XML back in the future.
> 

I support this idea. It makes a lot of sense to have as much of the JSON-specific text in the response document and all of the HTTP-specific text (redirects aside (at least for now)) in the HTTP document.

Scott

---

From: Arturo Servin <[email-masked]>
Date: Thu, 29 Nov 2012 10:17:32 -0200

I like the idea. It could simplify the documents.

Regards,
as

On 29/11/2012 10:08, Hollenbeck, Scott wrote:
> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds
>

---

From: "Carlos M. martinez" <[email-masked]>
Date: Thu, 29 Nov 2012 12:01:42 -0200

I agree with Andy.

---

From: Edward Lewis <[email-masked]>
Date: Thu, 29 Nov 2012 10:19:40 -0500

It makes sense to put all of the response information into one place.

I'd ask that the JSON document include text about why JSON is defined (at this point) and not XML.  The reason is that it'll be a natural question.  In as much as EPP and the protocol under development here are unrelated, operators may see this a little differently at first.  Running an XML based protocol now, there might be some explanation needed to say why the new one is not XML.  (Yes, it's a decade later, yadda, yadda, yadda, but the change ought to be rationalized in words.)

> understand. What does everyone think of this? Comments?

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Edward Lewis             
NeuStar                    You can leave a voice message at +1-571-434-5468

There are no answers - just tradeoffs, decisions, and responses.

---

From: Andy Newton <[email-masked]>
Date: Thu, 29 Nov 2012 15:30:04 +0000

From: Edward Lewis <[email-masked]<mailto:[email-masked]>>
Date: Thursday, November 29, 2012 10:19 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Edward Lewis <[email-masked]<mailto:[email-masked]>>
Subject: Re: [weirds] a small proposal toward simplification

We can do that.

-andy

---

From: Byron Ellacott <[email-masked]>
Date: Fri, 30 Nov 2012 06:52:04 +0000

>tag names will remain in case we want to bring XML back in the future.

I support this.  There's no reason any more to have the response contents
in the http draft.

  Byron