Subject: [weirds] Entity "Objects"

From: James Mitchell <[email-masked]>
Date: Thu, 28 Feb 2013 22:17:19 +1100

All,

I am concerned regarding the use of the entity object as described in the rdap query draft. It appears to me as though two separate objects, contacts and registrars, have been pulled together because they share data. This is problematic for me because
 - Contact objects and Registrar objects do not share the same identifier space.
 - Contact objects and Registrar objects share very little data; one may think of registrar objects as being composed of contact-like (not contact object) data, perhaps even several contact-like objects (registrar-contact objects do not share the same identifier space as domain-contact objects)

What is the motivation for shared query mechanism? Is it to avoid having one less path segment? How would one convey information about a registrar to the client, for example IANA ID without using registry-specific extensions?

Thanks,
James

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 28 Feb 2013 13:17:36 +0000

Entity objects can be identified by role. A registrar entity and a contact entity (such as a registrant) would have distinct roles in the context of a domain object.

Scott

From: [email-masked] [mailto:[email-masked]] On Behalf Of James Mitchell
Sent: Thursday, February 28, 2013 6:17 AM
To: [email-masked]
Subject: [weirds] Entity "Objects"

All,

Thanks,
James

---

From: James Mitchell <[email-masked]>
Date: Fri, 1 Mar 2013 08:26:35 +1100

Scott,

Perhaps contact objects and registrar objects share the same identifier space in Verisign's system, however in ours they do not. What object is identified by /entity/R-12345? My answer is both a contact and a registrar; the role does not satisfy the outcome as they will have different names, email addresses etc.

If I do not care about direct queries for contact/registrar objects (URLs constructed by clients), and instead assume that links will always be obtained in domain response,  then I CAN generate identifiers that separate the two identifier spaces (append C or R as appropriate) - however having to work around this does not feel right to me.

I believe that registrars should be their own path segments at /registrar/id. Does anyone else have this problem?

Regards,
James

From: <Hollenbeck>, Scott <[email-masked]<mailto:[email-masked]>>
Date: Friday, 1 March 2013 12:17 AM
To: James Mitchell <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: Entity "Objects"

Scott

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of James Mitchell
Sent: Thursday, February 28, 2013 6:17 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [weirds] Entity "Objects"

All,

Thanks,
James

---

From: Andy Newton <[email-masked]>
Date: Thu, 28 Feb 2013 23:11:43 +0000

From:  James Mitchell <[email-masked]>

>Perhaps contact objects and registrar objects share the same identifier
>space in Verisign's system, however in ours they do not. What object is
>identified by /entity/R-12345? My answer is both a contact and a
>registrar; the role does not satisfy the outcome
> as they will have different names, email addresses etc.
>
>If I do not care about direct queries for contact/registrar objects (URLs
>constructed by clients), and instead assume that links will always be
>obtained in domain response,  then I CAN generate identifiers that
>separate the two identifier spaces (append
> C or R as appropriate) - however having to work around this does not
>feel right to me.
>
>I believe that registrars should be their own path segments at
>/registrar/id. Does anyone else have this problem?

James,

We have to support multiple registry models, some with no registrars and
some more than 2 tiers. Some registry models have different concepts for
types of customers. Should we have to specify a new path segment for each
differentiation? What about registries that don't want to differentiate?
Imagine the complexity your putting on clients to know the distinctions.

If you need to separate the namespace for your registrars from your
contacts, do that with your identifiers. There's nothing stopping you from
prefixing "contact_" or "registrar_" or whatever prefix you see fit to
your registry unique identifiers if this is a necessity for you.

-andy

---

From: SM <[email-masked]>
Date: Thu, 28 Feb 2013 22:45:38 -0800

Hi Andy,
>your registry unique identifiers if this is a necessity for you.

The discussion is about identifiers.  The above will be different 
conventions for identifiers.  It will create a mess.  It might cause 
internationalization issues.

Regards,
-sm

---

From: Andy Newton <[email-masked]>
Date: Fri, 1 Mar 2013 07:29:44 +0000

>internationalization issues.

Care to explain?

-andy