Subject: Re: [weirds] search Unicode partial match

From: Ernie Dainow <[email-masked]>
Date: Mon, 22 Jul 2013 11:42:14 -0400

The following is unnecessarily restrictive and adds a lot of checking on
the client.
p.3 Clients MUST NOT issue a partial match search of Unicode characters
where a Unicode character may be legally combined with another ...

The onus should be on the server to return no results.

Guidelines for server side partial matching refer to [RFC5892] and
[I-D.ietf-precis-nickname]. These seem to be overkill for search, as they
describe processing to determine whether an internationalized name is valid
or not. Since search is not registration, it is only important to determine
whether names exist or not. While it is useful to return an error on a
search when the name is invalid, this requires a lot of extra checking and
should be optional.

It would be more consistent to refer to [RFC5891] to specify the match
processing, as in 3.3 of draft-ietf-weirds-rdap-query:
p.5 If the client sends the server an IDN in U-label format, servers that
   support IDNs MUST convert the IDN into A-label format and perform
   IDNA processing as specified in RFC 5891.

RFC 5891 allows checking for validity to be optional:
p.11
   This test may be omitted in special circumstances ...
   However, applying the test is likely to give
   much better information about the reason for a lookup failure

I don't think 3.3 of draft-ietf-weirds-rdap-query should be a MUST. If the
server stores IDN domain names as U-labels, this seems like a lot of
unnecessary complication and overhead to convert to A-label. A server
should be able to just lookup the U-label directly.

-Ernie

On Wed, Jul 17, 2013 at 9:41 AM, Andy Newton <[email-masked]> wrote:

>
> That's correct, this change impacts both the rdap-query draft and the
> json-response draft.
>
> My only hesitation with this approach is with the internationalization
> aspects of search processing. I hope everybody is comfortable with Section
> 4 of that draft, especially paragraphs 3 and 4.
>
> -andy
>
>

---

From: Andy Newton <[email-masked]>
Date: Tue, 23 Jul 2013 19:00:36 +0000

From: Ernie Dainow <[email-masked]<mailto:[email-masked]>>
Date: Monday, July 22, 2013 11:42 AM
To: Andrew Newton <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [weirds] search Unicode partial match

The following is unnecessarily restrictive and adds a lot of checking on the client.
p.3 Clients MUST NOT issue a partial match search of Unicode characters where a Unicode character may be legally combined with another ...

I think I agree. That should be a lower-cased should not. :)

Guidelines for server side partial matching refer to [RFC5892] and [I-D.ietf-precis-nickname]. These seem to be overkill for search, as they describe processing to determine whether an internationalized name is valid or not. Since search is not registration, it is only important to determine whether names exist or not. While it is useful to return an error on a search when the name is invalid, this requires a lot of extra checking and should be optional.

I'm good with this as long as it is spelled out that when clients send non-sense the results may be unpredictable. I don't know if this will be adequate for the IETF I18N experts, but the least we can do is ask.

It would be more consistent to refer to [RFC5891] to specify the match processing, as in 3.3 of draft-ietf-weirds-rdap-query:
p.5 If the client sends the server an IDN in U-label format, servers that
   support IDNs MUST convert the IDN into A-label format and perform
   IDNA processing as specified in RFC 5891.

I don't think 3.3 of draft-ietf-weirds-rdap-query should be a MUST. If the server stores IDN domain names as U-labels, this seems like a lot of unnecessary complication and overhead to convert to A-label. A server should be able to just lookup the U-label directly.

I suspect you are right but need to think about this.

Thanks for the feedback, Ernie.

-andy