Subject: [weirds] Current Search Functionality

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 31 Jul 2013 08:38:57 +0000

I'm a little bored with what's going on in this morning's oauth WG session so I decided to do a little research on current search functionality for com, net, org, and biz. This is by no means intended to be a comprehensive survey.

com/net: offers lookup and search for domains, name servers, and registrars by name. There's a limit of 50 results returned, with no paging or other method provided to get at whatever follows the first 50 results. The "." character is used to specify a search for anything matching a specific prefix. For example, a domain search for "a." will match all domains that begin with the letter "a". The "*" character can also be used for registrar name searches (but not domain names or name servers - go figure), but it's not documented. (Personal note: I have no idea why the "." character is used; "*" seems more intuitive to me. I need to ask the guy that maintains this software...)

org: Domain name lookup is available, but I can't find anything on the PIR web site that describes if/how search functionality and name server/registrar lookup is available. A search for "a." returns an "Invalid Input!" response. A list of registrars is available via link from the WHOIS web page.

biz: Similar to com/net, except that a maximum of 75 results will be returned. "*" is not supported.

Scott

---

From: "John Levine" <[email-masked]>
Date: 31 Jul 2013 12:18:34 -0000

>org: Domain name lookup is available, but I can't find anything on the
>PIR web site that describes if/how search functionality and name
>server/registrar lookup is available. A search for "a." returns an
>"Invalid Input!" response. A list of registrars is available via link
>from the WHOIS web page.

The wildcard character is % rather than *, limit is 50 answers.  A _
matches one character at the end of a name.  You can also match hosts
and contacts.  Send "help" to get surprisingly helpful help text.

You 

$ whois -h whois.publicinterestregistry.net abcd%.org
 [ boilerplate here ]

Domain ID:D165691150-LROR
Domain Name:ABCD-69.ORG

Domain ID:D154485720-LROR
Domain Name:ABCD-974.ORG

Domain ID:D160653658-LROR
Domain Name:ABCD-APAC.ORG

etc.

---

From: Ernie Dainow <[email-masked]>
Date: Wed, 31 Jul 2013 12:09:45 -0400

On Wed, Jul 31, 2013 at 4:38 AM, Hollenbeck, Scott <[email-masked]
> wrote:

> I'm a little bored with what's going on in this morning's oauth WG session
> so I decided to do a little research on current search functionality for
> com, net, org, and biz. This is by no means intended to be a comprehensive
> survey.
>
> com/net: offers lookup and search for domains, name servers, and
> registrars by name. There's a limit of 50 results returned, with no paging
> or other method provided to get at whatever follows the first 50 results.
> The "." character is used to specify a search for anything matching a
> specific prefix. For example, a domain search for "a." will match all
> domains that begin with the letter "a". The "*" character can also be used
> for registrar name searches (but not domain names or name servers - go
> figure), but it's not documented. (Personal note: I have no idea why the
> "." character is used; "*" seems more intuitive to me. I need to ask the
> guy that maintains this software...)
>
> org: Domain name lookup is available, but I can't find anything on the PIR
> web site that describes if/how search functionality and name
> server/registrar lookup is available. A search for "a." returns an "Invalid
> Input!" response. A list of registrars is available via link from the WHOIS
> web page.
>

org is pretty much the same as com/net -- limit of 50 results, no paging.
Prefix wild card is %
Whois help is not standardized and not documented but is available to those
in the know via  whois -h whois.pir.org help

-Ernie

> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds
>