Subject: [weirds] Preliminary Berlin WEIRDS Agenda

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 15 Jul 2013 17:06:49 -0700

...is now available; feedback welcome:

http://www.ietf.org/proceedings/87/agenda/agenda-87-weirds

-MSK

---

From: Pete Resnick <[email-masked]>
Date: Tue, 16 Jul 2013 08:09:42 -0500

I have some feedback:

> Web Extensible Internet Registration Data Service (WEIRDS)
> Agenda -- August 1, 2013 at 10:30-11:30 in Potsdam 2
>
> - Administrivia (10 mins; chairs)
>   - blue sheets
>   - minute-taker and jabber scribe

Yes, all fine, though I would suggest finding the minute-taker and 
jabber scribe before the meeting. Asking for volunteers now would be 
good. Those two items should take 2 minutes tops.

>   - current document status

Send out an email message with this beforehand. No need for it on the 
agenda. Please remove it.

> - Demo/interop report (5 mins; TBD)

I take it this is intended to be a report of the interop/demo event on 
the previous Saturday. The WG session is on Thursday. Again, this report 
should be sent out to the list. If something comes out of the report 
that needs discussion (a bug in one of the specs), that should be added 
to the agenda separately. I see no need for a report being on the agenda.

> - Handling of the object inventory draft (5 mins; chairs/AD)

Yes. There was barely any discussion on the list and I'd like to unwedge 
this. (And since the "wedgedness" is my fault... ;-) )

> - Bootstrapping (10 mins; Marc Blanchet)

I suspect this might need a bit more time, since there has been quite a 
bit of discussion in general, but little on Marc's last "requirements" 
message.

> - Redirects (10 mins; Carlos Martinez)

What is there to discuss on this draft? The list discussion seems to be 
quiet.

> - Search (10 mins; Ning Kong)

What's the plan on this agenda item? What discussion (or lack of 
discussion) on the list does this relate to?

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 16 Jul 2013 10:18:38 -0700

On Tue, Jul 16, 2013 at 6:09 AM, Pete Resnick <[email-masked]>wrote:

>> http://www.ietf.org/**proceedings/87/agenda/agenda-**87-weirds<http://www.ietf.org/proceedings/87/agenda/agenda-87-weirds>
>>
>
> I have some feedback:
>
> Yes, all fine, though I would suggest finding the minute-taker and jabber
> scribe before the meeting. Asking for volunteers now would be good. Those
> two items should take 2 minutes tops.
>

Any volunteers?

> I take it this is intended to be a report of the interop/demo event on the
> previous Saturday. The WG session is on Thursday. Again, this report should
> be sent out to the list. If something comes out of the report that needs
> discussion (a bug in one of the specs), that should be added to the agenda
> separately. I see no need for a report being on the agenda.
>

The last interop event led to some discussion, and I was anticipating the
same here.  I was anticipating the need for face time to discuss the
fallout rather than just present a report.  My fault for the lousy naming.

> discussion) on the list does this relate to?
Carlos and Ning, can you give a list of issues you'd like to cover?

On the search issue, we do need to decide how we're going to deal with
this.  We had discussed in Orlando whether we wanted a basic search and
advanced search document or something else, but I think that was before
John's survey that showed they're nearly non-existent today.  The group
needs to pick a path forward here, since an ultra-simple search capability
could be rolled into the rdap-query document fairly easily (I think...).

-MSK

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 16 Jul 2013 17:30:58 +0000

From: [email-masked] [mailto:[email-masked]] On Behalf Of Murray S. Kucherawy
Sent: Tuesday, July 16, 2013 1:19 PM
To: Pete Resnick
Cc: [email-masked]
Subject: Re: [weirds] Preliminary Berlin WEIRDS Agenda

[snip]
On the search issue, we do need to decide how we're going to deal with this.  We had discussed in Orlando whether we wanted a basic search and advanced search document or something else, but I think that was before John's survey that showed they're nearly non-existent today.  The group needs to pick a path forward here, since an ultra-simple search capability could be rolled into the rdap-query document fairly easily (I think...).

Nearly non-existent, yes, but supported by the largest gTLDs registries - and yes, I think that the very basic functionality described in the rdap-search draft could be rolled into rdap-query virtually as-is, made optional, and the need would be met.

Scott

---

From: "John Levine" <[email-masked]>
Date: 16 Jul 2013 18:04:58 -0000

>Nearly non-existent, yes, but supported by the largest gTLDs registries - and yes, I think
>that the very basic functionality described in the rdap-search draft could be rolled into
>rdap-query virtually as-is, made optional, and the need would be met.

Agreed.

The existing ICANN documents that refer to WEIRDS are ambiguous, but a
reasonable reading is that son-of-WHOIS will answer the same questions
that the current system does.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 16 Jul 2013 11:07:08 -0700

On Tue, Jul 16, 2013 at 10:30 AM, Hollenbeck, Scott <
[email-masked]> wrote:

>    *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Murray S. Kucherawy
> *Sent:* Tuesday, July 16, 2013 1:19 PM
> *To:* Pete Resnick
> *Cc:* [email-masked]
> *Subject:* Re: [weirds] Preliminary Berlin WEIRDS Agenda****
>
> ** **
>
> [snip]****
>
> could be rolled into the rdap-query document fairly easily (I think...).**
> **
>
> ** **
>
> Nearly non-existent, yes, but supported by the largest gTLDs registries –
> and yes, I think that the very basic functionality described in the
> rdap-search draft could be rolled into rdap-query virtually as-is, made
> optional, and the need would be met.****
>
> ** **
>
> Scott****
>

Just to be clear, by "nearly non-existent", I was talking about how trivial
it is to describe, not how important it may be.

-MSK

---

From: Ernie Dainow <[email-masked]>
Date: Tue, 16 Jul 2013 16:37:07 -0400

> that the current system does.
I agree with Scott's proposal to include the basic search from 
<draft-hollenbeck-weirds-rdap-search>. To be consistent with the current 
structure of the documents, it seems this should be split and merged 
into both draft-ietf-weirds-rdap-query and draft-ietf-weirds-json-response.

-Ernie

---

From: "Carlos M. martinez" <[email-masked]>
Date: Tue, 16 Jul 2013 19:09:31 -0400

My 10' would run more or less be as follows:

- wrap-up of the discussion so far (even if it's not very recent)
- server bootstrapping, how it has been done in the known implementations
- the server pooling idea, pros, cons
- open questions:
	- should we redirect from names to numbers and viceversa or removing
this requirement simplifies our work in some way ?
	- redirects and authentication: expectations for clients, if need to be
set or just ignored
- open mic

... and that would be it.

regards,

~Carlos

On 7/16/13 1:18 PM, Murray S. Kucherawy wrote:
> On Tue, Jul 16, 2013 at 6:09 AM, Pete Resnick <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>         http://www.ietf.org/__proceedings/87/agenda/agenda-__87-weirds
>         <http://www.ietf.org/proceedings/87/agenda/agenda-87-weirds>
> 
> 
>     I have some feedback:
> 
>     I take it this is intended to be a report of the interop/demo event
>     on the previous Saturday. The WG session is on Thursday. Again, this
>     report should be sent out to the list. If something comes out of the
>     report that needs discussion (a bug in one of the specs), that
>     should be added to the agenda separately. I see no need for a report
>     being on the agenda.
> 
> 
> The last interop event led to some discussion, and I was anticipating
> the same here.  I was anticipating the need for face time to discuss the
>     What is there to discuss on this draft? The list discussion seems to
>     be quiet.
> 
> needs to pick a path forward here, since an ultra-simple search
> capability could be rolled into the rdap-query document fairly easily (I
> think...).
> 
> -MSK
> 
> 
> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds
>

---

From: Ning Kong <[email-masked]>
Date: Wed, 17 Jul 2013 11:09:32 +0800

Hi Murray,

Please see my feedbacks inline.

> What's the plan on this agenda item? What discussion (or lack of discussion) on the list does this relate to?
> 
> 
> On the search issue, we do need to decide how we're going to deal with this.  We had discussed in Orlando whether we wanted a basic search and advanced search document or something else, but I think that was before John's survey that showed they're nearly non-existent today.  The group needs to pick a path forward here, since an ultra-simple search capability could be rolled into the rdap-query document fairly easily (I think…).

+1

The followings are the issues I'd like to cover on the search slot.

#1  Why should we consider the search function?
	1)  Optional search function described by the ICANN AGB 
	2)  ICANN WSWG (Whois Survey Working Group) Survey Results (Requirement 5 for search)
	     Note1: the final report of this survey is not published, but the results can be accessed in the link of https://community.icann.org/display/WSDT/WSWG+Survey+Results
	     Note2: According to the results, over 81% respondents support the search function of domain name, over 53% respondents indicated positive interest in other search functions (over 31% for NameServers, over 32% for Contact Name, over 34% for Contact Email).

#2  What should be the search function?
	1)  What query types should be searchable
		Domain?
			Handle?
			Name?
			Status?
		Nameserver?
			Handle?
			Name?
			IP?
		Entity?
			ID?
			Name?
			Email?
			Adr?
		IP?
			Handle?
			StartAddress?
			Name?
		AS?
			Handle?
			StartAutnum?
			Name?

	2)  What kind of search functions should be considered?
		Wildcard? (single character match, multiple characters match, specific number of characters match)
		Boolean? (and, or, not)
		Page?
		Order by? (Date, Name)

	2)  What path segments should be used for search?
		Option1:   domains/?name=exampl*.com      by hollenbeck-weirds-rdap-search-02
	        Option2:   search/?domain=exampl*.com      by zhou-weirds-rdap-restful-search-00
		Option3:   domains/?name=exampl*.com&page=3&orderby=name

	3)  What response format should be used for search?
		Search level ?
		Results ?
		Page ? (Total Page Number, Current Page Number)
		Oder by ?

	4)  Others?
		I18N consideration
		Security consideration 
		Anything else?

#3  How should we document the search function?
	Option1:  one separated search document which covers all the issues of search
	Option2:  Merging all the search function into all related RDAP documents (Query, Response, others?)
	Option3:  Merging the basic search function into all related RDAP documents (Query, Response, others?), drafting one separated search document to cover the advanced search function

#4  Other Open Questions
	1)  How to clearly define the basic search function and the advanced one? 
	2)  Need we consider the search function across different RDAP servers? (Search + Redirect ?)

Any comments are appreciated!

Cheers,
Ning

---

From: Andy Newton <[email-masked]>
Date: Wed, 17 Jul 2013 13:41:48 +0000

From:  Ernie Dainow <[email-masked]>
Date:  Tuesday, July 16, 2013 4:37 PM
Cc:  "[email-masked]" <[email-masked]>
Subject:  Re: [weirds] search, was Preliminary Berlin WEIRDS Agenda

>I
> agree with Scott's proposal to include the basic search from
>structure of the documents, it seems this should be split and merged into
>both draft-ietf-weirds-rdap-query and draft-ietf-weirds-json-response.
>
>-Ernie
>

That's correct, this change impacts both the rdap-query draft and the
json-response draft.

My only hesitation with this approach is with the internationalization
aspects of search processing. I hope everybody is comfortable with Section
4 of that draft, especially paragraphs 3 and 4.

-andy

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 17 Jul 2013 10:24:11 -0700

> Please see my feedbacks inline.

Why wait for the meeting? Can we start threads on the list on these topics
now?  Then we can use the meeting time to discuss things that appear to be
sticky or need the in-person meeting time.  As laid out, your topic list
will take a lot more time than I think we have in Berlin, and I'd rather
not request a second meeting if we can avoid it.

-MSK

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 17 Jul 2013 10:38:37 -0700

Same question here: Can we start this discussion now on the list so we can
make optimal use of our in-person time in Berlin?  We only have an hour.

-MSK

---

From: Marc Blanchet <[email-masked]>
Date: Mon, 22 Jul 2013 13:57:02 -0400

for bootstrapping, I think we discussed a lot already on the ML and we are at a stage where we need F2F. I'm currently working on the slides to foster the discussion on bootstrapping during the meeting and will send them to the chairs+list when done (asap0, so that we can continue the discussion before the meeting.

Regards, Marc.

Le 2013-07-17 à 13:38, "Murray S. Kucherawy" <[email-masked]> a écrit :

> Same question here: Can we start this discussion now on the list so we can make optimal use of our in-person time in Berlin?  We only have an hour.
> 
> -MSK
> 
> 
> On Tue, Jul 16, 2013 at 4:09 PM, Carlos M. martinez <[email-masked]> wrote: