Subject: [weirds] weirds implementation survey

From: Marc Blanchet <[email-masked]>
Date: Tue, 30 Jul 2013 16:32:25 +0200

Hello,
during the weirds interop session saturday, a short survey was created and filled by the implementors. The following is a summary of the features that were found negative (not implemented, no plan to implement). 

Which leaves a question to the wg: Should some of these features be removed from the specs? Should some of these features be MAY instead of SHOULD or MUST?

Regards, Marc.
===========

1) Features _not_ implemented by _most_ implementations:
        draft-ietf-weirds-json-response:
         5.4 lang

        draft-ietf-weirds-using-http
         5.2 302 Response with Location:
         5.2 303 Response with Location:
         5.2 307 Response with Location:
         5.5 429 Response
         5.6 Access-Control-Allow-Origin Header
         9.3 Return Content-language Header

2) Features _not_ implemented by _some_ implementations:
          (some features here are not listed because they are specific for one kind of registry (i.e. addresses vs domains)

        draft-ietf-weirds-rdap-query
         3.4 /nameserver/<idn a-label>
         3.4 /nameserver/<idn u-label>
         3.6 /help

        draft-ietf-weirds-json-response:
         5.3 remarks
         5.6 status
        5.7 port43
         5.8 public id
         6.2.1 secureDNS dsData
         6.2.2 secureDNS keyData

_______________________________________________
weirds-interop mailing list
[email-masked]
https://www.viagenie.ca/mailman/listinfo/weirds-interop

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 30 Jul 2013 14:40:18 +0000

FWIW the features not implemented by Verisign are more "haven't gotten to it yet" than "no plan to implement". We will probably make more progress in the coming weeks. I need to talk to Dow to figure out what we can do.

Scott

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Marc Blanchet
> Sent: Tuesday, July 30, 2013 10:32 AM
> To: [email-masked] Group
> Subject: [weirds] weirds implementation survey
> 
> Hello,
> during the weirds interop session saturday, a short survey was created
> and filled by the implementors. The following is a summary of the
> features that were found negative (not implemented, no plan to
> implement).
> 
> Which leaves a question to the wg: Should some of these features be
> removed from the specs? Should some of these features be MAY instead of
> SHOULD or MUST?
> 
> Regards, Marc.
> ===========
> 
>           (some features here are not listed because they are specific
> for one kind of registry (i.e. addresses vs domains)
> 
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 30 Jul 2013 17:43:04 +0200

let's state that this survey is:
- a snapshot of some implementations
- a way to give feedback to wg and doc authors about features that might need being discussed/revisited/considered.

no binding.

Marc.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 30 Jul 2013 18:20:49 +0200

Thanks for the report and to everyone that participated.  It's great to see
all this initiative without the co-chairs even asking.

I suspect I know the answer to this, but do you folks plan on doing this
again for Vancouver?

On Tue, Jul 30, 2013 at 4:40 PM, Hollenbeck, Scott <[email-masked]
> wrote:

> FWIW the features not implemented by Verisign are more "haven't gotten to
> it yet" than "no plan to implement". We will probably make more progress in
> the coming weeks. I need to talk to Dow to figure out what we can do.
>
> Scott
>

---

From: Simon Perreault <[email-masked]>
Date: Tue, 30 Jul 2013 18:25:45 +0200

> I suspect I know the answer to this, but do you folks plan on doing this

Yes! And next time we can focus on things higher up in the stack: IDN 
support, jCard conformance, etc.

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca