Subject: [weirds] xn--*

From: Simon Perreault <[email-masked]>
Date: Thu, 13 Mar 2014 13:12:56 -0400

All,

What was the conclusion about /domains?name=xn--* again? Is it a legal
query or not?

The current text allows LDH and U-labels. Since A-labels are a subset of
LDH, xn--* would be allowed too. Is this interpretation correct?

Do we really mean LDH, or do we mean NR-LDH? (Refer to
https://tools.ietf.org/html/rfc5890#page-10 for terminology graph...)

Thanks,
Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Ernie Dainow <[email-masked]>
Date: Thu, 13 Mar 2014 14:23:33 -0400

There was a prohibition against search of labels beginning with xn-- in 
earlier drafts but was removed in draft-ietf-weirds-rdap-query-07. Here 
is one thread about it
http://www.ietf.org/mail-archive/web/weirds/current/msg03050.html

-Ernie

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 14 Mar 2014 15:21:21 +0000

> -----Original Message-----
> From: weirds [mailto:[email-masked]] On Behalf Of Simon
> Perreault
> Sent: Thursday, March 13, 2014 1:13 PM
> To: [email-masked]
> Subject: [weirds] xn--*
> 
> All,
> 

My intention was LDH.

Scott

---

From: Simon Perreault <[email-masked]>
Date: Fri, 14 Mar 2014 11:31:26 -0400

>> https://tools.ietf.org/html/rfc5890#page-10 for terminology graph...)

Thanks to the both of you!

Simon