Subject: [weirds] Response for variant domain names

From: James Mitchell <[email-masked]>
Date: Wed, 5 Mar 2014 12:58:00 +0000

All,

I mentioned changing the response for variants at the meeting yesterday. This is what I have in mind:

query: /domain/blocked-variant.tld
Response:
{
"ldhName" : "blocked-variant.tld"
"status" : “unregistered"
"links" :
[
{
"value" : "http://example.com/domain/blocked-variant.tld",
"rel" : "primary-domain”, //???
"href" : "http://example.com/domain/primary-domain.tld",
"type" : "application/rdap+json"
}
]
// optionally include the primary domain response here
}

I prefer this approach because the response is for the name present in the query, not for another name. The response clearly relates the queried name to the primary name via the status – not all registries compute or store all variants, and listing all (blocked) variants in a response is out of the question (exponential explosion). Further, a redirect does not quite work, as (active) variants have information beyond a status, for example the date time the variant became activated, and some may even contain separate delegation information (some registries accept DS per variant instead of a DNSKEY for all variant names AFAIK).

Further, the variant relation values and definitions should be updated.

  *   “unregistered” is the logical opposite of “registered” and the description should say exactly that. I disagree with the existing description as the name is “in" the registry, but not with full domain data. IMO a weirds server can stop at the registered and unregistered statuses.
  *   Unregistered names can be subdivided into two buckets describing wether the name is available for registration, “blocked” or “withheld”. IMO the distinction is relevant only in the provisioning protocol, however some weirds servers may choose to make the distinction. Unfortunately neither status is currently available (withheld is effectively available by choosing either registration restricted or open registration - the latter bring the variant relation into question IMO). I’d prefer removing “registration restricted” and “open registration” in favour of adding both “blocked” and “withheld”.

Further, it should be responsibility of the client to infer “unregistered” from “blocked” or “withheld” instead of the server returning two statuses.

Regards,
James Mitchell
ARI Registry Services

---

From: Andy Newton <[email-masked]>
Date: Wed, 12 Mar 2014 17:57:12 +0000

Have you looked at the example on page 31? That would be more useful, in my opinion. With your approach you’ll need to register “primary-domain” in the 5988 registry.

-andy

From: James Mitchell <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 5, 2014 at 8:58 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [weirds] Response for variant domain names

All,

Regards,
James Mitchell
ARI Registry Services