Subject: [weirds] rdap-query: Query Pattern Formats (ticket 7)

From: Andrew Sullivan <[email-masked]>
Date: Wed, 14 May 2014 14:27:29 -0400

Hi,

Ticket 7 is confusing to me.  I'm trying to be sure I understand: are
we trying to anchor searches around label boundaries in DNS names, or
not?  I think it will be surprising if not.

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 14 May 2014 18:38:43 +0000

> -----Original Message-----
> From: weirds [mailto:[email-masked]] On Behalf Of Andrew
> Sullivan
> Sent: Wednesday, May 14, 2014 2:27 PM
> To: [email-masked]
> Subject: [weirds] rdap-query: Query Pattern Formats (ticket 7)
> 
> Hi,
> 

In the case of DNS names, yes, but we also have entity patterns to consider. That's why the text in the ticket describes a regex approach to make the intention clear instead of focusing on label boundaries in DNS names. Entities aren't DNS names.

Scott

---

From: Andrew Sullivan <[email-masked]>
Date: Wed, 14 May 2014 14:51:32 -0400

On Wed, May 14, 2014 at 06:38:43PM +0000, Hollenbeck, Scott wrote:

> In the case of DNS names, yes, but we also have entity patterns to
> consider. 

I got that part.

> That's why the text in the ticket describes a regex
> approach to make the intention clear instead of focusing on label
> boundaries in DNS names. 

What was confusing to me was that the example _was_ using a DNS name,
and indeed the implementation described there did the wrong thing.  (I
think that might have been the point, but I wasn't sure.)  Anyway, as
long as we keep this distinction, I'm happy.  Thanks.

A

-- 
Andrew Sullivan
[email-masked]