Subject: [weirds] 答复: I-D Action: draft-ietf-weirds-json-response-07.txt

From: 贾硕 <[email-masked]>
Date: Mon, 5 May 2014 17:02:01 +0800

Dear :
	About 'Add networks and autnums to the entity object class', my
question:
		Network and autnum object also contain entity object, so it
contains a circle: entities - network - entities -...
		Does it mean that  nested 'networks and autnums' will not
contain entities? and they should only be added to 'top' entity object ? 
		Thanks

Regards
Jiashuo

-----邮件原件-----
发件人: weirds [mailto:[email-masked]] 代表
[email-masked]
发送时间: 2014年5月1日 6:23
收件人: [email-masked]
抄送: [email-masked]
主题: [weirds] I-D Action: draft-ietf-weirds-json-response-07.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
 This draft is a work item of the Web Extensible Internet Registration Data
Service Working Group of the IETF.

        Title           : JSON Responses for the Registration Data Access
Protocol (RDAP)
        Authors         : Andrew Lee Newton
                          Scott Hollenbeck
	Filename        : draft-ietf-weirds-json-response-07.txt
	Pages           : 83
	Date            : 2014-04-30

Abstract:
   This document describes JSON data structures representing
   registration information maintained by Regional Internet Registries
   (RIRs) and Domain Name Registries (DNRs).  These data structures are
   used to form Registration Data Access Protocol (RDAP) query
   responses.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-weirds-json-response/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-weirds-json-response-07

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-weirds-json-response-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
weirds mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/weirds

---

From: Andy Newton <[email-masked]>
Date: Mon, 5 May 2014 14:51:23 +0000

> contain entities? and they should only be added to 'top' entity object ? 

Well, it doesn’t make sense to include the entities in the network or autnums as their presence inside an entity is indicative of that association.

We can put some SHOULD language about not doing that for the servers, and some MUST language for clients to be ready to accept such situation if servers violate the SHOULD.

Thanks for the input.

-andy

---

From: "Linlin Zhou" <[email-masked]>
Date: Tue, 6 May 2014 08:55:30 +0800

What if the network or autnum objects include entities besides the entity in the top level? This situation may also cause this problem.

Regards

Linlin Zhou
 
发件人： Andy Newton
发送时间： 2014-05-05 22:51
收件人： 贾硕
抄送： [email-masked]
主题： Re: [weirds] I-D Action: draft-ietf-weirds-json-response-07.txt

 

Thanks for the input.
 
-andy

---

From: Andy Newton <[email-masked]>
Date: Tue, 6 May 2014 13:33:47 +0000

On May 5, 2014, at 8:55 PM, Linlin Zhou <[email-masked]<mailto:[email-masked]>> wrote:

Can you describe an actual scenario that would cause this?

-andy

---

From: "Linlin Zhou" <[email-masked]>
Date: Wed, 7 May 2014 10:47:25 +0800

I just suppose there may be a possible situation as below:

{
    "entities" :
        [
            {
                "handle": "ABC-entity",
      "roles": [ "technical" ],
      ...      "networks":             {                "handle": "XXXX-RIR",                ...                "entities" :         [                        "handle": "XYZ-entity",                        ...                        "networks":                        {                             ...                        }                  ]             }        
   },
   ...
]
}
 "handle": "ABC-entity" and  "handle": "XYZ-entity" are different entities. "XYZ-entity" could appear in the second level of entity object, and maybe there's a third or fourth level.

Linlin Zhou
 
发件人： Andy Newton
发送时间： 2014-05-06 21:33
收件人： Linlin Zhou
抄送： jiashuo; [email-masked]
主题： Re: [weirds] I-D Action: draft-ietf-weirds-json-response-07.txt

On May 5, 2014, at 8:55 PM, Linlin Zhou <[email-masked]> wrote:

-andy

---

From: Andy Newton <[email-masked]>
Date: Mon, 12 May 2014 07:14:54 +0000

I was looking for a real-world scenario. But to your point, people can get inventive in the future. I’ll include some language about not repeating objects as to avoid loops.

-andy

On May 7, 2014, at 4:47 AM, Linlin Zhou <[email-masked]<mailto:[email-masked]>> wrote:

{
    "entities" :
        [
            {
                "handle": "ABC-entity",

      ...

      "networks":

            {

                "handle": "XXXX-RIR",

                ...

                "entities" :

         [

                        "handle": "XYZ-entity",

                        ...

                        "networks":

                        {

                             ...

                        }

                  ]

            }

   },

   ...

]

}

________________________________
Linlin Zhou

发件人： Andy Newton<mailto:[email-masked]>
发送时间： 2014-05-06 21:33
收件人： Linlin Zhou<mailto:[email-masked]>
抄送： jiashuo<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题： Re: [weirds] I-D Action: draft-ietf-weirds-json-response-07.txt

-andy