Subject: [Widex] Agenda topics

From: Dean Willis <[email-masked]>
Date: Mon, 6 Feb 2006 04:26:54 -0600

Vlad suggested we start the agenda discussion with the following:

1. Widex Requirements (20 min)
	-
http://www.ietf.org/internet-drafts/draft-ietf-widex-requirements-00.txt
2. Widex Framework (30 min)
	-
http://www.ietf.org/internet-drafts/draft-stirbu-widex-framework-00.txt
3. Widex Sync Messages, discussion on alternatives (60 min):
	- W3C REX (draft should be public by IETF65)
	- IETF Simple, xml-patch-ops
	- XUpdate

Does this look OK? Is there anything else we need to address?

--
Dean

_______________________________________________
Widex mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/widex

---

From: Dean Willis <[email-masked]>
Date: Mon, 6 Feb 2006 08:51:29 -0600

On Feb 6, 2006, at 7:44 AM, Randy Fischer wrote:

> Hi  Dean, All
>
> I've been trying to tune into the widex discussions, but
> it seems that there's a lot going on off this list.
>
> Is there another list I should subscribe to?
>

None that I'm aware of. If you have something to discuss, please  
bring it up -- things have been a bit too quiet here for my tastes.

On second thought, this does keep the administrative work minimal, so  
all you people talking on the list, please stop!

Seriously, y'all (I can say that, I grew up in Texas), get involved!

--
Dean

---

From: Chaz Ginger <[email-masked]>
Date: Mon, 06 Feb 2006 10:11:41 -0500

>From looking at the requirement docs I noticed that there isn't a model
for a Widex Server behind a NAT.  Why?

Also why the model where both the server and the renderer are behind the
NAT? Is this specifically to address the notion of localized discovery?

Chuck Wegrzyn

---

From: [email-masked]
Date: Tue, 7 Feb 2006 14:35:15 +0200

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] 
>On Behalf Of ext Chaz Ginger
>Sent: 06 February, 2006 17:12
>To: Dean Willis
>Cc: [email-masked]
>Subject: [Widex] Widex Servers...
>

We haven't considered the case when the Widex Server to be behind a NAT
device to be very common. For this reason it was not included in the
scope of this document.

>Also why the model where both the server and the renderer are 
>behind the NAT? Is this specifically to address the notion of 
>localized discovery?
>

Yes, this scenario is specifically related to localized discovery.

Vlad

---

From: Chaz Ginger <[email-masked]>
Date: Tue, 07 Feb 2006 09:03:17 -0500

Vlad,

 Why wouldn't you include the case of the Widex server behind a
firewall? I would expect that to be the most common case.  Most
companies that I know and work for all use some sort of firewall. Am I
missing something?

Chuck

---

From: Chaz Ginger <[email-masked]>
Date: Tue, 07 Feb 2006 09:39:43 -0500

Vlad,

 Perhaps you can explain to me how someone like Google, MSN or Yahoo
would offer Widex based services? Are you thinking they would use a VPN?

Chuck

[email-masked] wrote:
> Yes, but in most of those scenarios you are not accessing the servers
> directly but through some kind of VPN, making the Widex Renderer part of
> the same network as the Widex Server, case which is already described in
> the document.
>
> Vlad
>
>   
>> From: ext Chaz Ginger [mailto:[email-masked]] 
>> Sent: 07 February, 2006 16:03
>> To: Stirbu Vlad (Nokia-TP-MSW/Tampere)
>> Cc: [email-masked]
>> Subject: Re: [Widex] Widex Servers...
>>
>> Vlad,
>>
>> Why wouldn't you include the case of the Widex server behind 
>> a firewall? I would expect that to be the most common case.  
>> Most companies that I know and work for all use some sort of 
>> firewall. Am I missing something?
>>
>> Chuck
>>
>>>> From: [email-masked] [mailto:[email-masked]] On 
>>>> Behalf Of ext Chaz Ginger
>>> We haven't considered the case when the Widex Server to be behind a 
>>> NAT device to be very common. For this reason it was not included in 
>>> the scope of this document.
>>>
>>>   
>>>       
>>>> Also why the model where both the server and the renderer 
>>>>         
>> are behind 
>>     
>>>> the NAT? Is this specifically to address the notion of localized 
>>>> discovery?
>>>>
>>>>     
>>>>

---

From: [email-masked]
Date: Tue, 7 Feb 2006 16:13:49 +0200

Vlad

---

From: [email-masked]
Date: Tue, 7 Feb 2006 17:53:35 +0200

It seems that I misunderstood your previous example... I thought that
you were talking about Widex servers in corporate networks. So, for
service providers like Google or Yahoo, the server front-end has a
globally routable, public IP address (and/or FQDN), similar to section
4.1.2.

Vlad 

>Sent: 07 February, 2006 16:40
> Perhaps you can explain to me how someone like Google, MSN or 
>Yahoo would offer Widex based services? Are you thinking they 
>would use a VPN?
>
>Chuck
>
>> directly but through some kind of VPN, making the Widex 
>Renderer part 
>> of the same network as the Widex Server, case which is already 
>> described in the document.
>>
>> Vlad
>>
>>   
>>> firewall? I would expect that to be the most common case.

---

From: Chaz Ginger <[email-masked]>
Date: Tue, 07 Feb 2006 11:03:16 -0500

Vlad,

 We are back at the beginning.  Having run a number of "public" sites I
can say with some amount of certainty that they are behind NATs.  I am
sure there are some webservers (well Widex servers in this case) that
sit directly on the IP network, but they are the exception rather than
the rule. 

Chuck Wegrzyn

[email-masked] wrote:
>>> Yes, but in most of those scenarios you are not accessing 
>>>       
>> the servers 
>>     
>>>>> We haven't considered the case when the Widex Server to be 
>>>>>           
>> behind a 
>>     
>>>>> NAT device to be very common. For this reason it was not 
>>>>>           
>> included in 
>>

---

From: [email-masked]
Date: Tue, 7 Feb 2006 18:40:30 +0200

But does the client/renderer communicate directly with the server or via
a proxy/gateway (even if the client is not aware of the proxy)?

Vlad

>Sent: 07 February, 2006 18:03
> We are back at the beginning.  Having run a number of 
>"public" sites I can say with some amount of certainty that 
>they are behind NATs.  I am sure there are some webservers 
>(well Widex servers in this case) that sit directly on the IP 
>network, but they are the exception rather than the rule. 
>
>Chuck Wegrzyn
>
>

---

From: Chaz Ginger <[email-masked]>
Date: Tue, 07 Feb 2006 12:15:17 -0500

Vlad, it will do port forwarding or rewrite the entire dest. IP address
(depending on the NAT). The client may or may not have a NAT or proxy,
depending.

Chuck

[email-masked] wrote:
>>> It seems that I misunderstood your previous example... I 
>>>       
>> thought that 
>>     
>>> globally routable, public IP address (and/or FQDN), similar 
>>>       
>> to section 
>>     
>>> 4.1.2.
>>>
>>> Vlad
>>>
>>>   
>>>       
>>>>>>>> the NAT? Is this specifically to address the notion of 
>>>>>>>>                 
>> localized 
>>     
>>>>>>>> discovery?
>>>>>>>>
>>>>>>>>     
>>>>>>>>         
>>>>>>>>             
>>>>>>>>                 
>>>>>>> Yes, this scenario is specifically related to localized 
>>>>>>>               
>> discovery.
>>     
>>>>>>> Vlad
>>>>>>>
>>>>>>>
>>>>>>>   
>>>>>>>       
>>>>>>>           
>>>>>>>               
>>>>>>     
>>>>>>         
>>>>>>             
>>>>>   
>>>>>       
>>>>>           
>>>>     
>>>>         
>>>   
>>>       
>>     
>
>
>

---

From: [email-masked]
Date: Wed, 8 Feb 2006 11:17:20 +0200

Chuck,

When we wrote the NAT considerations the main criteria was to indicate
that NATs can have some effects on one or more Widex components (see
Widex framework); we didn't meant this draft to include all scenarios
where NAT boxes can be envolved or deployed. It would be useful to get
more information, why he would like to see such scenario addressed.

So, in order to better understand the relation beteen the NAT device and
the Widex in your case I'd like to ask you these questions:

1. Which entity is creating or managing these port mapping/forwarding?
2. What is its relationship with the Widex components, e.g. is the
management done by a Widex component? If yes, which?
3. Is this a specific Widex problem or is a generic problem?
4. Is the work adressed in a more generic way in some other activities,
e.g. Rserpool WG
http://www.ietf.org/html.charters/rserpool-charter.html?

Thanks,
Vlad

>Sent: 07 February, 2006 19:15
>Vlad, it will do port forwarding or rewrite the entire dest. 
>IP address (depending on the NAT). The client may or may not 
>have a NAT or proxy, depending.
>
>Chuck
>
>> But does the client/renderer communicate directly with the server or 
>> via a proxy/gateway (even if the client is not aware of the proxy)?
>>
>> Vlad
>>
>>   
>"public" sites 
>>> I can say with some amount of certainty that they are 
>behind NATs.  I 
>>> am sure there are some webservers (well Widex servers in this case) 
>>> that sit directly on the IP network, but they are the exception 
>>> rather than the rule.
>>>
>>> Chuck Wegrzyn
>>>
>>>
>>>>> would offer Widex based services? Are you thinking they 
>would use a 
>>>>> VPN?
>>>>>
>>>>> Chuck
>>>>>