Subject: Re: [woes] WOES Charter Proposal

From: Stephen Farrell <[email-masked]>
Date: Thu, 16 Jun 2011 21:14:20 +0100

I guess I'd worry about the added time if its a dependency but maybe there're ways around that. (Developing new schema stuff sounds to me like a slooow thing;-)

S

On 16 Jun 2011, at 20:43, "Peter Saint Andre" <[email-masked]> wrote:

> Yes, that seems not unreasonable.
> 
> ----- Original Message -----
> From: Joe Hildebrand
> To: Stephen Farrell <[email-masked]>
> Cc: Mike Jones <[email-masked]>; Tschofenig, Hannes (NSN - FI/Espoo) <[email-masked]>; ext Manger, James H <[email-masked]>; Sean Turner <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; Peter Saint Andre; Pete Resnick <[email-masked]>
> Sent: Thu Jun 16 12:21:56 2011
> Subject: Re: [woes] WOES Charter Proposal
> 
> Agree that 4 is scope creep that is outside of the scope of normal security
> area stuff, but it's likely to be a prereq.  I'm fine with dropping it from
> the charter, potentially getting support from the Apps ADs to move stuff
> like JSON Schema through the Apps AWG.
> 
> 
> On 6/16/11 11:51 AM, "Stephen Farrell" <[email-masked]> wrote:
> 
>> 
>> 3 & 4 there look a bit like scope-creep to me
>> 
>> Why are they absolutely needed?
>> 
>> S.
>> 
>> On 16/06/11 18:33, Joe Hildebrand wrote:
>>> Slight tweaks
>>> 
>>> 
>>> On 6/16/11 11:26 AM, "Mike Jones" <[email-masked]> wrote:
>>> 
>>>>    1) A JSON-based method of applying digital signatures and keyed message
>>>> digests to data that may represent JSON data structures.
>>> 
>>> ... may represent arbitrary data, including JSON data structures and text
>>> 
>>>>    2) A JSON-based method of applying encryption to data that may represent
>>>> JSON data structures.
>>> 
>>> Same as 1) above.  Not just for JSON.
>>> 
>>>> Separately, we may want to consider whether the following should be in
>>>> scope:
>>>> 
>>>>    3) A JSON-based method of representing public keys.
>>>> 
>>>> Also, please update and/or add these references (some were out of date, some
>>>> were missing):
>>> 
>>> Let's also add:
>>> 
>>> 4) Any JSON-specific prerequisite tooling such as JSON Schema
>>> 
>>> And add draft-zyp-json-schema as a reference.  I CC'd Kris Zyp to see if
>>> he's ok with that.  Kris: this might be a chance for a WG to pick up JSON
>>> Schema if you like.
>>> 
> 
> -- 
> Joe Hildebrand
>

---

From: Joe Hildebrand <[email-masked]>
Date: Thu, 16 Jun 2011 14:29:35 -0600

Kris has most of what we need already in his JSON Schema draft.

On 6/16/11 2:14 PM, "Stephen Farrell" <[email-masked]> wrote:

> I guess I'd worry about the added time if its a dependency but maybe there're
> ways around that. (Developing new schema stuff sounds to me like a slooow
> thing;-)
> 
> S
> 
>> Cc: Mike Jones <[email-masked]>; Tschofenig, Hannes (NSN -
>> FI/Espoo) <[email-masked]>; ext Manger, James H
>> <[email-masked]>; Sean Turner <[email-masked]>;
>> [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; Peter
>> Saint Andre; Pete Resnick <[email-masked]>

-- 
Joe Hildebrand

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 16 Jun 2011 15:03:27 -0600

Sure, it seems reasonable to discuss draft-zyp-json-schema-03 in the
Apps Area. It recently expired, so I'll ping the authors about bringing
it back to life.

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 16 Jun 2011 19:31:56 -0600

On 6/16/11 3:24 PM, Kris Zyp wrote:
> On 6/16/2011 3:03 PM, Peter Saint-Andre wrote:
> Yes, that would be great to see JSON Schema moved under a WG. We are
> currently working on draft 04, although at this point things have very
> much stabilized and most of the updates we are doing are editorial. We
> can try to speed that up if need be.
> Thanks,
> Kris

Hi Kris,

It's good to hear that you're still working on this spec. I'll contact
you and Gary offlist about how to proceed.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/