Subject: [woes] Proposed JOSE Charter

From: "Richard L. Barnes" <[email-masked]>
Date: Wed, 17 Aug 2011 13:34:41 -0400

Dear ADs,

Please find below an updated charter proposal for a working group on JSON integrity and encryption.  Based on working group discussions, I believe there is consensus around the current text.  

Changes from <http://www.ietf.org/mail-archive/web/woes/current/msg00160.html>:
-- Moved milestone dates forward 5 months
-- Changed "signing" to "integrity protection", to encompass asymmetric and symmetric

Thanks,
--Richard

Javascript Object Signing and Encryption (jose)
=================================================

Background 
----------

Javascript Object Notation (JSON) is a text format for the serialization of structured data described in RFC 4627. The JSON format is often used for serializing and transmitting structured data over a network connection. With the increased usage of JSON in protocols in the IETF and elsewhere, there is now a desire to offer security services such as encryption, digital signatures, and message authentication codes (MACs) for data that is being carried in JSON format.

Different proposals for providing such security services have already been defined and implemented. This Working Group's task is to standardize two security services, integrity protection (signature and MAC) and encryption, in order to increase interoperability of security features between protocols that use JSON.  The Working Group will base its work on well-known message security primitives (e.g., CMS), and will solicit input from the rest of the IETF Security Area to be sure that the security functionality in the JSON format is correct.

This group is chartered to work on four documents:

1) A Standards Track document specifying how to apply JSON-structured integrity protection to data, including (but not limited to) JSON data structures.  "Integrity protection" includes public-key digital signatures as well as symmetric-key MACs.

2) A Standards Track document specifying how to apply a JSON-structured encryption to data, including (but not limited to) JSON data structures.

3) A Standards Track document specifying how to encode public keys as JSON-structured objects.

4) A Standards Track document specifying mandatory-to-implement algorithms for the other three documents.

The working group may decide to address one or more of these goals in a single document, in which case the concrete milestones for signing/encryption below will both be satisfied by the single document.

Goals and Milestones 
--------------------

Jan 2012    Submit JSON object integrity document as a WG item.

Jan 2012    Submit JSON object encryption document as a WG item.

Jan 2012    Submit JSON key format document as a WG item.

Jan 2012    Submit JSON algoritm document as a WG item.

Jun 2012    Start Working Group Last Call on JSON object integrity document.

Jun 2012    Start Working Group Last Call on JSON object encryption document.

Jun 2012    Start Working Group Last Call on JSON key format document.

Jun 2012    Start Working Group Last Call on JSON algorithm document.

Jul 2012    Submit JSON object integrity document to IESG for consideration as 
Standards Track document.

Jul 2012    Submit JSON object encryption document to IESG for consideration 
as Standards Track document.

Jul 2012    Submit JSON key format document to IESG for consideration 
as Standards Track document.

Jul 2012    Submit JSON algorithm document to IESG for consideration 
as Standards Track document.

---

From: "Paul C. Bryan" <[email-masked]>
Date: Wed, 17 Aug 2011 11:29:57 -0700

+1

On Wed, 2011-08-17 at 13:34 -0400, Richard L. Barnes wrote:

> _______________________________________________
> woes mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/woes

---

From: Joe Hildebrand <[email-masked]>
Date: Thu, 18 Aug 2011 00:20:28 -0700

+1

On 8/17/11 10:34 AM, "Richard L. Barnes" <[email-masked]> wrote:

> Dear ADs,
> 
> Please find below an updated charter proposal for a working group on JSON
> integrity and encryption.  Based on working group discussions, I believe there
> is consensus around the current text.
> 
> Changes from 
> <http://www.ietf.org/mail-archive/web/woes/current/msg00160.html>:
> Javascript Object Notation (JSON) is a text format for the serialization of
> structured data described in RFC 4627. The JSON format is often used for
> serializing and transmitting structured data over a network connection. With
> the increased usage of JSON in protocols in the IETF and elsewhere, there is
> now a desire to offer security services such as encryption, digital
> signatures, and message authentication codes (MACs) for data that is being
> carried in JSON format.
> 
> Different proposals for providing such security services have already been
> defined and implemented. This Working Group's task is to standardize two
> security services, integrity protection (signature and MAC) and encryption, in
> order to increase interoperability of security features between protocols that
> use JSON.  The Working Group will base its work on well-known message security
> primitives (e.g., CMS), and will solicit input from the rest of the IETF
> Security Area to be sure that the security functionality in the JSON format is
> correct.
> 
> 1) A Standards Track document specifying how to apply JSON-structured
> integrity protection to data, including (but not limited to) JSON data
> structures.  "Integrity protection" includes public-key digital signatures as
> well as symmetric-key MACs.
> 
> 2) A Standards Track document specifying how to apply a JSON-structured
> encryption to data, including (but not limited to) JSON data structures.
> 
> The working group may decide to address one or more of these goals in a single
> document, in which case the concrete milestones for signing/encryption below
> will both be satisfied by the single document.
> 
> Goals and Milestones
> --------------------
> 

-- 
Joe Hildebrand

---

From: Sean Turner <[email-masked]>
Date: Thu, 18 Aug 2011 09:01:54 -0400

Richard,

Thanks for pulling this together.

All,

I've forwarded this to the IESG secretariat for inclusion on the 
2011-08-28 IESG telechat.  Assuming all goes well with the IESG, it'll 
go out to the entire IETF and the new-work mailing list for a two week 
review period.  To ensure no surprises next week with the IESG, I've 
also added it to today's informal IESG telechat (to get first impressions).

spt

On 8/17/11 1:34 PM, Richard L. Barnes wrote:
> Changes from<http://www.ietf.org/mail-archive/web/woes/current/msg00160.html>: