Subject: [Wpack] I-D Action: draft-ietf-wpack-use-cases-00.txt

From: [email-masked]
Date: Mon, 25 Oct 2021 09:37:10 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Web Packaging WG of the IETF.

        Title           : Use Cases and Requirements for Web Packages
        Authors         : Jeffrey Yasskin
                          Felipe Erias
	Filename        : draft-ietf-wpack-use-cases-00.txt
	Pages           : 23
	Date            : 2021-10-25

Abstract:
   This document lists use cases for signing and/or bundling collections
   of web pages, and extracts a set of requirements from them.

Discussion Venues

   This note is to be removed before publishing as an RFC.

   Discussion of this document takes place on the Web Packaging Working
   Group mailing list ([email-masked]), which is archived at
   https://mailarchive.ietf.org/arch/browse/wpack/.

   Source for this draft and an issue tracker can be found at
   https://github.com/wpack-wg/use-cases.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-wpack-use-cases/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-wpack-use-cases-00.html

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Sean Turner <[email-masked]>
Date: Mon, 25 Oct 2021 15:52:04 -0400

Jeffrey and Felipe -> thanks for getting this in under the deadline.

WG -> This issue basically draft-yasskin-wpack-use-cases-02. Now it is time to move the controversial use cases to an informative appendix. Note that the WG repo is located here:
https://github.com/wpack-wg/use-cases

Cheers,
spt

> On Oct 25, 2021, at 12:37, [email-masked] wrote:
> 
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Larry Masinter <[email-masked]>
Date: Mon, 25 Oct 2021 13:01:57 -0700

I thought the use cases weren't destined to be published as an RFC. So what
is the point of moving "controversial" use cases?
Even if it were published as an Informational RFC .

I think my suggestions about MIME multipart were misunderstood. I wasn't
suggesting you *use* MIME multipart.
I was suggesting you *add* the use cases for MIME multipart as potential use
cases for WPACK packaging --
For MHTML/related (which you cover), for form-data (which you don't), for
alternative (which you might have),
etc
--
https://LarryMasinter.net https://interlisp.org

> -----Original Message-----
> From: Wpack <[email-masked]> On Behalf Of Sean Turner
> Sent: Monday, October 25, 2021 12:52 PM
> To: WPACK List <[email-masked]>
> Subject: Re: [Wpack] I-D Action: draft-ietf-wpack-use-cases-00.txt
> 
> WG -> This issue basically draft-yasskin-wpack-use-cases-02. Now it is
time to
> move the controversial use cases to an informative appendix. Note that the
> WG repo is located here:
> > Internet-Draft directories: http://www.ietf.org/shadow.html or
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Wpack mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/wpack