Subject: Re: definitions and use of "transparency" in the taxonomy

From: "Gary Tomlinson" <[email-masked]>
Date: Wed, 05 Jan 2000 14:34:22 -0700

>>> <[email-masked]> 01/05/00 12:39PM >>>

... excerpt

> I don't buy the argument that "transparent proxy" is the common term
> for this in the industry.  I am in this industry and yet I have never
> heard that term used outside a wrec-related discussion, aside from its
> use to indicate a non-transforming proxy of HTTP content within RFC 2616.
> Given that the definition conflicts with that of "proxy" under HTTP and
> therefore conflicts with the HTTP protocol requirements placed on a
> proxy, I think it is foolish to use this term within specifications
> that are supposed to be subsidiary to the HTTP standard.  It therefore
> doesn't make sense for an IETF RFC to recommend that it be used within
> the taxonomy.

Albeit HTTP is a major protocol in the web, but its not the only one.  The WREC 
taxonomy covers the broader web including other protocols such as FTP, WCCP, NECP,
ICP, etc. In fact, there are even streaming media caches now, so the web is getting more
comprehensive everyday.  Given this broader  scope, I don't see how the taxonomy  can be 
subiduary to RFC2616.  However, I agree that terms should not be invented that conflict with 
existing terminology, especially those in RFC2616.  We have made an attempt to distinguish 
the terms "transparent proxy" and "transparent cache" by classifying them as "network
transparent proxy".  Apparently this term is still quite controversial since it doesn't really 
reflect the semantics of this mechanism.  We are actively seeking help in creating a 
term and clarifying it unambiguously per the IESG review.

Gary

---

From: "B. Scott Michel" <[email-masked]>
Date: Sun, 09 Jan 2000 18:19:44 -0800

Marketdroids aside (an unfortunately necessary evil in these dark
times),
perhaps the draft might contrive another term and mention that it is
AKA "transparent cache" and "transparent proxy".

This would allow us to define a more precise term that doesn't conflict
with the established standards and yet allows even the marketdroids to
translate to tech.

Just my $0.02.

-scooter
 (who still feels rather partisan about "transparent" anythings... :-)

-- 
Scott Michel                    |
UCLA Computer Science           |
PhD Graduate Student            |      Futuaris nisi irrisus ridebis