Subject: RE: Candidate re-charter/new WG

From: "Maciocco, Christian" <[email-masked]>
Date: Fri, 3 Nov 2000 13:34:11 -0800

Are these sessions/BOFs already scheduled? I didn't find anything at
http://www.ietf.org/meetings/agenda.html

Thanks
Christian

> -----Original Message-----
> From: Ian Cooper [mailto:[email-masked]]
> Sent: Friday, November 03, 2000 12:10 PM
> To: [email-masked]
> Cc: Patrik Fältström; Ned Freed; [email-masked];
> [email-masked]
> Subject: Candidate re-charter/new WG
> 
> 
> Now that we appear to have gotten to the end of the WREC work 
> items (there 
> will be a new version of the Known Problems document - just 
> changing the 
> order of things as an outcome of the Pittsburgh meeting - 
> submitted in the 
> next few days), we need to decide how to move on.
> 
> Below is a candidate (re)charter to take WREC forward as the "Web 
> Infrastructure" group (thanks to those who have given input of their 
> varying types).  As you'll see, the idea is to take on two 
> work items that 
> we believe are essential for web infrastructure going forward.
> 
> There is some cross over with the invalidation protocol with the CDNP 
> folks.  Since such a protocol is applicable to both areas, 
> and since the 
> CDNP folks look to have plenty of other interesting things to 
> work on, 
> WREC/WEBI appears to be a good place to work on this essential issue.
> 
> Likewise, there is some degree of cross over with the intermediary 
> discovery protocol.  In order to have some hope of moving away from 
> interception proxy environments, we need to help user agents find 
> intermediates (proxies, extensible proxies, surrogates).  
> Given that this 
> is an area where two proposed WGs (CDNP, OPES) would also 
> have an interest, 
> and since it doesn't appear to be directly in scope for 
> either, we feel 
> that WREC/WEBI is the best place for this.
> 
> Why the name change?  As (caching) proxies and surrogates 
> become essential 
> components in the web infrastructure we need to examine interactions 
> between these systems.  "Web Replication and Caching" doesn't seem a 
> sufficiently descriptive group name.  There also appears to 
> be a general 
> feeling of WREC=bad (and the name when spoken doesn't help 
> any) that we'd 
> like to try and move away from.
> 
> At present it's not totally clear whether we should be going 
> direct to a 
> working group in San Diego, or whether we should go through a 
> BoF stage to 
> discuss the area and determine whether the group is necessary 
> (and if not 
> where the work items should be handled).
> 
> Apologies for the short notice, but obviously we need to get 
> an idea of 
> what we're doing in time to request a meeting in San Diego.  
> Truncating the 
> distribution to the WREC list (the "webi" list has *not* been 
> set up yet) 
> would probably be a good idea.  (I'd set a Reply-To but I 
> don't know how to 
> drive that part of my mail agent ;-) )
> 
> Comments please!
> 
> 
> --------------------------->8---------------------------------
> ----------
> 
> Web Infrastructure (webi)
> 
> Co-chairs:
>     Mark Nottingham <[email-masked]>
>     Ian Cooper <[email-masked]>
> 
> Mailing Lists: [TENTATIVE]
>     General Discussion: [email-masked]
>     To Subscribe: [email-masked]
>     Archive: ftp://ftp.ietf.org/ietf-mail-archive/webi
> 
> Description of Working Group:
> 
> This working group will address specific issues identified by 
> the WREC 
> working group in the world wide web infrastructure, providing generic 
> mechanisms which are useful in several application domains (proxies, 
> content delivery surrogates).
> 
> Work items for this group will be:
> 
> 1) An invalidation protocol to provide a strong cache 
> coherence mechanism
>     while avoiding the latency penalty of validation, usable 
> in proxy as well
>     as surrogate configurations.
> 
> 2) An intermediate service discovery mechanism, consisting of:
> 
>    a) An intermediary service description format, which describes what
>       services an intermediary or arbitrary group of intermediaries is
>       willing to provide, and
> 
>    b) A discovery protocol for locating relevant service 
> descriptions within
>       a single administrative domain.
> 
>    Both components will take into consideration current 
> practice, related
>    work in the IETF, and a reasoned set of requirements, 
> which will include
>    the need to provide a reasonable alternative to 
> interception proxies.
> 
> Service discovery, and other issues pertaining to 
> coordination between 
> multiple administrative domains are explicitly out of scope 
> of this group.
> 
> Protocols associated with the provisioning of value added services, 
> including the vectoring of adaptation requests to other 
> devices, is also 
> out of scope for this group.
> 
> 
> Goals and Milestones:
> 
> Feb 01: Requirements document for intermediary discovery and 
> description
> Feb 01: First draft invalidation protocol
> Mar 01: Meet at Minneapolis IETF
> Apr 01: First draft intermediary discovery protocol
> Jul 01: First draft intermediary description mechanism
> Aug 01: Meet at London IETF
> Dec 01: Invalidation protocol finalized
> Dec 01: Salt Lake City
> Jan 02: Intermediary discovery protocol finalized
> Mar 02: Intermediary description mechanism finalized
> Apr 02: Re-charter
> 
> 
>

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 3 Nov 2000 16:26:47 -0800

No. All of them intend to meet in San Diego, but are still in various stages
of the meeting request process (AFAIK).

The immediate issue with WEBI is whether to request a WG and hence a WG
meeting, or a BoF. Because WEBI's work is a direct outgrowth of WREC, it is
possible to re-charter WREC into WEBI as a WG. OTOH, it might be more
appropriate to request a BoF to determine interest in the work items listed,
if it isn't clear that these are appropriate.

We believe they are appropriate, neccessary and widely interesting work
items, based on the output of WREC as well as other work in these areas.
However, it would be Good if we could get clear statements of support (or
dissent) for this charter from interested parties.

Simple "yes, that seems like a good idea/no, don't go and do that" answers
would be much appreciated; we just want to gather some amount of consensus
going into this.

-- 
Mark Nottingham, Research Scientist
Akamai Technologies (San Mateo, CA)

---

From: Patrik Fältström <[email-masked]>
Date: Sat, 4 Nov 2000 12:19:25 -0500

>http://www.ietf.org/meetings/agenda.html

No firm scheduling yet. I have only got a request for BOF formaly 
from OPES people, but expect others to send me a request ASAP (please 
do so!).

If you ask what day the meetings will be, the response is that I have 
reserved tuesday afternoon 4 1-hour slots for these three BOFs + one 
BOF on naming issues which spring from the URN/CNRP wgs in the IETF 
and the HANDLE/DOI projects outside of the IETF.

So, tuesday afternoon is what I aim at for meetings on these topics.

I explicitly wanted the meetings close to each other and not 
overlapping as it might happen that some tasks which at first end up 
at one meeting actually should be discussed in another. I.e. in some 
way one can see these 4 meetings as one really long one about web 
issues.

     Patrik

---

From: Patrik Fältström <[email-masked]>
Date: Sat, 4 Nov 2000 12:19:27 -0500

At 16.26 -0800 00-11-03, Mark Nottingham wrote:
>meeting, or a BoF.

Two different things: "create a wg" and "ask for a slot". The IESG 
will make this decision.

You should:

  - Request a slot (which will end up being tuesday afternoon)
  - Send in the new charter and say it is an update (to me)

IESG will decide if a BOF / new working group is needed, or if 
rechartering is the only thing which is needed.

But, of course, as always, IESG is happy to recieve input on what the 
community things. Don't let this delay you creating an agenda for the 
meeting though.

    paf