Subject: Different web pages for different browser versions

From: Jacob Palme <[email-masked]>
Date: Wed, 15 Nov 2000 11:05:00 +0800

I am not a regular participant of wrec. But I have a question
which maybe you have already solved. I tried to look into
your archives, but could not find it.

The question is that more and more web sites will chech
which browser type the user has, and deliver different
versions of a web page depending on the browser type.

How can proxies handle this, so that you deliver a cached
version only if it suits the browser capabilities of the
user?
-- 
Jacob Palme <[email-masked]> (Stockholm University and KTH)
for more info see URL: http://www.dsv.su.se/jpalme/

---

From: Patrick McManus <[email-masked]>
Date: Wed, 15 Nov 2000 08:41:57 -0500

this is really http, not whatever the heck wrec is (I just said that
to get the rhyme in.), but the server should add the 

Vary: User-Agent

header to the 1.1 response.. A 1.1 cache knows that only future
requests with the same user-agent header (and/or any other header(s)
listed in the vary response header) as the request that generated the
cached response may be satisified by that cached response. (subject to
the other normal freshness rules of course.)

[Jacob Palme: Wed, Nov 15, 2000 at 11:05:00AM +0800]

---

From: <[email-masked]>
Date: Wed, 15 Nov 2000 09:46:23 -0800 (PST)

Jacob,
	Both the CONNEG working group in the IETF and the
CCPP working group in the W3C have looked at this.  The
first step in this process is moving the decision about what
version to send away from dependencies based on User-Agent to
profiles (based on RDF in the CCPP case and prolog-like syntax
in the CONNEG case).  Those profiles can be referenced or
included in the request/response stream.  In some cases, the
proxy capabilities may even be associated with the request
so that an origin server can make a decision which includes
the transcoding capabilities of the proxy.
	For the W3C work, please see http://www.w3.org/Mobile/CCPP/ ;
for the IETF work, please see RFCs 2533, 2912, 2913, and 2938.
			regards,
				Ted Hardie

>  I am not a regular participant of wrec. But I have a question which
> maybe you have already solved. I tried to look into your archives,
> but could not find it.  The question is that more and more web sites
> will chech which browser type the user has, and deliver different
> versions of a web page depending on the browser type.  How can
> proxies handle this, so that you deliver a cached version only if it
> suits the browser capabilities of the user?  -- Jacob Palme
> <[email-masked]> (Stockholm University and KTH) for more info see
> URL: http://www.dsv.su.se/jpalme/