Subject: [XCON] Wireless Systems do not flee XML

From: adam at dynamicsoft.com (Adam Roach)
Date: Wed Jul 16 01:56:40 2003

[email-masked] [mailto:[email-masked]] writes:

> Dean made a statement during the XCON BOF that the wireless 
> guys (to which I count myself) do not want XML as it would 
> use to much bandwidth. That is in fact not true - there were 
> requirements expressed that XML is the preferred solution for 
> coding e.g. CPCP

To be clear, Dean's comments were addressing the
floor control protocol, not the policy control
protocols. In most cases, floor control is
significantly more dynamic and real-time than
policy control. If the floor control protocol
is inappropriately large, there are concerns that
the user experience on wireless networks will be
inadequate. For example, turnaround time from
requesting an empty floor to receiving notification
that it has been granted can't take too long,
or users will become frustrated and potentially
confused.

That said, we haven't yet established whether XML
is inappropriately heavy for floor control. I expect
that further work on the floor control protocol will
include an analysis of the issue.

/a

---

From: hgs at cs.columbia.edu (Henning Schulzrinne)
Date: Wed Jul 16 03:27:09 2003

In general, we probably need to distinguish two forms of overhead, 
namely the SOAP encapsulation XML and the 'real' XML.

Secondly, the evaluation may well be different for full-featured 
commands that create a floor, for example. These are likely to be used 
infrequently, so byte efficiency is somewhat secondary.

One solution is to have a trivial alternative that supports only the 
"claim floor" and can be as simple as

http://floor.example.com?f=1&o=c

Whether having two mechanisms is a good thing, I don't know. Assuming 
that this is ok, they probably must be very different in client 
complexity and message size.

---

From: rohan at cisco.com (Rohan Mahy)
Date: Wed Jul 16 07:51:22 2003

> include an analysis of the issue.

I would be quite happy with a simple TLV-encoded floor control 
protocol.  I don't think a floor control protocol needs any of the 
features of XML, or rather, I don't see any compelling reason to use 
XML to encode a floor-control protocol.

thanks,
-rohan

> /a
> _______________________________________________
> XCON mailing list
> [email-masked]
> http://www.softarmor.com/mailman/listinfo/xcon