Subject: [XCON] Wireless Systems do not flee XML

From: georg.mayer at nokia.com ([email-masked])
Date: Tue Jul 15 10:57:15 2003

Hi Dean et al,

Dean made a statement during the XCON BOF that the wireless guys (to which I count myself) do not want XML as it would use to much bandwidth. That is in fact not true - there were requirements expressed that XML is the preferred solution for coding e.g. CPCP, as this would allow us XML also for XCON purposes and we would not need to implement the next encoder in our devices. This was actually a requirement that clearly came out from the last 3G CN1 meeting.

The only thing that we also wanted to discuss is the possiblity and the hows and whens for compressing CPCP / XCAP specific information.

Best regards, let's go to the social
Georg

---

From: dwillis at dynamicsoft.com (Dean Willis)
Date: Wed Jul 16 03:16:50 2003

Georg said:

> Dean made a statement during the XCON BOF that the wireless 
> guys (to which I count myself) do not want XML as it would 
> use to much bandwidth. That is in fact not true - there were 
> requirements expressed that XML is the preferred solution for 
> coding e.g. CPCP, as this would allow us XML also for XCON 
> purposes and we would not need to implement the next encoder 
> in our devices. This was actually a requirement that clearly 
> came out from the last 3G CN1 meeting.

I was specifically worried about XML for floor management in a conference.

Within the "other" mobile community (3GPP2 -- CDMA) everybody that I've
talked is of the belief that the floor control messages for PoC (push talk
over cellular) will need to be down in the 20-30 byte range (including
headers after ROHC) to work optimally with CDMA2000. This allows them to
transmit in a single short data burst. 

XML for configuration and other non-real-time data seems to be ok.

--
Dean