Subject: [XCON] Aggregate requests in on koskelainen-xcon-cpcp-reqs-01

From: "Eric Burger" <[email-masked]>
Date: Fri, 7 Nov 2003 16:19:35 -0500

The document doubles many of the requirements by saying:

REQ-n        It MUST be possible to do X.

REQ-(n+1)    It MUST be possible to do X to many Y in a single operation.

First question: by single operation, is the goal to reduce the number of messages (e.g., mass ejecting 100 people using 1 message instead of 100)?  Or, is the goal to have atomic transactions (e.g., if I can't change all of the privileges for all of the users in the update request, fail the entire request).

If it is the former, why not just state one requirement to be able to batch requests?  That cuts down on the number of requirements by almost half.

If it is the latter, why not just state one requirement to have atomic multiple operation transactions?

The benefit is you can then do both, if that is what the client really needs.

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: [email-masked]
Date: Tue, 11 Nov 2003 04:36:12 +0200

It is the former. They are split into 2 requirements because we felt that they are not tied together, solution wise and do not need to be solved together.

Regards,
Hisham

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of ext
> Eric Burger
> Sent: Friday, November 07, 2003 11:20 PM
> To: [email-masked]
> Subject: [XCON] Aggregate requests in on koskelainen-xcon-cpcp-reqs-01
> 
> 
> First question: by single operation, is the goal to reduce 
> the number of messages (e.g., mass ejecting 100 people using 
> 1 message instead of 100)?  Or, is the goal to have atomic 
> transactions (e.g., if I can't change all of the privileges 
> for all of the users in the update request, fail the entire request).
> 
> If it is the former, why not just state one requirement to be 
> able to batch requests?  That cuts down on the number of 
> requirements by almost half.
> 
> If it is the latter, why not just state one requirement to 
> have atomic multiple operation transactions?
>

---

From: "Eric Burger" <[email-masked]>
Date: Mon, 10 Nov 2003 22:18:19 -0500

Looking at the requirements, I can't figure out why a particular requirement would have different implementation requirements than another.

> From: [email-masked] [mailto:[email-masked]]
> Sent: Mon, November 10, 2003 9:36 PM
> To: Eric Burger; [email-masked]
> Subject: RE: [XCON] Aggregate requests in on
> koskelainen-xcon-cpcp-reqs-01
> 
> 
> It is the former. They are split into 2 requirements because 
> we felt that they are not tied together, solution wise and do 
> not need to be solved together.
> 
> Regards,
> Hisham
>