Subject: [XCON] Comment on floor control requirements

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Tue, 11 Nov 2003 04:48:24 -0000

In draft-koskelainen-xcon-floor-control-req-00 there are hints that some sort of queue exists when the number of participants requesting the floor exceeds the number of participants allows simultaneous use of the floor.

For example REQ-10 refers to the number of simultaneous floor holders, and REQ-11 refers to passing the floor to the next in line after a time interval.

It would appear to me that this queuing needs to be more extensively discussed in the above requirements document. 

Firstly REQ-11 implies that the queue is first in, first out (and I stress that this is an implication), whereas in real life certain users may preempt others in the queue. 

Secondly it would appear to be appropriate to have requirements for the floor control chair to have requirements for manipulating the queue, e.g. to designate the order of obtaining the floor, to clear the queue and so on.

Additionally, perhaps other participants may also require visibility of the queue.

My proposal would therefore to update the draft to explicitly define this queue concept, and then to revise the requirements to reflect the existence of the queue, and add requirements for the manipulation of the queue.

regards

Keith

Keith Drage
Lucent Technologies
[email-masked]
tel: +44 1793 776249

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: Marcus Brunner <[email-masked]>
Date: Tue, 11 Nov 2003 10:16:14 -0600

keith,

> It would appear to me that this queuing needs to be more extensively
> discussed in the above requirements document.
>

I think there should not be any restrictions on what queuing is needed. The 
mechanisms to be standardized should be free of any of these assumtions.

> Firstly REQ-11 implies that the queue is first in, first out (and I
> stress that this is an implication), whereas in real life certain users
> may preempt others in the queue.
>
> Secondly it would appear to be appropriate to have requirements for the
> floor control chair to have requirements for manipulating the queue, e.g.
> to designate the order of obtaining the floor, to clear the queue and so
> on.
>

I assume this to be implementation specific.

> Additionally, perhaps other participants may also require visibility of

that is good point, In draft-brunner I called it state awareness (so 
participants should be able to get information about the current state of 
the floor control mechnisms including also the queue state.

> My proposal would therefore to update the draft to explicitly define this
> queue concept, and then to revise the requirements to reflect the
> existence of the queue, and add requirements for the manipulation of the
> queue.
>

I oppose, this is really implementation/application specific and should not 
influence the design of the mechnism.

Marcus

> tel: +44 1793 776249

--------------------------------------
Dr. Marcus Brunner
Network Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
Phone: +49 (0) 6221 905 11 29
Mobile: +49 (0) 163 275 17 43
personal home page: http://www.brubers.org/marcus