Subject: AW: [XCON] CPCP requirements to support IMS

From: Leis Peter <[email-masked]>
Date: Thu, 20 Nov 2003 12:42:54 +0100

hi Georg,

I think XCAP is not the right decission for floor control. Floor control certainly has some real time requirements while XCAP is a protocol for data administration. In addition the decission to use XCAP (over Ut interface) for floor control is not yet made within 3GPP. 

Another issue is compression. As far as I know there is no procedure for compression of XCAP (at least up till now). But for floor control which might happen quite frequently during an active conference we need a protocol that can be compressed.

Peter

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]]
Gesendet: Donnerstag, 20. November 2003 10:51
An: [email-masked]
Betreff: [XCON] CPCP requirements to support IMS

Hello,

as the CPCP issue is one very crucial for 3GPP, I would like to summarize some requirements from the IMS side. Please be aware that these are not official 3G requirements, but are my personal summary. I am the rapporteur of the technical specifications for IMS Conferencing protocol (stage 3) and collected some of the issues raised during the last meetings.

The time frame for finishing IMS conferencing in 3GPP are quite tight again. SIP related stuff for Conferencing is mostly done in the IMS spec, but for CPCP there is a complete lack and we are desperately looking for progress. The below issues should be decided on until latest mid of February, so that we have a chance to go on with conferencing in IMS.

Here we go:

- creation of a conference URI as well as of a conference-factory URI

Well that's so basic - I do not want to go through all the requirements which are already there 

- indication that user is automatically unsubscribed from conference event subscription when user is leaving

This saves a lot of bandwidht on the air interface, as the user will just receive a NOTIFY with a Subscription-State header set to "terminated" that additionally indicates that it has left the conference (two SIP messages) instead of receiving the notification about his/her own leaving, sending a un-SUBSCRIBE, receiving another NOTIFY (6 messages). 

- Dial-Out lists which state that the focus should either send INVITE or REFER to the invited user. 

Both options (INVITE and REFER) are needed in order to allow different charging models. 

It is not feasable that e.g. the moderator sends the REFER requests to the invited users, as this will put high load to the air interface (REFER + 2 NOTIFYs = 6 messages per REFERED-to user)

- CPCP solution must be based on XCAP

The interface for Data Manipulation in 3GPP IMS is the Ut interface. Over that the following issues will be handled:
	- Presence related data manipulation
	- CPCP 
	- Floor Control
	- generic data manipulation

In order to have one common interface, that could also be handled by the UE (and the related service applications in the network) in a common way, it is highly required that all these issues are solved by one protocol. 

This would also gurantee common security, charging, etc. models for the Ut interface.

Please ask if you need information on the IMS related issues. 

Thanks and best regards
Georg

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: Roland Hedberg <[email-masked]>
Date: Fri, 21 Nov 2003 10:21:18 +0100

Leis Peter wrote:

> I think XCAP is not the right decission for floor control. Floor control 
 > certainly has some real time requirements while XCAP is a protocol 
for data
 > administration. In addition the decission to use XCAP (over Ut 
interface) for
 > floor control is not yet made within 3GPP.
> 
> Another issue is compression. As far as I know there is no procedure for 
 > compression of XCAP (at least up till now). But for floor control which
 > might happen quite frequently during an active conference we need a 
protocol that can be compressed.

Isn't you really putting forth that the amount of bytes moved about by 
CPCP should be kept lo ?
If the choice was a protocol like XCAP then compression might be 
necessary but if another protocol was choosen then it might not be an issue.

-- Roland