Subject: RE: AW: [XCON] CPCP requirements to support IMS

From: [email-masked]
Date: Fri, 21 Nov 2003 11:30:38 +0200

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of ext
> Roland Hedberg
> Sent: 21.November.2003 11:21
> To: Leis Peter; [email-masked]
> Subject: Re: AW: [XCON] CPCP requirements to support IMS
> 
> 
> Leis Peter wrote:
> 
> > I think XCAP is not the right decission for floor control. 
> Floor control 
>  > certainly has some real time requirements while XCAP is a protocol 
> for data
>  > administration. In addition the decission to use XCAP (over Ut 
> interface) for
>  > floor control is not yet made within 3GPP.
> > 
> > Another issue is compression. As far as I know there is no 
> procedure for 
>  > compression of XCAP (at least up till now). But for floor 
> control which
>  > might happen quite frequently during an active conference 
> we need a 
> protocol that can be compressed.
> 
> Isn't you really putting forth that the amount of bytes moved 
> about by 
> CPCP should be kept lo ?
> If the choice was a protocol like XCAP then compression might be 
> necessary but if another protocol was choosen then it might 
> not be an issue.

The issue will only go away if you choose a binary protocol. Choosing any text based protocol will introduce the same issue.

Regards,
Hisham 

> 
> -- Roland
> 
> 
> _______________________________________________
> XCON mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/xcon
> 

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: Roland Hedberg <[email-masked]>
Date: Fri, 21 Nov 2003 10:46:53 +0100

[email-masked] wrote:
>>about by CPCP should be kept lo ?
> The issue will only go away if you choose a binary protocol. 
 > Choosing any text based protocol will introduce the same issue.

Not going into details here but not all text based protocols are as 
volumnious as the XML based.

Still, the requirement should be about the size and not about 
compression or not. That might be an issue but only if a talkative 
protocol was choosen for other reasons.

-- Roland