Subject: [XCON] I-D ACTION:draft-ietf-xcon-conference-scenarios-00.txt

From: [email-masked]
Date: Thu, 18 Dec 2003 15:28:54 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Centralized Conferencing Working Group of the IETF.

	Title		: Conferencing Scenarios
	Author(s)	: R. Even
	Filename	: draft-ietf-xcon-conference-scenarios-00.txt
	Pages		: 15
	Date		: 2003-12-18
	
This document describes SIP conferencing scenarios.  It will describe
   basic and advance conferencing scenarios.  These conferencing
   scenarios will help with definition and evaluation of the
   requirements for SIP conferencing framework and the protocol
   associated with the framework.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-xcon-conference-scenarios-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-xcon-conference-scenarios-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-xcon-conference-scenarios-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: [email-masked]
Date: Thu, 18 Dec 2003 15:06:01 -0600

Hello,

In section 4.1 of the draft ( Video mixing scenarios ), it says " For video the user selects one of a set of pre-defined video presentations offered by the server". Does it mean that end user in the conference knows what all streams the server can offer? Does this pre-defined video list changes dynamically ?...For example Particpant A is getting video of particpant B, but decides to watch a mosaic of participant B and C, it should be able to do so...The server should be able to mix the streams of B and C and send one stream to A...

Umesh
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of ext
[email-masked]
Sent: Thursday, December 18, 2003 2:29 PM
Cc: [email-masked]
Subject: [XCON] I-D ACTION:draft-ietf-xcon-conference-scenarios-00.txt

	

Send a message to:
	[email-masked].
In the body type:

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: "Even, Roni" <[email-masked]>
Date: Mon, 22 Dec 2003 09:18:36 +0200

Umesh,
The video mixing scenarios describe typical video conferencing scenarios. An
participants with the right privilege level may select the screen layout he
wants to have. The selection may be for his own view or for the whole
conference view. The availability of such functionality per participant or
per conference is dependent on the mixer functionality. This functionality
is not saying what is the content (whose video is mixed) but on the layout.
Layout may be static during the conference or may be changed dynamically
based on user selection (e.g. start with a single view and request a quad
view later) or the layout can change automatically based on the number of
participants in the conference.
The selection of the layout is independent from the selection of which
stream is seen in each sub-window

Roni Even

*************************************
Roni Even

Polycom Israel

Tel: +972-3-9251200
Cell: +972-55-481099
email:[email-masked]
*******************************************

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, December 18, 2003 11:06 PM
To: [email-masked]
Subject: RE: [XCON] I-D ACTION:draft-ietf-xcon-conference-scenarios-00.txt

Hello,

In section 4.1 of the draft ( Video mixing scenarios ), it says " For video
the user selects one of a set of pre-defined video presentations offered by
the server". Does it mean that end user in the conference knows what all
streams the server can offer? Does this pre-defined video list changes
dynamically ?...For example Particpant A is getting video of particpant B,
but decides to watch a mosaic of participant B and C, it should be able to
do so...The server should be able to mix the streams of B and C and send one
stream to A...

Umesh
-----Original Message-----

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Centralized Conferencing Working Group of
the IETF.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-xcon-conference-scenarios-00.
txt

Send a message to:
	[email-masked].
In the body type:

---

From: [email-masked]
Date: Mon, 22 Dec 2003 17:39:52 -0600

Hello Roni,

Thanks for your input..So basically the user can decide the contents of the screen layout, but the screen layout can be static or can be changed dynamically based on user selection. In nutshell can the end user  say i want to see user  A, B, C in mosaic ( assuming the conferencing server supports this kind of layout) to the conferencing server?. Each user can send its own request for content and for layout. In that case the mixer has to support the functionality to select the desired layout and select the particular streams the end user is asking for.

And in case the conferencing server doesnt support this kind of layout, what is the protocol to inform the client..I dont know if this would fall under media control policy.. 

BR 
Umesh
-----Original Message-----
From: ext Even, Roni [mailto:[email-masked]]
Sent: Monday, December 22, 2003 1:19 AM
To: Chandra Umesh (NRC/Dallas); [email-masked]
Subject: RE: [XCON] I-D
ACTION:draft-ietf-xcon-conference-scenarios-00.txt

Umesh,

Roni Even

Polycom Israel

Tel: +972-3-9251200
Cell: +972-55-481099

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, December 18, 2003 11:06 PM
To: [email-masked]
Subject: RE: [XCON] I-D ACTION:draft-ietf-xcon-conference-scenarios-00.txt

Hello,

Umesh
-----Original Message-----

	

Send a message to:
	[email-masked].
In the body type:

---

From: "Even, Roni" <[email-masked]>
Date: Tue, 23 Dec 2003 08:35:16 +0200

Hi,
The participant will need to select first the layout ( 3 sub windows in your
example) and then select who will be seen in the windows by defining the
mix. The media policy control protocol should allow this.
Roni Even

VP Product Planning
Polycom Israel

Tel: +972-3-9251200
Cell: +972-55-481099

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, December 23, 2003 1:40 AM
To: [email-masked]; [email-masked]
Subject: RE: [XCON] I-D ACTION:draft-ietf-xcon-conference-scenarios-00.txt

Hello Roni,

Thanks for your input..So basically the user can decide the contents of the
screen layout, but the screen layout can be static or can be changed
dynamically based on user selection. In nutshell can the end user  say i
want to see user  A, B, C in mosaic ( assuming the conferencing server
supports this kind of layout) to the conferencing server?. Each user can
send its own request for content and for layout. In that case the mixer has
to support the functionality to select the desired layout and select the
particular streams the end user is asking for.

And in case the conferencing server doesnt support this kind of layout, what
is the protocol to inform the client..I dont know if this would fall under
media control policy.. 

BR 
Umesh
-----Original Message-----
From: ext Even, Roni [mailto:[email-masked]]
Sent: Monday, December 22, 2003 1:19 AM
To: Chandra Umesh (NRC/Dallas); [email-masked]
Subject: RE: [XCON] I-D

Umesh,

Roni Even

Polycom Israel

Tel: +972-3-9251200
Cell: +972-55-481099

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, December 18, 2003 11:06 PM
To: [email-masked]
Subject: RE: [XCON] I-D ACTION:draft-ietf-xcon-conference-scenarios-00.txt

Hello,

Umesh
-----Original Message-----

	

Send a message to:
	[email-masked].
In the body type: