Subject: [XCON] CPCP Requirement: Hidden Participants

From: [email-masked]
Date: Mon, 15 Dec 2003 14:55:21 +0200

This is in reference to requirements REQ-A7 and REQ-E10 in http://www.ietf.org/internet-drafts/draft-ietf-xcon-cpcp-reqs-00.txt

   REQ-A7: It SHOULD be possible to participate in a conference as a
   hidden user. Hidden user is present in a conference, but his presence
   is not revealed.

   REQ-E10: It MUST be possible to allow and disallow hidden membership
   in a conference.

Should a conference policy, using CPCP, specify if a user can be hidden? This means that the conference state package does not report the participation on the hidden user. CPCP is used to identify which users are hidden. The list of hidden users is only manipulated by a privileged user such as the moderator.

Regards,
Hisham

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 15 Dec 2003 09:17:08 -0500

I think that this capability could be deferred.
I think it would be acceptable to allow a user
to hide himself, and I think we need to allow
one user to hide another (because of the PC app
for a dumb phone problem).  I think getting into
permission issues is complicated.

I'm puzzled by "the list of hidden users is
manipulated by a privileged user..." I think that
such a statement opens a large box of complication
in specification.  I would prefer, for now, to
not have any specified behavior for anything
like a privileged user.  

Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, December 15, 2003 7:55 AM
> To: [email-masked]
> Subject: [XCON] CPCP Requirement: Hidden Participants
> 
> 
> This is in reference to requirements REQ-A7 and REQ-E10 in 
> http://www.ietf.org/internet-drafts/draft-ietf-xcon-cpcp-reqs-00.txt
> 
> Should a conference policy, using CPCP, specify if a user can 
> be hidden? This means that the conference state package does 
> not report the participation on the hidden user. CPCP is used 
> to identify which users are hidden. The list of hidden users 
> is only manipulated by a privileged user such as the moderator.
> 
> Regards,
> Hisham
>

---

From: [email-masked]
Date: Mon, 15 Dec 2003 16:45:41 +0200

> From: ext Rosen, Brian [mailto:[email-masked]]
> Sent: 15.December.2003 16:17
> To: Khartabil Hisham (NMP-MSW/Helsinki); [email-masked]
> Subject: RE: [XCON] CPCP Requirement: Hidden Participants
> 
> 

Noted.

> not have any specified behavior for anything

You can't have everyone manipulating the policy. We can define a privileged user to be the moderator for now.

/Hisham

---

From: Michael Hammer <[email-masked]>
Date: Mon, 15 Dec 2003 11:16:59 -0500

Related to this is there a requirement that, while not revealing the 
identity of a hidden user, the conference policy contains state indication 
about either the presence of hidden users, or the possibility/preclusion 
that such hidden users may be present?

I am anticipating that:
1) Laws may exist that require notification of such.
2) In some conferences, participants may want technical assurance that 
hidden users are not possible before they speak.

Mike

At 02:55 PM 12/15/2003 +0200, [email-masked] wrote:
>Should a conference policy, using CPCP, specify if a user can be hidden? 
>This means that the conference state package does not report the 
>participation on the hidden user. CPCP is used to identify which users are 
>hidden. The list of hidden users is only manipulated by a privileged user 
>such as the moderator.
>
>Regards,
>Hisham
>

---

From: Michael Hammer <[email-masked]>
Date: Mon, 15 Dec 2003 11:23:38 -0500

At 04:45 PM 12/15/2003 +0200, [email-masked] wrote:

>You can't have everyone manipulating the policy. We can define a 
>privileged user to be the moderator for now.

But, you should be able to pass the baton on who is the moderator to 
another participant.  I am taking that the conference creator might not be 
the conference moderator.  I looked in the privileges section and am not 
sure whether being the moderator is considered a privilege.  Is a 
requirement needed along the lines of:

It must be possible to set, modify, delete the assignment of a moderator to 
the conference.
??

Mike

---

From: [email-masked]
Date: Mon, 15 Dec 2003 18:29:10 +0200

> From: ext Michael Hammer [mailto:[email-masked]]
> Sent: 15.December.2003 18:17
> To: Khartabil Hisham (NMP-MSW/Helsinki)
> Cc: [email-masked]
> Subject: Re: [XCON] CPCP Requirement: Hidden Participants
> 
> 

That's a good point. This might require changes to the conference event package to indicate if there are hidden participants or not, and if so, how many.

The question remain: is there a need for such a feature (to hide users?)?

Regards,
Hisham

---

From: [email-masked]
Date: Mon, 15 Dec 2003 18:52:41 +0200

> Sent: 15.December.2003 18:24
> Cc: [email-masked]; [email-masked]

At the moment it is assumed that the creator is the moderator. Moderating a conference involves manipulating the policy. They might be different levels of moderators, depending on what the creator assigns to different users as privileges. Examples of privileges include who can manipulate dial-out list, who can manipulate dial-in list, who can manipulate conference info, who can expel users, who can manipulate floor control policy, etc.

As Brian noted a couple of times, we don't want to get into privileges at the moment due to complexity.

Regards,
Hisham

---

From: Michael Hammer <[email-masked]>
Date: Mon, 15 Dec 2003 12:13:55 -0500

At 06:52 PM 12/15/2003 +0200, [email-masked] wrote:

>At the moment it is assumed that the creator is the moderator. Moderating 
>a conference involves manipulating the policy. They might be different 
>levels of moderators, depending on what the creator assigns to different 
>users as privileges. Examples of privileges include who can manipulate 
>dial-out list, who can manipulate dial-in list, who can manipulate 
>conference info, who can expel users, who can manipulate floor control 
>policy, etc.
>

So if moderator is a privilege, then I take it there will be no mention of 
moderators.

Mike

---

From: [email-masked]
Date: Tue, 16 Dec 2003 10:41:20 +0200

> Sent: 15.December.2003 19:14

> >As Brian noted a couple of times, we don't want to get into 
> privileges at 
> >the moment due to complexity.
> 

If there is, it would mean creator (until we make progress on the privileges stuff).

/Hisham

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Fri, 19 Dec 2003 11:14:02 -0000

I believe hidden users are appropriate.

I do not believe that this adds complexity to the specifications (particularly to the specification of CPCP), so I see no need to make it a DEFER as far as the specifications are concerned. It may add complexity to the implementation, so I am quite happy to see it a MAY in the requirements, so that it is optional to implement.

As regards the legal implications of hidden users, then yes, there may be priveleged users that are able to request the identity of hidden users (along with an indication that they are hidden). This of course requires the enabling of such a privileged user in the first place.

Secondly, it may not be necessary to identify hidden users, but merely that there are hidden users in the conference (in addition to any that may have made themselves visible). Some countries require some form of tone or announcement on voice conferences when someone else is listening in. They also require an announcement or other indication in the call is being recorded.

regards

Keith

Keith Drage
Lucent Technologies
[email-masked]
tel: +44 1793 776249

> Sent: 15 December 2003 16:29
> To: [email-masked]
> Cc: [email-masked]
> That's a good point. This might require changes to the 
> conference event package to indicate if there are hidden 
> participants or not, and if so, how many.
>

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Fri, 19 Dec 2003 11:14:01 -0000

I do not agree where this going.

At least as far as floor control is concerned, it should be possible for the setter of the conference policy to set the moderator for floor control, and change it. The setter of the conference policy may not even be a participant in the conference, thus making it impossible to moderate the floor.

I accept that we do not want this to get too complex, but the conference policy should define who is the moderator for floor control.

regards

Keith

> Sent: 16 December 2003 08:41
> To: [email-masked]