Subject: RE: [XCON] Chicken and Egg - Can CPCP create a conference

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 2 Dec 2003 11:34:58 -0500

We need a consistent definition of "instantiation" or we need to not
use the term in the documents.

I think we are still just having a semantic discussion, and not
arguing over much substance.  I think we all agree that once you
have a conference ID, you can do things with it:
	You can use it to change policy
	You can INVITE yourself to it
	You can REFER someone to it

Depending on the policy in force at the time, an INVITE or REFER
may not be accepted, and that could be because of the time, or who
you are, or what your SDP offer is.  All of those are conference
or media policy decisions, and nothing else.

I can argue your objections to my definition of "instantiate" or
you can propose another definition on instantiation, or
propose that we eliminate the word from our documents.

Brian

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: Tuesday, December 02, 2003 11:15 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [XCON] Chicken and Egg - Can CPCP create a conference
> 
> 
> 
> 
> [email-masked] wrote:
> > 
> >>Several points to make.  In my view:
> >>1. "Instantiating" a conference is a concept that is getting 
> >>confusing.
> >>It's all in what you mean.  I think it's when the mixer resources
> >>are actually allocated (as opposed to reserved).  That starts when
> >>the first participant creates a dialog with the focus, and ends
> >>when the last dialog terminates.  Getting a conference ID doesn't
> >>instantiate a conference, creating a dialog with it does.
> > 
> > Some chat type conferences can exist without any participants.
>  > Participants come and go as they please. Why is there a requirement
>  > that at least one participant is needed for the conference 
> to ever exist?
> 
> I agree. Defining the conference by the allocation of mixer resources 
> seems wrong to me. That is very implementation specific - I 
> might choose 
> to allocate mixer resources differently than Brian does. In 
> case of chat 
> conferences where mixing is trivial, there may not be any explicitly 
> allocated mixing resources at all.
> 
> IMO a conference is defined by a valid address. So as long as the sip 
> address constituting the conference ID, which names a unique 
> focus, is 
> valid, it *is* a conference. The only real question is what 
> state that 
> conference is in. If the conference isn't scheduled to start 
> yet, then I 
> would hope that a request directed to it would yield some meaningful 
> error - perhaps 480 Temporarily Unavailable, giving the time until it 
> will be available. If a request is directed to it after 
> policy says it 
> should have expired, then a 404 Not Found error would be appropriate.
> 
> > You are asking to redefine the whole concept of ah-hoc conferencing
>  > using SIP. The INVITE creates a conference, and creates a dialog.
> ...
>  > again, with ad-hoc conferences, there is no policy to dictate this.
>  > I think I will stop commenting now until someone agrues that I am
>  > wrong and an ah-hoc conference also needs a policy (where my reply
>  > would be: why is it called ah-hoc then?).
> 
> I have to disagree with you and agree with Brian here.
> I don't think it makes sense to say a conference has no policy.
> It may be that you can neither query nor manipulate the policy, but 
> conceptually it still has a policy. Fancier conferencing 
> products would 
> hopefully provide the ability to query and manipulate policy 
> on ad hoc 
> conferences.
> 
> I think the only real difference is that if you create an ad hoc 
> conference by sending an invitation to a conference factory, 
> you get a 
> conference with some *default* policy determined by the 
> factory in its 
> infinite wisdom.
> 
> 	Paul
> 
> 
> _______________________________________________
> XCON mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/xcon
> 

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 02 Dec 2003 14:10:46 -0500

> or media policy decisions, and nothing else.

Agree.

> propose that we eliminate the word from our documents.

I don't think the term is needed for describing when resources are 
assigned - it is entirely an implementation issue.

It may be useful to have a term for the state when sip operations on the 
conference ID (focus uri) by suitably authorized parties can be expected 
to work. But that may not be an all or nothing thing.

	Paul