Subject: [XCON] CPCP and Conference URIs - there are more than one!

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 4 Dec 2003 09:48:17 -0500

The discussion of multiple ways to create conferences triggered 
a discussion of XCON work being useable with multiple "using" (to
borrow a phrase from geopriv) protocols.

We have been assuming that CPCP will, at one time or another, accept
or receive a conference uri, which has so far been thought of as a
SIP uri.  This will not do.  There has to be a LIST of conference URIs,
one for each using protocol the conference might support.

There are already conference bridges that accept both SIP and H.323
endpoints intermixed.  The conference uri for the H.323 endpoints does
not start with "sip:" folks!

There might even be a tel uri in there, right?!!!
Ooh, Ooh, sure would be nice if that tel uri could have the PIN.
Nah, over the top :)

Brian

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: [email-masked]
Date: Thu, 4 Dec 2003 17:34:41 +0200

Brian,

No argument there. We thought of that when we where creating the xcap based solution. The current solution can only hold a tel and a sip URI. We plan on changing this.

Looks like a requirement needs to be added to the requirements document. Does the solution need to be future proof? or do we just allow listing the currently known protocols?

Regards,
Hisham

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of ext
> Rosen, Brian
> Sent: 04.December.2003 16:48
> To: [email-masked]'
> Subject: [XCON] CPCP and Conference URIs - there are more than one!
> 
>

---

From: "Orit Levin" <[email-masked]>
Date: Thu, 4 Dec 2003 15:26:59 -0800

Yes, a conference can have a list of URI identifiers and the CPCP needs
to reflect it.

My question is: Would we like to reflect this fact in the SIP Conference
Package as well? (At least - as an optional structure :-)

Orit. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Thursday, December 04, 2003 7:35 AM
To: [email-masked]; [email-masked]
Subject: RE: [XCON] CPCP and Conference URIs - there are more than one!

Brian,

No argument there. We thought of that when we where creating the xcap
based solution. The current solution can only hold a tel and a sip URI.
We plan on changing this.

Looks like a requirement needs to be added to the requirements document.
Does the solution need to be future proof? or do we just allow listing
the currently known protocols?

Regards,
Hisham

> The discussion of multiple ways to create conferences triggered a 
> discussion of XCON work being useable with multiple "using" (to borrow

> a phrase from geopriv) protocols.
> 
> or receive a conference uri, which has so far been thought of as a SIP

> uri.  This will not do.  There has to be a LIST of conference URIs,

---

From: Alan Johnston <[email-masked]>
Date: Thu, 04 Dec 2003 17:34:16 -0600

>Package as well? (At least - as an optional structure :-)

Yes!

Thanks,
Alan Johnston
MCI
sip:[email-masked]

---

From: "Chris Boulton" <[email-masked]>
Date: Fri, 5 Dec 2003 08:34:27 -0000

Yes I think so also - for completeness the package should indicate a
generic URI rather than binding only to SIP.

Chris.

>From: Alan Johnston [mailto:[email-masked]]
>Sent: 04 December 2003 23:34
>To: Orit Levin; [email-masked]; [email-masked];
>[email-masked]
SIP
>_______________________________________________________________________
_
>This email has been scanned for all viruses by the MessageLabs Email
>Security System. For more information on a proactive email security
>service working around the clock, around the globe, visit
>http://www.messagelabs.com
>_______________________________________________________________________
_

________________________________________________________________________
This email has been scanned for all viruses by the MessageLabs Email
Security System. For more information on a proactive email security
service working around the clock, around the globe, visit
http://www.messagelabs.com
________________________________________________________________________

---

From: "Even, Roni" <[email-masked]>
Date: Fri, 5 Dec 2003 19:53:02 +0200

Hi,
I think that Brian's point is very important. As for the SIP conference
package, I think that the information in the XCON CPCP may support many call
setup protocols (SP, H.323, H.320, PSTN) but the SIP conferencing package
should be for SIP addresses.
Roni Even 

-----Original Message-----
From: Orit Levin
To: [email-masked]; [email-masked]; [email-masked]
Sent: 05/12/2003 01:26
Subject: RE: [XCON] CPCP and Conference URIs - there are more than one!

Orit. 

-----Original Message-----

Brian,

Regards,
Hisham

---

From: "Eric Burger" <[email-masked]>
Date: Thu, 11 Dec 2003 23:23:37 -0500

Would I be interpreting this statement correctly
     "but the SIP conferencing package should be for SIP addresses"
to mean that the SIP conferencing package only includes SIP stuff?

Consider a multi-protocol conference bridge that has four users.  A, B, and C use SIP while D uses H.323.

A, B, and C subscribe to the SIP conferencing package, being conference aware.

Do they know about D?  D does not have a SIP address.

What D does have is a URL.

I would propose that if anything changes, it is that the packages (and XCON, too) just refer to URI's.  We should not place any restriction on URI scheme.  They are opaque objects.

> From: Even, Roni [mailto:[email-masked]]
> Sent: Fri, December 05, 2003 12:53 PM
> To: 'Orit Levin '; [email-masked] ';
> [email-masked] '; [email-masked] '

---

From: "Orit Levin" <[email-masked]>
Date: Fri, 12 Dec 2003 09:43:28 -0800

In the SIP conference package, the participant URIs are opaque URIs. -
It fits Eric's view.

Should the conference package include different kinds of "Conference
URIs" - is a more difficult question. Let's say we do, how are they
going to be used by the recipient of the event information?

In order to answer this question we need to provide answers to the
following first:

- Do we envision that other than SIP entities are going to subscribe to
the SIP conference package?
- Will XCON rely on the SIP conference package exclusively to supply all
the basic events information about a conference?

Orit.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric
Burger
Sent: Thursday, December 11, 2003 8:24 PM
To: Even, Roni
Cc: [email-masked]
Subject: RE: [XCON] CPCP and Conference URIs - there are more than one!

Consider a multi-protocol conference bridge that has four users.  A, B,
and C use SIP while D uses H.323.

A, B, and C subscribe to the SIP conferencing package, being conference
aware.

I would propose that if anything changes, it is that the packages (and
XCON, too) just refer to URI's.  We should not place any restriction on
URI scheme.  They are opaque objects.

> I think that Brian's point is very important. As for the SIP 
> conference package, I think that the information in the XCON CPCP may 
> support many call setup protocols (SP, H.323, H.320, PSTN) but the SIP

> conferencing package should be for SIP addresses.
> Roni Even
> 
> Yes, a conference can have a list of URI identifiers and the CPCP 
> needs to reflect it.
> 
> My question is: Would we like to reflect this fact in the SIP 
> Conference Package as well? (At least - as an optional structure :-)
> 
> Orit. 
>

---

From: [email-masked]
Date: Sat, 13 Dec 2003 18:36:46 +0200

> going to be used by the recipient of the event information?

In theory at least, the recipient might want to subscibe to the conference package, but join the conference by some other means than a SIP URI. 

For example, the client might have a high latency, low bandwidth IP pipe -- good enough for SIP subscriptions but not good enough for voice. It might also have a trusty old circuit switched telephony application that would be perfect for voice.

Cheers,
Aki

---

From: "Orit Levin" <[email-masked]>
Date: Mon, 15 Dec 2003 15:31:43 -0800

Good example!
I am convinced now. Will add to the conference package.

Thanks,
Orit. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Saturday, December 13, 2003 8:37 AM
To: Orit Levin
Cc: [email-masked]
Subject: RE: [XCON] CPCP and Conference URIs - there are more than one!

Orit wrote:
> URIs" - is a more difficult question. Let's say we do, how are they  >

In theory at least, the recipient might want to subscibe to the
conference package, but join the conference by some other means than a
SIP URI. 

For example, the client might have a high latency, low bandwidth IP pipe
-- good enough for SIP subscriptions but not good enough for voice. It
might also have a trusty old circuit switched telephony application that
would be perfect for voice.

Cheers,
Aki