Subject: RE: [XCON] Chicken and Egg - Can CPCP create a conference

From: [email-masked]
Date: Thu, 4 Dec 2003 13:43:27 +0200

Hi,

Inline.

 > > >No, unless the example.com is also the focus host.  If it 
 > > is, then the
 > > >web server is there too. That is just not a limitation 
 > worth worrying
 > > >about.
 > > 
 > > Look at Hisham's example - they are the same.  One can get 
 > > around it by 
 > > having an application server that does 3pcc, or some sort of 
 > > HTTP proxy, 
 > > but why require all this complexity?  Why must my media 
 > > server be my policy 
 > > server as well?
 > We're assuming XCAP, right?  So a "web server" is not just a web
 > server, it's an XCAP server.  If it is the CPCP server; you can't
 > separate the http part from the xcap part from the cpcp part; they
 > are the same thing.
 > 
 > If your media server is your conference server (focus), then it's
 > not much of a stretch at all to force it to be your conference
 > policy server, at least now.  Now, that doesn't mean that you can't,
 > for example, use the media server as a mixer, and have the focus
 > be part of some proxy server, controlling the mixer with, say,
 > Megaco.  It seems pretty impractical to separate the conference
 > policy server from the focus, because they are so intertwined.

I don't like to couple these elements unnecessarily using any type of URI naming conventions. An equally possible setup is one where the policy server is in fact separate XCAP server, and both the conference participant and the focus are XCAP clients.

In any case, aren't we talking about simply passing on some information about the conference to its participants. So, have the focus return in a 200 OK to an INVITE:

Call-Info: <http://xcapsrv002.phantom.example.com/services/cpcp/userA/policy12345.xml>;purpose=xcap-cpcp

This lets the client know where to go and do XCAP CPCP if it wants to manipulate the policy.

Cheers,
Aki

<snip />

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 04 Dec 2003 14:04:47 -0500

[email-masked] wrote:
> 
> In any case, aren't we talking about simply passing on some information about
 > the conference to its participants. So, have the focus return in a 200 OK
 > to an INVITE:
> 

This seems like a good idea.

Carrying that thought further, consider the case where, by policy, the 
conference isn't accepting calls now. (E.g. the start time of the 
conference hasn't arrived yet.) In that case the server must respond 
with some sort of error to incoming invites. An obvious thing to do 
would be to return 480 Temporarily Unavailable. In addition to that, it 
might be good to return an Error-Info with a reference to the conference 
policy. This would provide a translation from focus uri to policy uri 
that can't easily be obtained any other way.

I suggest that some well defined and useful behavior (whether its 
exactly what I propose above or something else) be normative.

	Paul