Subject: [XCON] CPCP Requirement: Floor Control

From: [email-masked]
Date: Mon, 15 Dec 2003 14:57:53 +0200

There needs to be some floor control policy that is part of CPCP. Requirements like:

- Does the Conference have floor control or not
- Is the conference floor control moderator-driven by human or First come first serve by automata.
- How many users can have the floor at one time.
- If automata driven, how long is the maximum time a user can ask for floor.

Does anyone have objections to such requirements in CPCP requirements document? Any other requirements for floor control policy?

There is one requirement that appears in http://www.ietf.org/internet-drafts/draft-ietf-xcon-cpcp-reqs-00.txt

   REQ-F1: It MUST be possible to assign and de-assign the users who are
   allowed to manipulate floor policy.

Regards,
Hisham

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Fri, 19 Dec 2003 11:14:01 -0000

See below

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 15 December 2003 12:58
> To: [email-masked]
> Subject: [XCON] CPCP Requirement: Floor Control
> 
> 

OK

> or First come first serve by automata.

I am not sure this is the right pair of settings. First of all, the discussion in Minneapolis was of the opinion that there could be a number of algorithms. I am not sure whether these are configurable using CPCP, but first come first served is only one of the automatic ones. It is even conceivable that one of the actions of the moderator is to regulate the order in the queue (or "set" as we discussed in Minneapolis).

Secondly, I have assumed that for floor control, there will always be a moderator, and therefore there will always be moderator control, it is just a matter of whether the floor can be automatically be granted elsewhere in the absence of a moderator instruction when the floor becomes vacant.

> - How many users can have the floor at one time.

OK

> - If automata driven, how long is the maximum time a user can 

Not sure automatic timeouts are useful in a conference. This to me would be moderator action. If people want it, then it must be settable to infinity.

> 
> Does anyone have objections to such requirements in CPCP 
> requirements document? Any other requirements for floor 
> control policy?
> 
Additionally I would add:

- Assignment / removal / replacement of the moderator to the floor
- Is it possible to have more than one floor in a conference, e.g. in relation to multiple media streams. The moderator for message chat may be different from the moderator controlling the audio-visual, but they could well be in the same conference.

> There is one requirement that appears in 
> http://www.ietf.org/internet-drafts/draft-ietf-xcon-cpcp-reqs-00.txt
>