Subject: [XCON] CPCP Requirement: de-activating a conference

From: [email-masked]
Date: Mon, 15 Dec 2003 14:57:25 +0200

This is in reference to requirement REQ-B9 in http://www.ietf.org/internet-drafts/draft-ietf-xcon-cpcp-reqs-00.txt

   REQ-B9: It MUST be possible to inactive a conference for defined
   period of time.

There are start and stop times for a conference. A conference might live for days, weeks or even months. Should a conference policy, using CPCP, allow a privileged user to de-activate a conference for a period of time within the start and stop times of a conference? Examples are administrator is performing some maintenance.

Regards,
Hisham

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 15 Dec 2003 09:24:55 -0500

Again, I'm worried about "privileged users".  I think we need to finish
some discussions we started a while ago that essentially are semantics.
What is an "inactivated" conference, and how does it differ from a
conference that can be re-instantiated (a weekly meeting for example)?

Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, December 15, 2003 7:57 AM
> To: [email-masked]
> Subject: [XCON] CPCP Requirement: de-activating a conference
> 
> 
> This is in reference to requirement REQ-B9 in 
> http://www.ietf.org/internet-drafts/draft-ietf-xcon-cpcp-reqs-00.txt
> 
> There are start and stop times for a conference. A conference 
> might live for days, weeks or even months. Should a 
> conference policy, using CPCP, allow a privileged user to 
> de-activate a conference for a period of time within the 
> start and stop times of a conference? Examples are 
> administrator is performing some maintenance.
> 
> Regards,
> Hisham
>

---

From: [email-masked]
Date: Mon, 15 Dec 2003 17:21:24 +0200

> From: ext Rosen, Brian [mailto:[email-masked]]
> Sent: 15.December.2003 16:25
> To: Khartabil Hisham (NMP-MSW/Helsinki); [email-masked]
> Subject: RE: [XCON] CPCP Requirement: de-activating a conference
> 
> 

We can assume it is the moderator for now.

> conference that can be re-instantiated (a weekly meeting for example)?

A long lived conference is one that runs for months (chat sessions on the internet seem to run for that long). They are not repeated, but instead are constantly running.

An administrator, for maintenance reasons, might want to de-activate a conference for a short period of time.

Of course the administrator can kick everyone out by sending them BYE requests and redefining the conference start time. But it has the disadvantage that the inactivity time for maintenance cannot be scheduled. Do we want to be able to schedule such event for long lived conferences?

Regards,
Hisham

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Fri, 19 Dec 2003 11:14:01 -0000

You seem to be ending defining an inactivated conference due to a lack of flexbility over start and stop times. What is to stop you having multiple start and stop times that are completely independent of regular scheduling?

If the conference them has a stop specified sometime in the middle, and a subsequent restart, how is that different from an inactivated conference?

regards

KeithKeith Drage
Lucent Technologies
[email-masked]
tel: +44 1793 776249

> Sent: 15 December 2003 15:21
> To: [email-masked]; [email-masked]
> A long lived conference is one that runs for months (chat 
> sessions on the internet seem to run for that long). They are 
> not repeated, but instead are constantly running.
> 
> An administrator, for maintenance reasons, might want to 
> de-activate a conference for a short period of time.
> 
> Of course the administrator can kick everyone out by sending 
> them BYE requests and redefining the conference start time. 
> But it has the disadvantage that the inactivity time for 
> maintenance cannot be scheduled. Do we want to be able to 
> schedule such event for long lived conferences?
> 
> Regards,
> Hisham
> 
> > 
> > Brian
> >

---

From: [email-masked]
Date: Fri, 19 Dec 2003 16:01:05 +0200

You are getting into the solution already, so I take it that you agree that such a requirement is needed.

Having multiple start and stop times has the side effect that a conference policy will forever grow. In the solution we propose using XCAP, we have start-time, stop-time, and repeat intervals. Having multiple start and stop times where there is a repeat interval will cause unnecessary complexity.

To accommodate setting a long lived conference inactive to a short period of time, we have defined an inactive start and stop times.

I guess we can defer the argument about what the solution should look like until we agree on the requirement.

Regards,
Hisham

> From: ext Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: 19.December.2003 13:14
> To: Khartabil Hisham (NMP-MSW/Helsinki); [email-masked];
> [email-masked]
> You seem to be ending defining an inactivated conference due 
> to a lack of flexbility over start and stop times. What is to 
> stop you having multiple start and stop times that are 
> completely independent of regular scheduling?
> 
> If the conference them has a stop specified sometime in the 
> middle, and a subsequent restart, how is that different from 
> an inactivated conference?
> 
> regards
> 
> KeithKeith Drage
> Lucent Technologies
> [email-masked]
> tel: +44 1793 776249
> 
>

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Fri, 19 Dec 2003 14:43:28 -0000

At the moment I was not trying to propose words, I was merely trying to see how your inactive state was different from the conference having been stopped.

So far you have been asked that question twice, once by me, and once by someone else, and you have gone into statements about side effects, but you have never actually answered the question.

So, is it a different state, or not?

Once we understand that, then we can look at the words.

regards

Keith

Keith Drage
Lucent Technologies
[email-masked]
tel: +44 1793 776249

> Sent: 19 December 2003 14:01
> To: [email-masked]; [email-masked]; [email-masked]
> You are getting into the solution already, so I take it that 
> you agree that such a requirement is needed.
> 
> Having multiple start and stop times has the side effect that 
> a conference policy will forever grow. In the solution we 
> propose using XCAP, we have start-time, stop-time, and repeat 
> intervals. Having multiple start and stop times where there 
> is a repeat interval will cause unnecessary complexity.
> 
> To accommodate setting a long lived conference inactive to a 
> short period of time, we have defined an inactive start and 
> stop times.
> 
> I guess we can defer the argument about what the solution 
> should look like until we agree on the requirement.
> 
> Regards,
> Hisham
>

---

From: [email-masked]
Date: Fri, 19 Dec 2003 17:10:16 +0200

Your question is slightly different that Brian's. Here is a copy paste from what I replied to Brian:

------------------

An administrator, for maintenance reasons, might want to de-activate a conference for a short period of time.
------------------------------

In this case, there is no difference in meaning when you say "stopping" or "deactivating" the conference. But since you are stopping the conference for a short period of time then restarting it again, and you do not want to affect the overall start and stop time of the conference, then you are really just making the conference inactive. Maybe inactive in the wrong word here. Maybe suspend is a better word. You are suspending the conference.

The other scenario is that the conference does not have to be running yet. Someone might schedule a conference starting Monday next week and stop 3 months from Monday. Moments later, the administrator decides that in 2 weekends time, he will suspend all running conferences. The administrator can immediately schedule such event before the meeting starts on Monday.

Brian was asking what the difference is between de-activating a conference and conference repeats. I guess you can think of as such, but it is not the same thing. Certainly the solution can incorporate both, but the 2 need to be recognised a separate requirements.

I hope what I state above answers his question (and your for that matter :)

Regards,
Hisham

> Sent: 19.December.2003 16:43
> To: Khartabil Hisham (NMP-MSW/Helsinki); Drage, Keith (Keith);
> [email-masked]; [email-masked]
> At the moment I was not trying to propose words, I was merely 
> trying to see how your inactive state was different from the 
> conference having been stopped.
> 
> So far you have been asked that question twice, once by me, 
> and once by someone else, and you have gone into statements 
> about side effects, but you have never actually answered the question.
>

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 24 Dec 2003 12:31:27 -0000

So I think you are basically telling me it is the same state.

I would therefore suggest combining all the requirements in this area into a single requirement - something along the lines of:

START PROPOSAL
The conference administrator can set start and stop times for a conference, or may start and stop the conference on-demand. A conference that is stopped on-demand does not have a programmed stop time removed, and thus if the conference is restarted, that programmed stop time will apply. Start and stop times can be specific (i.e. for a single conference event) or recurring such that the conference occurs e.g. daily, weekly, monthly. Recurring conferences can have the frequency set using an appropriate set of time intervals.
END PROPOSAL

The way this is worded would also allow a conference that is programmed to start later to be started early. This would seem to me to be useful, and the only reason to preclude it would be lack of resources, which could be determined and rejected at the time of making of the request. Of course if the conference has been started early, and then stopped before the start time, it will restart at the programmed start time.

I agree that we can exclude multiple start and stop times (except for the recurring conferences outlined above). If this is a necessity for any user, then it would seem simple enough to programme up multiple conferences, each with their own start and stop times. Maybe we can have a note expressing this in the requirements.

Are we placing any CPCP restrictions on conferences that have already started? I currently see none in the requirements documents so assume that we can add, remove and modify CPCP data when the conference is in progress.

regards

Keith

Keith Drage
Lucent Technologies
[email-masked]
tel: +44 1793 776249

> Sent: 19 December 2003 15:10
> In this case, there is no difference in meaning when you say 
> "stopping" or "deactivating" the conference. But since you 
> are stopping the conference for a short period of time then 
> restarting it again, and you do not want to affect the 
> overall start and stop time of the conference, then you are 
> really just making the conference inactive. Maybe inactive in 
> the wrong word here. Maybe suspend is a better word. You are 
> suspending the conference.
> 
> The other scenario is that the conference does not have to be 
> running yet. Someone might schedule a conference starting 
> Monday next week and stop 3 months from Monday. Moments 
> later, the administrator decides that in 2 weekends time, he 
> will suspend all running conferences. The administrator can 
> immediately schedule such event before the meeting starts on Monday.
> 
> Brian was asking what the difference is between de-activating 
> a conference and conference repeats. I guess you can think of 
> as such, but it is not the same thing. Certainly the solution 
> can incorporate both, but the 2 need to be recognised a 
> separate requirements.
> 
> > > > > > Again, I'm worried about "privileged users".  I 
> think we need 
> > > > > > to finish
> > > > > > some discussions we started a while ago that 
> essentially are 
> > > > > > semantics.
> > > > >