Subject: [XCON] CPCP Requirement: Anonymous participants

From: [email-masked]
Date: Mon, 15 Dec 2003 14:54:27 +0200

This is the first of a series of emails discussing Conference Policy Requirements. Your engagement is appreciated.

This is in reference to requirements REQ-A6 and REQ-E9 in http://www.ietf.org/internet-drafts/draft-ietf-xcon-cpcp-reqs-00.txt

   REQ-A6: It SHOULD be possible to anonymously participate in a
   conference.

   REQ-E9: It MUST be possible to allow and disallow anonymous
   membership in a conference.

Should a conference policy, using CPCP, specify if anonymous participants are allowed to join a conference? Or should this be a local policy at the server?

There are 2 types of anonymous participants:

1. ones that joins a conference using a http digest username of "anonymous" and no password
2. ones that join with a proper username and password, but hide their identity using [email-masked] in the From-header of a SIP INVITE. The conference state package notifications shows them as anonymous participants.

I don't think we need to allow 1. Either a conference requires everyone to know the username and password of the conference, or does not require digest authentication at all.

2 can be provided, but we need consensus that this is a useful feature.

Regards,
Hisham

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: Ben Campbell <[email-masked]>
Date: Thu, 18 Dec 2003 15:04:17 -0600

> I don't think we need to allow 1. Either a conference requires everyone to know the username and password of the conference, or does not require digest authentication at all.

Will you ever want to distinguish between the priviledges of an 
anonymous partitipant and those of non-anonymous participants?