Subject: [XCON] CPCP Requirement: Conference package subscribers

From: [email-masked]
Date: Mon, 15 Dec 2003 14:54:54 +0200

This is in reference to requirement REQ-H5 in http://www.ietf.org/internet-drafts/draft-ietf-xcon-cpcp-reqs-00.txt

   REQ-H5: It SHOULD be possible to define users who are allowed to
   subscribe to conference event package [4]

Should this be a separate list? or should a combination of Dial-out list, Dial-in list be sufficient? i.e. only participants and potential participants can subscribe to the conference event package (outside users not allowed)?

In any case, I think the requirement needs to stay, but needs rewording according to the conclusions we come up with that answer the above question.

Regards,
Hisham

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: [email-masked]
Date: Mon, 15 Dec 2003 15:01:30 +0200

The address from where I subscribe the conference event might be diffrent to the addres from where I'm joining to the conference.

BR,
Jari 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of ext
> [email-masked]
> Sent: 15 December, 2003 14:55
> To: [email-masked]
> Subject: [XCON] CPCP Requirement: Conference package subscribers
> 
> 
> This is in reference to requirement REQ-H5 in 
> http://www.ietf.org/internet-drafts/draft-ietf-xcon-cpcp-reqs-00.txt
> 
> Should this be a separate list? or should a combination of 
> Dial-out list, Dial-in list be sufficient? i.e. only 
> participants and potential participants can subscribe to the 
> conference event package (outside users not allowed)?
> 
> In any case, I think the requirement needs to stay, but needs 
> rewording according to the conclusions we come up with that 
> answer the above question.
> 
> Regards,
> Hisham
>

---

From: [email-masked]
Date: Mon, 15 Dec 2003 15:06:27 +0200

Jari,

You are right, if you use a non-sip protocol to join the conference.

In any case, this is not related to the questions I ask that are related who is allowed to subscribe to the conference state event package.

Regards,
Hisham

> From: Mutikainen Jari (NMP-MSW/Helsinki) 
> Sent: 15.December.2003 15:02
> To: Khartabil Hisham (NMP-MSW/Helsinki); [email-masked]
> Subject: RE: [XCON] CPCP Requirement: Conference package subscribers
> 
> 
> The address from where I subscribe the conference event might 
> be diffrent to the addres from where I'm joining to the conference.
> 
> BR,
> Jari 
>

---

From: [email-masked]
Date: Mon, 15 Dec 2003 15:49:03 +0200

I might want to follow the conference status (and manage it if I'm the host) from my PC client, and participate from a legacy mobile/PSTN device. Even if I'm using a single device, I might have a device that does not support VoIP but supports non-RT SIP, so I'm using my SIP subscription and it's SIP URI to subscribe, but Tel URI to join. 

Now, the only way to tie these is that we have a separate list for participants that are allowed to subscribe? In dial-in case it could be possible to put both URIs to the Dial-In list, but in Dial-out case it is impossible, as the server tries to invite both, even they mean a single participant?

BR,
Jari

> Sent: 15 December, 2003 15:06
> To: Mutikainen Jari (NMP-MSW/Helsinki); [email-masked]
> In any case, this is not related to the questions I ask that 
> are related who is allowed to subscribe to the conference 
> state event package.
> 
> Regards,
> Hisham
>

---

From: [email-masked]
Date: Mon, 15 Dec 2003 16:01:01 +0200

I think I understand what you're saying now: You are talking about the participant having 2 different identities, one is a SIP URI and the other is a TEL URI. I originally thought you are talking about the conference focus itself having 2 URIs.

If the dial-out list has your TEL URI, and we use the dial-out and dial-in list as indicators to who is allowed to subscribe to a conference package, then your question is: how does the focus know that the SUBSCRIBE that carries your SIP URI is you when it only has your TEL URI?

I have 2 solutions:

1. Use your TEL URI in the SUBSCRIBE. Why would you use your SIP URI? You certainly don't have to.
2. Have the dial-out list carry both your TEL and SIP URIs.

I think option 1 is far more superior.

My original question was: are there any scenarios where a conference state subscriber may not be a potential participant? 

Another question: Are there any scenarios where the participant is not allowed to subscribe to the conference package.

If the answer to the above 2 questions is yes, then we need a separate privilege list for conference package subscribers.

Regards,
Hisham

> Sent: 15.December.2003 15:49
> I might want to follow the conference status (and manage it 
> if I'm the host) from my PC client, and participate from a 
> legacy mobile/PSTN device. Even if I'm using a single device, 
> I might have a device that does not support VoIP but supports 
> non-RT SIP, so I'm using my SIP subscription and it's SIP URI 
> to subscribe, but Tel URI to join. 
> 
> Now, the only way to tie these is that we have a separate 
> list for participants that are allowed to subscribe? In 
> dial-in case it could be possible to put both URIs to the 
> Dial-In list, but in Dial-out case it is impossible, as the 
> server tries to invite both, even they mean a single participant?
> 
> BR,
> Jari
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 15 Dec 2003 09:08:41 -0500

I didn't read Jari's answer the same way.

I think you could easily have a PC app that was not a "participant",
in that it never sends or receives media, but does:
	Read and Modify Conference Policy
	Read and Modify Media Policy
	Read and Modify whatever floor control mechanism there is

This would be a PC app for a "dumb" phone.  The phone is the "participant".
It would have a dialog with the focus, and send/receive media.  It
would be conference un-aware.

So, the PC app has to be able to subscribe to the conference package,
but is neither a dial in, nor a dial out participant.

Brian

> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, December 15, 2003 9:01 AM
> To: [email-masked]; [email-masked]
> I think I understand what you're saying now: You are talking 
> about the participant having 2 different identities, one is a 
> SIP URI and the other is a TEL URI. I originally thought you 
> are talking about the conference focus itself having 2 URIs.
> 
> If the dial-out list has your TEL URI, and we use the 
> dial-out and dial-in list as indicators to who is allowed to 
> subscribe to a conference package, then your question is: how 
> does the focus know that the SUBSCRIBE that carries your SIP 
> URI is you when it only has your TEL URI?
> 
> I have 2 solutions:
> 
> My original question was: are there any scenarios where a 
> conference state subscriber may not be a potential participant? 
> 
> Another question: Are there any scenarios where the 
> participant is not allowed to subscribe to the conference package.
> 
> If the answer to the above 2 questions is yes, then we need a 
> separate privilege list for conference package subscribers.
> 
> Regards,
> Hisham
>

---

From: [email-masked]
Date: Mon, 15 Dec 2003 16:13:42 +0200

Inline:

> Sent: 15 December, 2003 16:01

At least in IMS this is impossible. I cannot take my grand ma's PSTN phone, write down it's E.164 number, and register from my SIP client using this E.164 number. In my understanding the IMS provider allows registration only from tel URIs it has allocated to me.

> 2. Have the dial-out list carry both your TEL and SIP URIs.

And to which one the server dials? Both?

BR,
Jari

---

From: [email-masked]
Date: Mon, 15 Dec 2003 16:19:28 +0200

> Sent: 15.December.2003 16:14
> At least in IMS this is impossible. I cannot take my grand 
> ma's PSTN phone, write down it's E.164 number, and register 
> from my SIP client using this E.164 number. In my 
> understanding the IMS provider allows registration only from 
> tel URIs it has allocated to me.

You and your grand mother are 2 different people with 2 different identities, so you're grandmother's TEL URI needs to be on the dial-x list.

In this case, I see there is a need to have a conference package subscriber list that is different that the dial-x lists since you are not on those lists but want to subscribe to the package.

> And to which one the server dials? Both?

no, it picks one. Anyway, I agree we need a separate list.

/Hisham

---

From: Michael Hammer <[email-masked]>
Date: Mon, 15 Dec 2003 11:07:52 -0500

The terms "dial-in" and "dial-out" seem very media-specific, or at least 
connection-oriented-specific.  Is it necessary to have this coupling?  If 
so, then you would need to not only include details of the identity of the 
participant, but the nature of what they are enabled to do:

connection-oriented media type (in/out)
connectionless media
control links, ...

Perhaps this should be more of a single list of "participants" of any type, 
with added attributes about what they are permitted to do, who initiates 
communication.  But, that is jumping to conclusions in the requirements.

So, perhaps the requirement needs to be split apart.

Mike

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Fri, 19 Dec 2003 11:14:00 -0000

See below

> From: [email-masked] [mailto:[email-masked]]
> Sent: 15 December 2003 14:14
> To: [email-masked]; [email-masked]
heavily snipped
> tel URIs it has allocated to me.
This comes as part of release 6 for IMS. The it is possible to associate the same public user identity with two private user identities. and therefore register the same public user identity from two different devices (they must however have the appropriate USIM or ISIM application to hold the private user identity etc).

regards

Keith

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Fri, 19 Dec 2003 11:14:00 -0000

The only additional client I could think of for this information was a presence server, but presumably that should be a PUBLISH type operation rather than a SUBSCRIBE to the conference event package.

However it does raise a question of whether there should be an additional conference policy requirement relating to PUBLISH of conference information from the conference server and who to.

regards

Keith

> Sent: 15 December 2003 12:55
> To: [email-masked]

---

From: [email-masked]
Date: Tue, 23 Dec 2003 13:00:43 +0200

> From: ext Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: 19 December, 2003 13:14
> To: Mutikainen Jari (NMP-MSW/Helsinki); Khartabil Hisham
> (NMP-MSW/Helsinki); [email-masked]
> This comes as part of release 6 for IMS. The it is possible 
> to associate the same public user identity with two private 
> user identities. and therefore register the same public user 
> identity from two different devices (they must however have 
> the appropriate USIM or ISIM application to hold the private 
> user identity etc).
> 
> regards
> 
> Keith

Yes, I agree, but the requirement was to be able to join to the conference from any POTS terminal, while subscribing and managing the conference status from IMS SIP device.

BR,
Jari