Subject: RE: [XCON] Talking Points

From: "Even, Roni" <[email-masked]>
Date: Wed, 22 Mar 2006 15:54:17 +0200

Brian,
Hi,
The modify conference is needed for modifying parameters before the
conference starts.
The get may be needed to get the conference information after it is
finished for CDR (we need charging)
Roni Even

> -----Original Message-----
> From: Brian Rosen [mailto:[email-masked]]
> Sent: Wednesday, March 22, 2006 8:12 AM
> To: 'Chris Boulton'; 'Adam Roach'; [email-masked]
> Subject: RE: [XCON] Talking Points
> 
> I'm thinking that the operation to add or delete someone to a list is
just
> that.  If that someone has some kind of state that can be modified,
then
> the
> add/delete returns a handle and the set/get is used to change the
state.
> 
> Would that work for you?
> 
> -----Original Message-----
> From: Chris Boulton [mailto:[email-masked]]
> Sent: Tuesday, March 21, 2006 9:37 PM
> To: [email-masked]; Adam Roach; [email-masked]
> Subject: RE: [XCON] Talking Points
> 
> AddListItem(Participant), DeleteListItem(Participant).  May need a
> modify, but I don't think so
> 
> Brian - I guess this all depends on how you define a participant.  If
> the participant has tied properties that might change during a
> conference then a modify might be needed.
> 
> Chris.
> 
> 
> -----Original Message-----
> From: Brian Rosen [mailto:[email-masked]]
> Sent: 21 March 2006 23:13
> To: 'Adam Roach'; [email-masked]
> Subject: RE: [XCON] Talking Points
> 
> Using my verb/noun list:
> 
>     * Create Conference based on specified blueprint
> Create(Conference)
>     * Create Conference based on implied blueprint
> Create(Conference)
>     * Modify/Delete/Get Conference
> Delete(Conference).  Maybe I need a get/modify but I don't think so
>     * Add/Modify/Delete/Get User
> AddListItem(Participant), DeleteListItem(Participant).  May need a
> modify,
> but I don't think so
>     * Modify User Roles
> Is this AddListItem(AllowedRoles)?  I'd need a new noun for List
>     * Add/Modify/Delete/Get Endpoint
> I'm not sure exactly what this is, but may need another noun for
> endpoint
>     * Add/Modify/Delete/Get Endpoint Media
> I'm pretty sure this is not xcon state
>     * Add/Modify/Delete/Get Media Groups
> I'm pretty sure this is not xcon state
>     * Add/Modify/Delete Sidebar
> Create(Sidebar), Delete(Sidebar) not sure you need a modify
>    Generally I think you have a very simplistic create, and then use
>    set/get to change values in the object the create made for you
>     * Add/Modify/Delete/Get Role
> Need a noun, maybe Set(Role), but is this actually conference state?
>     * Add User To Sidebar
> AddListItem(Sidebar)
>     * Delete User From Sidebar
> DeleteListItem(Sidebar)
>     * Move User Between Sidebars
> Delete then add.  Doesn't have to be a transaction I think
>     * Add/Modify/Delete/Get XML element
> Set/Get(one of my list of nouns)
>     * Set/Get/Delete XML attribute
> Dunno what you mean
>     * Get Templates
> Aha, need a noun for set/get "focus"
>     * Get Blueprints
> Get(focus)
>     * Get Active Conferences
> Get(focus)
> 
>     * Cancel
> Cancel what?
>     * Ping
> Ping on the conf control channel?  Some no-op
>     * Options
> Dunno what you mean
> 
> 
> 
> 
> _______________________________________________
> XCON mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/xcon
> 
> 
> Information contained in this e-mail and any attachments are intended
for
> the use of the addressee only, and may contain confidential
information of
> Ubiquity Software Corporation.  All unauthorized use, disclosure or
> distribution is strictly prohibited.  If you are not the addressee,
please
> notify the sender immediately and destroy all copies of this email.
> Unless
> otherwise expressly agreed in writing signed by an officer of Ubiquity
> Software Corporation, nothing in this communication shall be deemed to
be
> legally binding.  Thank you.
> 
> 
> _______________________________________________
> XCON mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/xcon

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: "Brian Rosen" <[email-masked]>
Date: Wed, 22 Mar 2006 02:10:45 -0500

All of the parameters I can think of that you "modify" are just values
somewhere in the object.  The Set/Get verb can set them to any value that is
acceptable at any time.  Creating a new item in a list is not a set/get,
it's a different operation.  

Brian

-----Original Message-----
From: Even, Roni [mailto:[email-masked]] 
Sent: Wednesday, March 22, 2006 8:54 AM
To: [email-masked]; Chris Boulton; Adam Roach; [email-masked]
Subject: RE: [XCON] Talking Points

Brian,
Hi,

just
then
state.
for
information of
please
be