Subject: RE: [XCON] Talking Points

From: "Chris Boulton" <[email-masked]>
Date: Wed, 22 Mar 2006 02:37:10 -0000

AddListItem(Participant), DeleteListItem(Participant).  May need a
modify, but I don't think so

Brian - I guess this all depends on how you define a participant.  If
the participant has tied properties that might change during a
conference then a modify might be needed.

Chris.

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]] 
Sent: 21 March 2006 23:13
To: 'Adam Roach'; [email-masked]
Subject: RE: [XCON] Talking Points

Using my verb/noun list:

    * Create Conference based on specified blueprint
Create(Conference)
    * Create Conference based on implied blueprint
Create(Conference)
    * Modify/Delete/Get Conference
Delete(Conference).  Maybe I need a get/modify but I don't think so
    * Add/Modify/Delete/Get User
AddListItem(Participant), DeleteListItem(Participant).  May need a
modify,
but I don't think so
    * Modify User Roles
Is this AddListItem(AllowedRoles)?  I'd need a new noun for List
    * Add/Modify/Delete/Get Endpoint
I'm not sure exactly what this is, but may need another noun for
endpoint
    * Add/Modify/Delete/Get Endpoint Media
I'm pretty sure this is not xcon state
    * Add/Modify/Delete/Get Media Groups
I'm pretty sure this is not xcon state
    * Add/Modify/Delete Sidebar
Create(Sidebar), Delete(Sidebar) not sure you need a modify
   Generally I think you have a very simplistic create, and then use 
   set/get to change values in the object the create made for you
    * Add/Modify/Delete/Get Role
Need a noun, maybe Set(Role), but is this actually conference state?
    * Add User To Sidebar
AddListItem(Sidebar)
    * Delete User From Sidebar
DeleteListItem(Sidebar)
    * Move User Between Sidebars
Delete then add.  Doesn't have to be a transaction I think
    * Add/Modify/Delete/Get XML element
Set/Get(one of my list of nouns)
    * Set/Get/Delete XML attribute
Dunno what you mean
    * Get Templates
Aha, need a noun for set/get "focus"
    * Get Blueprints
Get(focus)
    * Get Active Conferences
Get(focus)

    * Cancel
Cancel what?
    * Ping
Ping on the conf control channel?  Some no-op
    * Options
Dunno what you mean

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

Information contained in this e-mail and any attachments are intended for the use of the addressee only, and may contain confidential information of Ubiquity Software Corporation.  All unauthorized use, disclosure or distribution is strictly prohibited.  If you are not the addressee, please notify the sender immediately and destroy all copies of this email.  Unless otherwise expressly agreed in writing signed by an officer of Ubiquity Software Corporation, nothing in this communication shall be deemed to be legally binding.  Thank you.

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: "Brian Rosen" <[email-masked]>
Date: Wed, 22 Mar 2006 01:12:05 -0500

I'm thinking that the operation to add or delete someone to a list is just
that.  If that someone has some kind of state that can be modified, then the
add/delete returns a handle and the set/get is used to change the state.

Would that work for you?

-----Original Message-----
From: Chris Boulton [mailto:[email-masked]] 
Sent: Tuesday, March 21, 2006 9:37 PM
To: [email-masked]; Adam Roach; [email-masked]
Subject: RE: [XCON] Talking Points

Chris.

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]] 
Sent: 21 March 2006 23:13
To: 'Adam Roach'; [email-masked]
Subject: RE: [XCON] Talking Points

Using my verb/noun list:

    * Cancel
Cancel what?
    * Ping

Information contained in this e-mail and any attachments are intended for
the use of the addressee only, and may contain confidential information of
Ubiquity Software Corporation.  All unauthorized use, disclosure or
distribution is strictly prohibited.  If you are not the addressee, please
notify the sender immediately and destroy all copies of this email.  Unless
otherwise expressly agreed in writing signed by an officer of Ubiquity
Software Corporation, nothing in this communication shall be deemed to be
legally binding.  Thank you.

---

From: "Sean Olson" <[email-masked]>
Date: Wed, 22 Mar 2006 09:29:11 -0800

I'm not sure I understand why you need to explicitly call out the list
data structure for the participant .... Isn't this self-described by the
data model? 

-----Original Message-----
From: Chris Boulton [mailto:[email-masked]] 
Sent: Tuesday, March 21, 2006 6:37 PM
To: [email-masked]; Adam Roach; [email-masked]
Subject: RE: [XCON] Talking Points

Chris.

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]]
Sent: 21 March 2006 23:13
To: 'Adam Roach'; [email-masked]
Subject: RE: [XCON] Talking Points

Using my verb/noun list:

    * Add/Modify/Delete/Get Endpoint Media I'm pretty sure this is not
xcon state
    * Add/Modify/Delete/Get Media Groups I'm pretty sure this is not
xcon state

    * Cancel
Cancel what?
    * Ping

Information contained in this e-mail and any attachments are intended
for the use of the addressee only, and may contain confidential
information of Ubiquity Software Corporation.  All unauthorized use,
disclosure or distribution is strictly prohibited.  If you are not the
addressee, please notify the sender immediately and destroy all copies
of this email.  Unless otherwise expressly agreed in writing signed by
an officer of Ubiquity Software Corporation, nothing in this
communication shall be deemed to be legally binding.  Thank you.

---

From: Adam Roach <[email-masked]>
Date: Wed, 22 Mar 2006 11:34:47 -0600

Probably not... you have multiple lists to which users can be added. Or
did I misunderstand your question?

/a

---

From: "Brian Rosen" <[email-masked]>
Date: Wed, 22 Mar 2006 14:31:31 -0500

User is a little bit of a special case here, because the protocol doesn't
actually provide a method to directly create one.  It indirectly creates
them by users responding to actions resulting from using dial out, dial
in/refer mechanisms.  In the end, however, a new user would be added to the
list of users, and would have some kind of index that would be used for, as
in the example, a user volume control.

A better example is the dial out list.  You explicitly add/delete an item on
that list.

You don't have to create the volume control entry explicitly; when a new
user is added, by the focus, it effectively adds a new volume control to the
volume control list.  So we don't need to AddListElement(Volume); it's done
implicitly.  You can immediately Set(Volume(user)) (ignore syntax)

Brian

-----Original Message-----
From: Chris Boulton [mailto:[email-masked]] 
Sent: Tuesday, March 21, 2006 6:37 PM
To: [email-masked]; Adam Roach; [email-masked]
Subject: RE: [XCON] Talking Points

Chris.

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]]
Sent: 21 March 2006 23:13
To: 'Adam Roach'; [email-masked]
Subject: RE: [XCON] Talking Points

Using my verb/noun list:

    * Cancel
Cancel what?
    * Ping