Subject: [XCON] Last Call: <draft-ietf-xcon-ccmp-12.txt> (CentralizedConferencing Manipulation Protocol) to Proposed Standard

From: "Duddy, Sean (Sean)" <[email-masked]>
Date: Thu, 10 Mar 2011 12:21:38 -0000

Hi All,
    Just a minor comment:-
 
Section 4.3 (a)
 
 "If the domain name is NOT within the server's domain of
responsibility,
 then the server MUST return a 500 Server Internal Error."
 
I dont believe this is an appropriate error for this situation. 
I am not sure what error code would be applicable here, but 500 would
indicate to a client that their request is causing an error on the
server which is not the case...

Sean

---

From: Simon Pietro Romano <[email-masked]>
Date: Fri, 11 Mar 2011 18:10:48 +0100

Hi Sean,

>     Just a minor comment:-
> Section 4.3 (a)
>  "If the domain name is NOT within the server's domain of responsibility,
> I am not sure what error code would be applicable here, but 500 
> would indicate to a client that their request is causing an error on 
> the server which is not the case...
I see your point. What about using a 4xx code like, e.g., "Invalid 
Domain Name"?

Simon
> Sean
>
>
> _______________________________________________
> XCON mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xcon

-- 
                             _\\|//_
                             ( O-O )
    ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                     Simon Pietro Romano
               Universita' di Napoli Federico II
                  Computer Science Department
         Phone: +39 081 7683823 -- Fax: +39 081 7684219
                 e-mail: [email-masked]
           http://www.comics.unina.it/simonpietro.romano

     <<Molti mi dicono che lo scoraggiamento è l'alibi degli
    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
                          oooO
    ~~~~~~~~~~~~~~~~~~~~~~(   )~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
                           \ (    (   )
                            \_)    ) /
                                  (_/

---

From: "Duddy, Sean (Sean)" <[email-masked]>
Date: Fri, 11 Mar 2011 22:45:25 -0000

Hi Simon,
    That sounds good to me!
 
Sean

________________________________

From: Simon Pietro Romano [mailto:[email-masked]] 
Sent: 11 March 2011 17:11
To: Duddy, Sean (Sean)
Cc: [email-masked]; [email-masked]
Subject: Re: [XCON] Last Call: <draft-ietf-xcon-ccmp-12.txt> (CentralizedConferencing Manipulation Protocol) to Proposed Standard

Hi Sean,

	    Just a minor comment:-
	 
	Section 4.3 (a)

	I dont believe this is an appropriate error for this situation. 
	I am not sure what error code would be applicable here, but 500 would indicate to a client that their request is causing an error on the server which is not the case...

I see your point. What about using a 4xx code like, e.g., "Invalid Domain Name"?

Simon

	 
	Sean