Subject: Re: [xmpp] [Standards] Modifying the schema for auth(RFC 3920)

From: "Joe Hildebrand" <[email-masked]>
Date: Tue, 23 Jun 2009 11:14:54 -0700

Moving the discussion to the XMPP working group mailing list since this is RFC-related.

It looks like Google's docs for this are here:

http://code.google.com/apis/talk/jep_extensions/jid_domain_change.html

Should the client just use this bare JID the next time it logs in?  If so, we may need to make a change to 3920bis to make this clear.  If we're contemplating making a change in -bis, we should make the correct one, not just loosen up the schema.

Of course, in your implementation, there's nothing that says you can't use any schema you like to do validation, since validation is not required and the schemas are non-normative.

-- 
Joe Hildebrand

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mittal Thakkar
Sent: Tuesday, June 23, 2009 12:43 AM
To: [email-masked]
Subject: [Standards] Modifying the schema for auth(RFC 3920)

Hi,

The clients using the libpurple 2.6.x like Adium and Pidgin sends the following stanza for auth :
<auth xmlns='urn:ietf:params:xml:ns:xmpp-sasl' mechanism='DIGEST-MD5' xmlns:ga='http://www.google.com/talk/protocol/auth' ga:client-uses-full-bind-result='true'/>.
At our server xml parsing fails as in the schema for auth it supports only one attribute ie. mechanism. wrt. Appendix C.4 of RFC 3920.

Is it valid if we allow any attribute( of other namespace ) for the <auth/> as RFC is silent about it. The schema we want to use is as follows:

<xs:element name='auth'>
    <xs:complexType>
      <xs:simpleContent>
        <xs:extension base='xs:string'>
          <xs:attribute name='mechanism'
                        type='xs:string'
                        use='optional'/>
          <xs:anyAttribute namespace='##other' processContents='lax'/>
        </xs:extension>
      </xs:simpleContent>
    </xs:complexType>
  </xs:element>

-- 
Thanks,
Regards,
Mittal Thakkar

---

From: Jiří Zárevúcky <[email-masked]>
Date: Tue, 23 Jun 2009 23:34:41 +0200

> Should the client just use this bare JID the next time it logs in?  If so, we may need to make a change to 3920bis to make this clear.  If we're contemplating making a change in -bis, we should mak…

In my opinion, this is a pretty Google-specific problem. In normal
XMPP world, user account is strictly defined by the combination of
node identifier and domain name. This google "extension" allows user
to log in with different domain, then the one user registered with.

If we are to modify the spec about this, we must also allow one
account to have multiple JIDs, which in turn would require a way to
retrieve all the account's aliases (for the proper handling on another
servers), along with proper security considerations and so on...

> Of course, in your implementation, there's nothing that says you can't use any schema you like to do validation, since validation is not required and the schemas are non-normative.

IMHO, validation is completely useless on an XMPP server. It just
slows it down and possibly breaks it on any unexpected input.
The server should handle the communication as long as there is
everything needed. Not kick client in the butt for something that
shouldn't be here.

> _______________________________________________
> xmpp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xmpp
>