Subject: [xmpp] MUST NOT inside RECOMMENDED

From: Kevin Smith <[email-masked]>
Date: Mon, 7 Jun 2010 10:16:15 +0100

3.4
The following guidelines are RECOMMENDED, but the guidelines
themselves MUST - it's a minor thing, but switching the MUSTs to
SHOULDs seems to me that it'd parse better.

/K

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 07 Jun 2010 09:41:21 -0600

> SHOULDs seems to me that it'd parse better.

Agreed. Fixed in my working copy.

/psa

---

From: Ben Campbell <[email-masked]>
Date: Thu, 10 Jun 2010 10:40:45 -0500

> SHOULDs seems to me that it'd parse better.

That's actually not an uncommon thing in other specs. For example, a spec may say you SHOULD follow procedure X, and procedure X says you MUST do something. In effect, this means that _if_ you follow procedure X, but don't follow the MUST, things might break.

So in section 3.4, once you've made the decision to follow the guidelines, how badly do things break if you don't follow the MUSTs in the guidelines?

> /K
> _______________________________________________
> xmpp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xmpp