Subject: [xmpp] Mechanism Preferences.

From: Kevin Smith <[email-masked]>
Date: Tue, 8 Jun 2010 10:23:54 +0100

6.2.3 states
"A server MUST offer and a client MUST
   try SASL mechanisms in the order of their perceived strength."

I'm not sure MUST here is right - SHOULD seems sufficient.
I think deployments could reasonably have other priorities than
perceived strength (perceived by whom?) - such as computational
expense.

/K

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 08 Jun 2010 19:06:02 +0100

>perceived strength (perceived by whom?) - such as computational
Good point. +1.