Subject: [xmpp] xmpp-tls slides

From: Peter Saint-Andre <[email-masked]>
Date: Sun, 03 Nov 2013 10:58:15 -0800

Here are my draft slides about draft-saintandre-xmpp-tls and related
topics (if we get that far in the agenda).

https://stpeter.im/files/ietf88-xmpp-tls.pdf

Enjoy! :-)

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Philipp Hancke <[email-masked]>
Date: Sun, 03 Nov 2013 20:31:05 +0100

[...]
> https://stpeter.im/files/ietf88-xmpp-tls.pdf

slide 3: Few server-to-server connections TLS-protected

I think most s2s connections (*) are actually using TLS for encryption, 
so it's 80% using TLS. However, few of those connections are using 
certificates which enable strong authentication (my pessimistic view on 
that is 5%).

(*): apart from a large deployment which doesn't even do xmpp-1.0; 
unfortunately, this deployment is behind 15% of the domains I know of.

slide 9: s/PKIK/PKIX/?

---

From: Peter Saint-Andre <[email-masked]>
Date: Sun, 03 Nov 2013 12:27:33 -0800

On 11/3/13 11:31 AM, Philipp Hancke wrote:
> I think most s2s connections (*) are actually using TLS for
> encryption, so it's 80% using TLS. However, few of those
> connections are using certificates which enable strong
> authentication (my pessimistic view on that is 5%).

In fact I don't have numbers on that. It would be good to collect some
stats. Maybe the jabber.org admins can do that for us? ;-)

This gives renewed impetus to also documenting TLS+Dialback.

> unfortunately, this deployment is behind 15% of the domains I know

That's unfortunate indeed.

> slide 9: s/PKIK/PKIX/?

Noted.

I'll upload corrected slides shortly.

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Peter Saint-Andre <[email-masked]>
Date: Sun, 03 Nov 2013 12:36:44 -0800

On 11/3/13 12:27 PM, Peter Saint-Andre wrote:
> In fact I don't have numbers on that. It would be good to collect
> some stats. Maybe the jabber.org admins can do that for us? ;-)
> 

Philipp, I'd be happy to collaborate with you on that.

>> (*): apart from a large deployment which doesn't even do
>> xmpp-1.0; unfortunately, this deployment is behind 15% of the
>> domains I know of.
> 

Done at the URL above.

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 04 Nov 2013 15:03:59 -0800

On 11/3/13 10:58 AM, Peter Saint-Andre wrote:
> Here are my draft slides about draft-saintandre-xmpp-tls and
> related topics (if we get that far in the agenda).
> 

When I presented the slides this morning, I found an error in the
slide order. I've uploaded revised slides to the foregoing URL.

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/