Subject: [xrblock] Numeric format of PDV metric

From: [email-masked]
Date: Thu, 20 Oct 2011 10:05:20 +0800 (CST)

Hi,

I have read PDV draft available at:

http://tools.ietf.org/html/draft-ietf-xrblock-rtcp-xr-pdv-00

and find one nits, i.e.,

The first paragraph in the defintion of Negative PDV Threshold/Peak metric

is same as the first paragraph in the defintion of metricPositive PDV Percentile

metric, this make Negative PDV Threshold/Peak metric inconsistent with the defintion

of Positive PDV Threshold/Peak metric, in my understanding.

Also according to numeric format definition in the section 2, the range of S11:4

would be from -2047.9375 to 2047.9375.However in the defintion of Negative PDV Threshold/Peak,

the measured value range from -2047.9375 to +2047.8125, how this is calcualted?

Regards!

Zhaojing&SunShine

ShangHai Research Institute of China Telecom Corporation Limited.

---

From: Qin Wu <[email-masked]>
Date: Thu, 20 Oct 2011 18:34:02 +0800

Hi,
Thank for your review, please  see my reply below.
  ----- Original Message ----- 
  From: [email-masked] 
  To: xrblock 
  Cc: zhangyx 
  Sent: Thursday, October 20, 2011 10:05 AM
  Subject: Numeric format of PDV metric

  Hi, 

  [Qin]: Good catch, I think the right text for the 1st paragraph of Negative PDV Threshold/Peak metric  should be:
  "
        This field is associated with the Negative PDV percentile and
        expressed in Milliseconds with numeric format S11:4.  The term
        Negative represents that the packets are arriving earlier than the
        expected time.
  "

  [Qin]: If you look at the section 2, you will see a note which said  "use of flag values at the top of the numeric
           range slightly reduces this upper limit".
           That is to say 0x7ffe and 0x7fff are used as flags for "over-
           range" and "unavailable" conditions. Also 0x8000 is reserved since the leftmost bit is used to indicate signed.
          Therefore the lower limit for S11:4 is 
          -(2^11-1/2^4)=-2047.9375
          the upper limit for S11:4 is:
          2^11-3/2^4 = 2047.8125.
  Also in the same way, I think the range of S7:8 in the section 2 should be fixed as(-127.996,+127.996).
   
  Regards! 
  Zhaojing&SunShine