Subject: Re: [xrblock] General comments on xrblock metrics drafts

From: [email-masked]
Date: Mon, 31 Oct 2011 17:23:32 +0800 (CST)

Hi, Alan:

Question for clarification.

Isn't the sampled metric same as the  Interval metric? Is the sampled metric only applied to per-packet reporting ? what's the difference between sampled metric and non-sampled metric?

what's the difference between sampled metric and Interval metric? Would you like to clarify more?

Cheers!

Jing

------------------ 原始邮件 ------------------

发件人：Alan Clark

时　间：2011/10/31 06:51:03 星期一

收件人：[email-masked]

抄送人：

主　题：[xrblock] General comments on xrblock metrics drafts

1. Cumulative, Interval and Sample metrics
The drafts current have one bit assigned for Cumulative/Interval indication.. Some metrics are however sampled and don’t have validity for an interval or a call/session; an example of this is PPDV, which is a sampled value of a running average and only has validity for the last 200-300ms before the value is sampled.
Proposal - increase this to two bits to allow for the indication of a Sampled value.

---

From: Qin Wu <[email-masked]>
Date: Mon, 31 Oct 2011 17:51:38 +0800

In the current XRBlock metrics drafts, the cumulative/Interval indicatin using one bit within block header can be used to determine which mesurement interval or sequence number (Cumulative or Interval) in the measurement information XR Block in draft-ietf-xrblock-rtcp-xr-meas-identity-01 should be choosed to calculate derive metric. E.g.,   packet expected should be calcuated based on Interval/cumulative indication.
So my followup question is what's the usage of sampled indication? Is it for metric calulation or something else? Do we have other ways to indicate sample value if it is really beneficial?e.g., using SDP extension?
I am curious to know the answer.

Regards!
-Qin
----- Original Message ----- 
  From: [email-masked] 
  To: Alan Clark ; xrblock 
  Sent: Monday, October 31, 2011 5:23 PM
  Subject: Re: [xrblock] General comments on xrblock metrics drafts

  Hi, Alan: 
   
  Cheers! 
  Jing  
  ------------------ 原始邮件 ------------------ 

  发件人：Alan Clark 

------------------------------------------------------------------------------

  _______________________________________________
  xrblock mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/xrblock

---

From: Alan Clark <[email-masked]>
Date: Mon, 31 Oct 2011 08:08:23 -0400

Hi Jing

An interval metric should be measured throughout an interval however a
sampled metric is an instantaneous value.

Using Jitter/PDV as an example:

- Interval PDV should be calculated by measuring the delay variation of each
packet and averaging these over the interval.  This requires the
implementation to sum the individual measurements and divide by the number
of measurements.

- PPDV (RFC3550) is calculated by keeping a running average of the
individual delay variation measurements using a scaling factor of 16 and
then reporting the value of this running average at the end of the interval.
With a scaling factor of 16 the PPDV metric is most strongly affected by the
delay variation of the most recent 10-20 packets and hence is not
representative of the whole interval.

Interval averages can be quite misleading if the measurements are strongly
time varying, which PDV typically is.

Best Regards

Alan

On 10/31/11 5:23 AM, "[email-masked]" <[email-masked]> wrote:

>  Isn't the sampled metric same as the  Interval metric? Is the sampled metric
> only applied to per-packet reporting ? what's the difference between sampled
> metric and non-sampled metric?
>   
> The drafts current have one bit assigned for Cumulative/Interval indication..
> Some metrics are however sampled and don’t have validity for an interval or a
> call/session; an example of this is PPDV, which is a sampled value of a
> running average and only has validity for the last 200-300ms before the value
> is sampled.

---

From: "Rachel Huang(yihong)" <[email-masked]>
Date: Tue, 01 Nov 2011 03:01:55 +0000

Hi Alan,

In my understanding, interval can’t represent  that the value is an average one.  The cumulative/interval field indicates whether the metric value is calculated only based on the information of the interval currently measuring. If it is, then it’s an interval metric. Otherwise, it’s a cumulative metric. As for whether the metric value is an average one or an instantaneous one depends on the arithmetic of the calculation, which can be explained in the definition of metric fields.

For example.  PPDV,  the interarrival jitter defined in RFC3550, uses a parameter 1/16 to reduce the noise which may be due to some large random changes. Yes, I agree with you that the value of interarrival jitter is most strongly affected by the delay variation of the most recent 10-20 packets. But we can still regard it as an interval metric, cause the value is calculated only in an interval and doesn’t have any relationship with the previous interval or next interval. While the arithmetic of the metric calculation determines that the value is not the average throughout the interval.

I don’t know whether I understand correctly.  If I don’t, please correct me.
Thank you!

Best Regards!
Rachel

From: [email-masked] [mailto:[email-masked]] On Behalf Of Alan Clark
Sent: Monday, October 31, 2011 8:08 PM
To: [email-masked]
Cc: xrblock
Subject: Re: [xrblock] General comments on xrblock metrics drafts

Hi Jing

An interval metric should be measured throughout an interval however a sampled metric is an instantaneous value.

- Interval PDV should be calculated by measuring the delay variation of each packet and averaging these over the interval.  This requires the implementation to sum the individual measurements and divide by the number of measurements.

- PPDV (RFC3550) is calculated by keeping a running average of the individual delay variation measurements using a scaling factor of 16 and then reporting the value of this running average at the end of the interval.  With a scaling factor of 16 the PPDV metric is most strongly affected by the delay variation of the most recent 10-20 packets and hence is not representative of the whole interval.

Interval averages can be quite misleading if the measurements are strongly time varying, which PDV typically is.

Best Regards

Alan

 Hi, Alan:

 Cheers!

 Jing

 ------------------ 原始邮件 ------------------

发件人：Alan Clark