Subject: [xrblock] I-D Action: draft-ietf-xrblock-rtcp-xr-meas-identity-00.txt

From: [email-masked]
Date: Tue, 04 Oct 2011 10:23:12 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Metric Blocks for use with RTCP&#39;s Extended Report Framework Working Group of the IETF.

	Title           : RTCP Source Description (SDES) items for Measurement Identity
	Author(s)       : Geoff Hunt
                          Alan Clark
                          Qin Wu
	Filename        : draft-ietf-xrblock-rtcp-xr-meas-identity-00.txt
	Pages           : 10
	Date            : 2011-09-26

   This document defines RTCP SDES items carrying parameters which
   identify a measurement, to which one or more other RTCP XR Report
   Blocks may refer.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-xrblock-rtcp-xr-meas-identity-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-xrblock-rtcp-xr-meas-identity-00.txt

---

From: Colin Perkins <[email-masked]>
Date: Mon, 10 Oct 2011 17:02:53 +0100

> http://www.ietf.org/internet-drafts/draft-ietf-xrblock-rtcp-xr-meas-identity-00.txt

I understand the need for the application specific identifier (APSI), and agree that an RTCP SDES packet is the right place to send this.

I'm somewhat less convinced of the need for the Extended First Sequence Number, Extended Last Sequence Number, Cumulative Measurement Duration, and Interval Measurement Duration reports, but could be convinced that they're useful. I'm not sure these fit into SDES items either, as they describe a measurement and not the source, and my memory of the consensus from Quebec City was that the correlation tag was to become an SDES item, but not these other report blocks. 

-- 
Colin Perkins
http://csperkins.org/

---

From: Qin Wu <[email-masked]>
Date: Tue, 11 Oct 2011 20:01:07 +0800

Hi, Colin:
Thank for your quick review, I agree Correlation tag should also go to SDES packet.
please see my reply below.
----- Original Message ----- 
From: "Colin Perkins" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, October 11, 2011 12:02 AM
Subject: Re: [xrblock] I-D Action:draft-ietf-xrblock-rtcp-xr-meas-identity-00.txt

> I understand the need for the application specific identifier (APSI), and agree that an RTCP SDES packet is the right place to send this.

[Qin]: Yes, that's what was agreed in the last IETF meeting, i.e., The information that needs to correlate RTCP and non-RTCP based reports goes to SDES packet.

> I'm somewhat less convinced of the need for the Extended First Sequence Number, Extended Last Sequence Number, Cumulative Measurement Duration, and Interval Measurement Duration reports, but could be convinced that they're useful. I'm not sure these fit into SDES items either, as they describe a measurement and not the source, 

[Qin]: These information is useful when we relate measurement data in metric blocks to the stream, and measurement period. 
The measurement period can be identified by this information. Therefore We may have two ways to convey these information:
1. Defining new SDES Item
2. Define new XR Reporting Block
It seems SDES item is not appropriate as you said, I propose to use new XR reporting Block. But this block is not related to identity. 

>and my memory of the consensus from Quebec City was that the correlation tag was to become an SDES item, but not these other report blocks. 

[Qin]: Yes, we discussed on the list before when we talked about draft-ietf-avtcore-monarch-03. I remembered Roni thinks Using the tag may provide another level
of freedom allowing more than one tag per SSRC, that is to say one metric block may belong to two group with different tag at the same time.
Therefore tag can be used to associate a set of RTCP XR metrics blocks in another level, even though each metric block is using different SSRC.
one example of usage is tag can be used when multiple RTP sessions are used.

 However I think correlation tag is not mandatory feature, for example metric blocks which were defined
before this document is wrote does not support tag feature, and even some new metric blocks we are going to define  may also not support association tag feature.
But I am okay to take correlation tag into SDES item.

> -- 
> Colin Perkins
> http://csperkins.org/
> 
> 
> 
> _______________________________________________
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock

---

From: Colin Perkins <[email-masked]>
Date: Tue, 11 Oct 2011 15:02:30 +0100

> It seems SDES item is not appropriate as you said, I propose to use new XR reporting Block. But this block is not related to identity. 

I know this information is not related to identity. If you need it, then it should be an XR block. My question is, do you need it?

> [Qin]: Yes, we discussed on the list before when we talked about draft-ietf-avtcore-monarch-03. I remembered Roni thinks Using the tag may provide another level of freedom allowing more than one tag per SSRC, that is to say one metric block may belong to two group with different tag at the same time. Therefore tag can be used to associate a set of RTCP XR metrics blocks in another level, even though each metric block is using different SSRC. one example of usage is tag can be used when multiple RTP sessions are used.

I don't understand this. RTCP XR blocks only report on a single session, why would you want to use a new tag to match them across sessions? You can use the RTCP CNAME to do that.

> However I think correlation tag is not mandatory feature, for example metric blocks which were defined before this document is wrote does not support tag feature, and even some new metric blocks we are going to define  may also not support association tag feature. But I am okay to take correlation tag into SDES item.

I thought we'd previously agreed, on the mailing list and in Quebec City, that the 3 bit correlation tag should be removed entirely. The existing SSRC and CNAME can be used to correlate RTCP XR data. The RTCP SDES APSI block you defined can be used to correlate with non-RTP sessions.

-- 
Colin Perkins
http://csperkins.org/

---

From: Qin Wu <[email-masked]>
Date: Wed, 12 Oct 2011 13:46:30 +0800

----- Original Message ----- 
From: "Colin Perkins" <[email-masked]>
To: "Qin Wu" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, October 11, 2011 10:02 PM
Subject: Re: [xrblock] I-D Action:draft-ietf-xrblock-rtcp-xr-meas-identity-00.txt

[Qin]: Yes it is needed, I think they do have a vlue when we expect to compare measurement results from different metric blocks which are based on the same measurement 
period, same start sequence number and last sequence number. Maybe there is also other usages I haven't identified.

[Qin]: See below.

[Qin]: Sorry, I misunderstand what you said by Correlation tag. I know there has already consesus to remove tag field from each XR Block.
However this doesn't mean you can't insert it into SDES item if it has value in some use case that existed. Therefore I misunderstood you proposed to make a tag or key become a new SDES item.
Anyway I have no objection to your conclusion.
-- 
Colin Perkins
http://csperkins.org/