Subject: [xrblock] 答复: General comments on xrblock metrics drafts

From: Qin Wu <[email-masked]>
Date: Tue, 01 Nov 2011 07:19:54 +0000

Hi, Alan:

So the Interval metric you understand is for per RTP packet monitoring or observation while the sampled metric is not.
In other words,
a. The Interval metric is obtained by keeping trace of each RTP packet during a specified Interval and treat all the sequence number valid.
b.The sampled metric is obtained by sampling a sub set of RTP packets during a specified Interval.
Is that what you say?

However according to PDV drafts and other similar xrblock metrics drafts, per-packet statistics doesn't apply to these metrics(See security consideration section).

That seems to implicate that both Interval metrics and cumulative metric are not used for per-packet accounting but for sampling use.

Regards!

-Qin

________________________________
发件人: [email-masked] [[email-masked]] 代表 Alan Clark [[email-masked]]
发送时间: 2011年10月31日 20:08
到: [email-masked]
Cc: xrblock
主题: Re: [xrblock] General comments on xrblock metrics drafts

Hi Jing

An interval metric should be measured throughout an interval however a sampled metric is an instantaneous value.

Using Jitter/PDV as an example:

- Interval PDV should be calculated by measuring the delay variation of each packet and averaging these over the interval.  This requires the implementation to sum the individual measurements and divide by the number of measurements.

- PPDV (RFC3550) is calculated by keeping a running average of the individual delay variation measurements using a scaling factor of 16 and then reporting the value of this running average at the end of the interval.  With a scaling factor of 16 the PPDV metric is most strongly affected by the delay variation of the most recent 10-20 packets and hence is not representative of the whole interval.

Interval averages can be quite misleading if the measurements are strongly time varying, which PDV typically is.

Best Regards

Alan

On 10/31/11 5:23 AM, "[email-masked]<https://imail.huawei.com/OWA/UrlBlockedError.aspx>" <[email-masked]<https://imail.huawei.com/OWA/UrlBlockedError.aspx>> wrote:

 Hi, Alan:

 Question for clarification.

 Isn't the sampled metric same as the  Interval metric? Is the sampled metric only applied to per-packet reporting ? what's the difference between sampled metric and non-sampled metric?

 what's the difference between sampled metric and Interval metric? Would you like to clarify more?

 Cheers!

 Jing

 ------------------ 原始邮件 ------------------

发件人：Alan Clark
时　间：2011/10/31 06:51:03 星期一
收件人：[email-masked]<https://imail.huawei.com/OWA/UrlBlockedError.aspx>
抄送人：
主　题：[xrblock] General comments on xrblock metrics drafts

1. Cumulative, Interval and Sample metrics
The drafts current have one bit assigned for Cumulative/Interval indication.. Some metrics are however sampled and don’t have validity for an interval or a call/session; an example of this is PPDV, which is a sampled value of a running average and only has validity for the last 200-300ms before the value is sampled.
Proposal - increase this to two bits to allow for the indication of a Sampled value.

---

From: Qin Wu <[email-masked]>
Date: Tue, 01 Nov 2011 08:17:07 +0000

[Qin]: I agree people often confuse some statistics measurement that use sample with average. But Sample is not a new concept and widely used in the RFC 3550(e.g., page 15 for the definition of timestample), for example,

you can sample SSRC, you can sample packet, the sample instant is choosen as reference point. jitter calculation is based on the RTP timestamp which
 represents the instant when the first data in the packet was sampled. The sample implementation is allowed in the RFC3550.

Also, in my understanding the sample will be used only when it is impractical to keep track of all the packets.

So it looks to me if you gather enough samples within interval, you will get a more accurate average or other statistics measurment that does not rely on per-packet statistics.

Best Regards

Alan

 Hi, Alan:

 Cheers!

 Jing

 ------------------ 原始邮件 ------------------

发件人：Alan Clark

---

From: Alan Clark <[email-masked]>
Date: Tue, 1 Nov 2011 17:18:09 -0400

Hi Qin

In this case the term Sample would mean the sampled value of a continuously
calculated metric rather than a metric calculated based on sampled packets.
There is already one RTP example of this, which is PPDV.  This is a fairly
common way to report a metric for a time varying value, and since the
comment is addressed to the xrblocks generally it would seem to make sense
to allow for the idea that some of the current or future metrics reported
using XR may be sample values rather than true interval or cumulative
values.

Best Regards

Alan

On 11/1/11 3:19 AM, "Qin Wu" <[email-masked]> wrote:

> Hi, Alan:
> 
> So the Interval metric you understand is for per RTP packet monitoring or
> observation while the sampled metric is not.
> In other words,
> a. The Interval metric is obtained by keeping trace of each RTP packet during
> a specified Interval and treat all the sequence number valid.
> However according to PDV drafts and other similar xrblock metrics drafts,
> per-packet statistics doesn't apply to these metrics(See security
> consideration section).
> 
> That seems to implicate that both Interval metrics and cumulative metric are
> not used for per-packet accounting but for sampling use.
> 
>  
> 
> Regards!
> 
> -Qin
> 
> 
> - Interval PDV should be calculated by measuring the delay variation of each
> packet and averaging these over the interval.  This requires the
> implementation to sum the individual measurements and divide by the number of
> measurements.
> 
> - PPDV (RFC3550) is calculated by keeping a running average of the individual
> delay variation measurements using a scaling factor of 16 and then reporting
> the value of this running average at the end of the interval.  With a scaling
> factor of 16 the PPDV metric is most strongly affected by the delay variation
> of the most recent 10-20 packets and hence is not representative of the whole
> interval.
> 
> On 10/31/11 5:23 AM, "[email-masked]
> <https://imail.huawei.com/OWA/UrlBlockedError.aspx> " <[email-masked]
> <https://imail.huawei.com/OWA/UrlBlockedError.aspx> > wrote:
> 
>>   
>>  Hi, Alan: 
>>   
>>  Isn't the sampled metric same as the  Interval metric? Is the sampled metric
>> only applied to per-packet reporting ? what's the difference between sampled
>> metric and non-sampled metric?
>>   
>> 收件人：[email-masked] <https://imail.huawei.com/OWA/UrlBlockedError.aspx>
>> 抄送人： 
>> The drafts current have one bit assigned for Cumulative/Interval indication..
>> Some metrics are however sampled and don’t have validity for an interval or a
>> call/session; an example of this is PPDV, which is a sampled value of a
>> running average and only has validity for the last 200-300ms before the value
>> is sampled.

---

From: Qin Wu <[email-masked]>
Date: Wed, 02 Nov 2011 12:04:44 +0800

Re: 答复: [xrblock] General comments on xrblock metrics draftsHi, Alan:
I get you point. 
It looks your motivation is to distinguish derived metric from basic metric.

The basic metric is directly measured while the derived metric is calculated from basic metric.

Furthermore, we may have derived derived metric is calculate based on combination of derived metric and basic metric.

Take PDV draft as an example, The metric for Mean PDV is derived derived metric.
Take Discard draft as an exmple, the metric for number of packets discarded is derived metric.
Is that what you say?

In this case, It looks most of the metric belong to derived metric except Loss RLE, Duplicate RLE, and
Packet Receipt Times Report Blocks defined in RFC3611.

That's why I say the xrblock metric drafts you listed are not for per-packet statistics or basic metric.
This has already been described in Security Consideration Section in each xrblock metics drafts.

Regards!
-Qin

----- Original Message ----- 
  From: Alan Clark 
  To: Qin Wu ; [email-masked] 
  Cc: xrblock 
  Sent: Wednesday, November 02, 2011 5:18 AM
  Subject: Re: 答复: [xrblock] General comments on xrblock metrics drafts

  Hi Qin

  In this case the term Sample would mean the sampled value of a continuously calculated metric rather than a metric calculated based on sampled packets.  There is already one RTP example of this, which is PPDV.  This is a fairly common way to report a metric for a time varying value, and since the comment is addressed to the xrblocks generally it would seem to make sense to allow for the idea that some of the current or future metrics reported using XR may be sample values rather than true interval or cumulative values.

  Best Regards

  Alan

    Hi, Alan:

    Regards!

    -Qin

----------------------------------------------------------------------------
    发件人: [email-masked] [[email-masked]] 代表 Alan Clark [[email-masked]]
    发送时间: 2011年10月31日 20:08
    到: [email-masked]
    Cc: xrblock
    主题: Re: [xrblock] General comments on xrblock metrics drafts

    Hi Jing

    Best Regards

    Alan

    On 10/31/11 5:23 AM, "[email-masked] <https://imail.huawei.com/OWA/UrlBlockedError.aspx> " <[email-masked] <https://imail.huawei.com/OWA/UrlBlockedError.aspx> > wrote:

       Hi, Alan: 

        

       Cheers! 
        
       Jing  
        
       ------------------ 原始邮件 ------------------ 
       
      发件人：Alan Clark