Subject: [xrblock] Comments on burst loss/discard drafts

From: Alan Clark <[email-masked]>
Date: Mon, 14 Nov 2011 22:07:12 -0500

I will not be at the XRBLOCK meeting however would appreciate the following
comment being considered as part of the discussion on burst loss/discard.

Packet loss and PDV/jitter (and hence discards) are often caused by
congestion - i.e. the same cause - and can therefore occur at the same time.
>From the perspective of the impact of loss and discard on user perceived
quality - they have a combined effect and need to be considered together.
If there are separate metrics for packet loss bursts/gaps and packet discard
burst/gaps then any timing relationship between these is lost.

- It is therefore desirable to have a burst/gap loss/discard metric block.
- Having a burst/gap loss block has some utility as loss can be caused by
layer 1/2 problems.
- Having a burst/gap discard block has limited usefulness

So have one of:

- Burst/Gap Loss/Discard
or
- Burst/Gap Loss/Discard, Burst/Gap Loss
or
- Burst/Gap Loss/Discard, Burst/Gap Loss, Burst/Gap Discard

Alan

---

From: Qin Wu <[email-masked]>
Date: Tue, 15 Nov 2011 05:13:06 +0000

Hi, Alan:

Sorry for late reply since my laptop is down in these days.

Just like to let you know we have already list this as a open in our presentation slides.

So don't worry, we will not forget to discuss them.

Regards!

-Qin

________________________________
发件人: [email-masked] [[email-masked]] 代表 Alan Clark [[email-masked]]
发送时间: 2011年11月15日 11:07
到: Charles Eckel (eckelcu); Shida Schubert
Cc: [email-masked]
主题: [xrblock] Comments on burst loss/discard drafts

I will not be at the XRBLOCK meeting however would appreciate the following comment being considered as part of the discussion on burst loss/discard.

Packet loss and PDV/jitter (and hence discards) are often caused by congestion - i.e. the same cause - and can therefore occur at the same time.  From the perspective of the impact of loss and discard on user perceived quality - they have a combined effect and need to be considered together.  If there are separate metrics for packet loss bursts/gaps and packet discard burst/gaps then any timing relationship between these is lost.

- It is therefore desirable to have a burst/gap loss/discard metric block.
- Having a burst/gap loss block has some utility as loss can be caused by layer 1/2 problems.
- Having a burst/gap discard block has limited usefulness

So have one of:

- Burst/Gap Loss/Discard
or

Alan

---

From: Varun Singh <[email-masked]>
Date: Tue, 15 Nov 2011 08:33:05 +0000

Hi,

Comments inline.

On Tue, Nov 15, 2011 at 03:07, Alan Clark <[email-masked]> wrote:
>  If there are separate metrics for packet loss bursts/gaps and packet
> discard burst/gaps then any timing relationship between these is lost.
>

I support 3 different blocks because there might be some cases or
intervals a receiver may want to only report loss or discard while
there might be others that may report both together.

>
> Alan
>
>
>
>
> _______________________________________________
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock
>
>

-- 
http://www.netlab.tkk.fi/~varun/

---

From: Qin Wu <[email-masked]>
Date: Tue, 15 Nov 2011 10:14:07 +0000

It looks defining 3 xrblocks will cause all five metric values in the three xr metric blocks being repeated 3 times.
Is it more simple to delete 5 duplicate metrics in burst gap discards xr block and keep burst gap loss as it does,
allow thinned burst gap discard metric block and original burst gap loss being sent together in the one compound RTCP 
XR packet if we like to seek combing both loss and discard.

Also put burst gap discard metric and burst gap loss togegther in one newly define metric block conflicts the rationale we build
in Monarch draft. Why containing two different parameter in the same metric block?

Regards!
-Qin
________________________________________
发件人: [email-masked] [[email-masked]] 代表 Varun Singh [[email-masked]]
发送时间: 2011年11月15日 16:33
到: Alan Clark
Cc: [email-masked]
主题: Re: [xrblock] Comments on burst loss/discard drafts

Hi,

Comments inline.