Subject: Re: [xrblock] General comments on xrblock metrics drafts

From: [email-masked]
Date: Tue, 1 Nov 2011 15:39:52 +0800 (CST)

Thank for your kindly explaination.

It looks to me the term "sample" is also appilied to Interval PDV in your example, you just sample all the RTP packets over the Interval.

For PPDV in RFC3550, I didn't find any place to say how many samples they obtained(i.e., sample size during the interval), so the PPDV calculation, looks to me, has nothing to do with  the sample size, i.e., whether it is per-packet monitoring or sampling monitoring.

But since PPDV is just a statistics measurement,I think the more sample the PPDV metric collect, the more accurate of PPDV be calculated.

Cheers!

Jing

------------------ 原始邮件 ------------------

发件人：Alan Clark

时　间：2011/10/31 20:08:23 星期一

收件人：[email-masked]

抄送人：xrblock

主　题：Re: [xrblock] General comments on xrblock metrics drafts

Hi Jing

An interval metric should be measured throughout an interval however a sampled metric is an instantaneous value.

Using Jitter/PDV as an example:

- Interval PDV should be calculated by measuring the delay variation of each packet and averaging these over the interval. This requires the implementation to sum the individual measurements and divide by the number of measurements.

- PPDV (RFC3550) is calculated by keeping a running average of the individual delay variation measurements using a scaling factor of 16 and then reporting the value of this running average at the end of the interval. With a scaling factor of 16 the PPDV metric is most strongly affected by the delay variation of the most recent 10-20 packets and hence is not representative of the whole interval.

Interval averages can be quite misleading if the measurements are strongly time varying, which PDV typically is.

Best Regards

Alan

On 10/31/11 5:23 AM, "[email-masked]" <[email-masked]> wrote:

Hi, Alan:

Question for clarification.

Isn't the sampled metric same as the Interval metric? Is the sampled metric only applied to per-packet reporting ? what's the difference between sampled metric and non-sampled metric?

what's the difference between sampled metric and Interval metric? Would you like to clarify more?

Cheers!

Jing

------------------ 原始邮件 ------------------

发件人：Alan Clark
时　间：2011/10/31 06:51:03 星期一
收件人：[email-masked]
抄送人：
主　题：[xrblock] General comments on xrblock metrics drafts

1. Cumulative, Interval and Sample metrics
The drafts current have one bit assigned for Cumulative/Interval indication... Some metrics are however sampled and don’t have validity for an interval or a call/session; an example of this is PPDV, which is a sampled value of a running average and only has validity for the last 200-300ms before the value is sampled.
Proposal - increase this to two bits to allow for the indication of a Sampled value.

---

From: Alan Clark <[email-masked]>
Date: Tue, 1 Nov 2011 08:39:09 -0400

Hi Rachel

When we say “interval metric” we imply that the metric relates to what
happened during that interval of time.  For example if you refer to the
packet loss rate in an interval this would normally be interpreted to mean
the number of packets lost in the interval divided by the number of packets
expected.  This would lead the reasonable expectation that an “interval PDV”
would be the average value of the set of per-packet PDV’s during the
interval.

PDV is often strongly time varying, particularly around the network
edge/access network.  Measuring the average value of PDV during an interval
may give a very low value that leads the network operator to believe that
congestion is low.  The PPDV metric in RFC3550 works fairly well in
providing an estimate of PDV however it is misleading to describe it as an
interval metric, as it very obviously does not relate to the interval - only
the last 1-2% of it.  It would be ok to report the maximum value of PDV
during an interval but not to describe the end-of-interval sampled value of
the running average of PDV as “interval PDV”.

There are other measurable parameters that are strongly time varying and
which may have similar conundrums, for example audio signal levels, buffer
levels......  This work is partly about creating a framework for using XR
for reporting and hence it is important to get some of the basic concepts
right. 

Best Regards

Alan

On 10/31/11 11:01 PM, "Rachel Huang(yihong)" <[email-masked]>
wrote:

> Hi Alan,
>  
> In my understanding, interval can’t represent  that the value is an average
> one.  The cumulative/interval field indicates whether the metric value is
> calculated only based on the information of the interval currently measuring.
> If it is, then it’s an interval metric. Otherwise, it’s a cumulative metric.
> As for whether the metric value is an average one or an instantaneous one
> depends on the arithmetic of the calculation, which can be explained in the
> definition of metric fields.
>  
> For example.  PPDV,  the interarrival jitter defined in RFC3550, uses a
> parameter 1/16 to reduce the noise which may be due to some large random
> changes. Yes, I agree with you that the value of interarrival jitter is most
> strongly affected by the delay variation of the most recent 10-20 packets. But
> we can still regard it as an interval metric, cause the value is calculated
> only in an interval and doesn’t have any relationship with the previous
> interval or next interval. While the arithmetic of the metric calculation
> determines that the value is not the average throughout the interval.
>  
> I don’t know whether I understand correctly.  If I don’t, please correct me.
> Thank you!
>  
> 
> Best Regards!
> Rachel
>  
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Alan Clark
> Sent: Monday, October 31, 2011 8:08 PM
> To: [email-masked]
> Cc: xrblock
> Subject: Re: [xrblock] General comments on xrblock metrics drafts
>  
> Hi Jing
> 
> - Interval PDV should be calculated by measuring the delay variation of each
> packet and averaging these over the interval.  This requires the
> implementation to sum the individual measurements and divide by the number of
> measurements.
> 
> - PPDV (RFC3550) is calculated by keeping a running average of the individual
> delay variation measurements using a scaling factor of 16 and then reporting
> the value of this running average at the end of the interval.  With a scaling
> factor of 16 the PPDV metric is most strongly affected by the delay variation
> of the most recent 10-20 packets and hence is not representative of the whole
> interval.
> 
>  Isn't the sampled metric same as the  Interval metric? Is the sampled metric
> only applied to per-packet reporting ? what's the difference between sampled
> metric and non-sampled metric?
>   
> 收件人：[email-masked] <收件人：[email-masked]>
> 抄送人： 
> The drafts current have one bit assigned for Cumulative/Interval indication..
> Some metrics are however sampled and don’t have validity for an interval or a
> call/session; an example of this is PPDV, which is a sampled value of a
> running average and only has validity for the last 200-300ms before the value
> is sampled.