Subject: [xrblock] Polling the WG for interests in adding new milestones

From: Shida Schubert <[email-masked]>
Date: Wed, 14 Mar 2012 20:06:14 +0900

All;

 Below are drafts that have been discussed and 
received some supports. 

 Charles and I would have to talk to AD about adding 
milestones for any new WG items but I want to poll 
the WG for interests before the meeting, so we can 
talk to AD face to face. 

 To make sure we get enough energy to complete the 
work we will be adopting, we as chairs want to hear 
who is willing to review and contribute not only interested. 

 So please indicate what you are willing to do for 
each of the drafts listed below next to the option 
listed. 

 draft-zorn-xrblock-rtcp-xr-al-stat

 - Interested 

 - Interested and willing to review 

 - Interested and willing to review and contribute

***************************

 draft-asaeda-xrblock-rtcp-xr-synchronization

 - Interested 

 - Interested and willing to review 

 - Interested and willing to review and contribute

Many Thanks & Regards
  Shida

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 14 Mar 2012 13:48:41 +0100

Interested and willing to review on both I-Ds. 

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Shida Schubert
> Sent: Wednesday, March 14, 2012 1:06 PM
> To: xrblock
> Subject: [xrblock] Polling the WG for interests in adding new
> milestones
> 
> 
> All;
> 
> _______________________________________________
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock

---

From: "Roni Even" <[email-masked]>
Date: Wed, 14 Mar 2012 16:54:58 +0200

Same here,
Roni Even

> Behalf Of Romascanu, Dan (Dan)
> Sent: Wednesday, March 14, 2012 2:49 PM
> To: Shida Schubert; xrblock
> Subject: Re: [xrblock] Polling the WG for interests in adding new
> milestones
> 
> >  Below are drafts that have been discussed and received some
> supports.
> >
> >  Charles and I would have to talk to AD about adding milestones for
> > any new WG items but I want to poll the WG for interests before the
> > meeting, so we can talk to AD face to face.
> >
> >  To make sure we get enough energy to complete the work we will be
> > adopting, we as chairs want to hear who is willing to review and
> > contribute not only interested.
> >
> >  So please indicate what you are willing to do for each of the drafts
> > listed below next to the option listed.
> >

---

From: Colin Perkins <[email-masked]>
Date: Wed, 14 Mar 2012 16:23:15 +0000

Shida,

I have been reviewing these, and am happy to continue to do so.
Colin

-- 
Colin Perkins
http://csperkins.org/

---

From: Kevin Gross <[email-masked]>
Date: Wed, 14 Mar 2012 15:53:05 -0600

Interested and willing to
review draft-asaeda-xrblock-rtcp-xr-synchronization

Kevin Gross
+1-303-447-0517
Media Network Consultant
AVA Networks - www.AVAnw.com <http://www.avanw.com/>,
www.X192.org<http://www.x192.org/>

---

From: <[email-masked]>
Date: Fri, 16 Mar 2012 12:03:27 +0100

Hi all,

my feedback to draft-asaeda-xrblock-rtcp-xr-synchronization:

Section 5.2. "Packet i Generalization offset":
here are 32 bits used, 16 bits seem to be sufficient, because value is a result of a modulo operation "mod 65536".
Possibility is to reduce field to 16 bits and use free bits as a reserved field.

Possiblity:
old:
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      | General Synchronization Offset of packet begin_seq+1 mod 65536|
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

new:
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |GSO pack. begin_seq+1 mod 65536|              rsvd             |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Regards

Roland

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Roni Even
Gesendet: Mittwoch, 14. März 2012 15:55
An: 'Romascanu, Dan (Dan)'; 'Shida Schubert'; 'xrblock'
Betreff: Re: [xrblock] Polling the WG for interests in adding new milestones

Same here,
Roni Even

---

From: Qin Wu <[email-masked]>
Date: Mon, 19 Mar 2012 11:09:04 +0800

Hi, Roland:
The fair question is what is the acceptable synchronization offset is for any streaming service?

I tend to agree with you 16bit is more than enough for synchronization offset between
two streams sent in two separated RTP streams since 16 bit field in the order of  millisecond
can support Maximum synchronization delay 65.536 secs.

Taken audio-video synchronization requirements described in BBF TR-126 as a example,audio stream and video stream
belong to the same session, the acceptable synchronization offset is multiple tens of milliseconds,
far less than 65.536 secs.

However if we change 32bit into 16bit, we may face padding issue. For example, given the odd number of General sycnrhonization 
offset in 16bit carried in the same report blocks, we may need to add one additonal 16bit paading at the end of report block since
following the constraint for report block defined in RFC3611, each report block should be multiple 32 bit words long.

Also I like to point out "mod 65536 (2^16)" has nothing to do with 32 bit synchronization offset field but used to limit the maximimu number
of multiple synchronization offset reporting. 

Regards!
-Qin
----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Friday, March 16, 2012 7:03 PM
Subject: Re: [xrblock] Polling the WG for interests in adding new milestones

Hi all,

Possiblity:
old:

new:

Regards

Roland

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Roni Even
Gesendet: Mittwoch, 14. März 2012 15:55
An: 'Romascanu, Dan (Dan)'; 'Shida Schubert'; 'xrblock'
Betreff: Re: [xrblock] Polling the WG for interests in adding new milestones

Same here,
Roni Even