Subject: [xrblock] Fw: Comments on draft-ietf-xrblock-rtcp-xr-synchronization-00

From: Qin Wu <[email-masked]>
Date: Tue, 23 Oct 2012 10:29:24 +0800

Hi,Rachel:
Please see comments inline.

Regards!
-Qin
----- Original Message ----- 
From: Huangyihong (Rachel) 
To: [email-masked] 
Sent: Thursday, October 18, 2012 11:30 AM
Subject: [xrblock] Comments on draft-ietf-xrblock-rtcp-xr-synchronization-00

Hi folks,

I have 2 comments for draft-ietf-xrblock-rtcp-xr-synchronization:

1.       In RTP flows synchronization offset metric block, only one SSRC set to the SSRC of the reference RTP stream has been specified. IMO,  the SSRC of the reporting stream should be also required. 

[Qin]: Are you saying the synchronization offset is applied to two streams and used to measure the time difference between two stream, so for reporting stream, how to choose the reference stream?

2.       Synchronization offset is a 64-bit unsigned fixed-point number. No indication shows which stream, the reporting stream or the reference stream,  is lag behind. So I propose to split one bit from "Reserved" field to indicate the offset direction.

[Qin]: What do you mean offset direction? Are you saying the value of offset can be either less than zero or greater than zero? However in the current text, the synchronization offset is unsigned value or positive value.

       I am thinking if we can choose one slow stream as reference stream, in that case, the offset value is always a positive value.

Best Regards!

Rachel

--------------------------------------------------------------------------------

_______________________________________________
xrblock mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/xrblock

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Tue, 23 Oct 2012 03:43:46 +0000

Hi Qin,

Please see inline.

Best Regards!
Rachel

From: [email-masked] [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Tuesday, October 23, 2012 10:29 AM
To: [email-masked]
Subject: [xrblock] Fw: Comments on draft-ietf-xrblock-rtcp-xr-synchronization-00

Hi,Rachel:

Regards!
-Qin
----- Original Message -----
From: Huangyihong (Rachel)<mailto:[email-masked]>
To: [email-masked]<mailto:[email-masked]>
Sent: Thursday, October 18, 2012 11:30 AM
Subject: [xrblock] Comments on draft-ietf-xrblock-rtcp-xr-synchronization-00

Hi folks,

       [Rachel]: The reference stream could be randomly chosen from the streams which belong to the one session and have the same RTCP CNAME. For example, audio and video streams, the reference stream could be audio stream while video stream is  the reporting stream. Vice versa. Another example is SVC case, we can choose base layer stream as the reference stream while the other layer stream as the reporting stream.

      [Rachel]: It is up to how do you choose the reference stream. If the reference steam is randomly chosen from the streams that need to be synchronized, the offset value could be positive or negative.

Best Regards!
Rachel

________________________________
_______________________________________________
xrblock mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/xrblock