Subject: [xrblock] FW: I-D Action: draft-ietf-xrblock-rtcp-xr-qoe-09.txt

From: Qin Wu <[email-masked]>
Date: Tue, 18 Jun 2013 08:43:55 +0000

On 18 June , 2013 4:29 PM, [email-masked] wrote:

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Metric Blocks for use with RTCP's Extended Report Framework Working Group of the IETF.

	Title           : RTP Control Protocol (RTCP) Extended Report (XR) Blocks for QoE Metric Reporting
	Author(s)       : Alan Clark
                          Qin Wu
                          Roland Schott
                          Glen Zorn
	Filename        : draft-ietf-xrblock-rtcp-xr-qoe-09.txt
	Pages           : 25
	Date            : 2013-06-18

Abstract:
   This document defines an RTP Control Protocol (RTCP) Extended Report
   (XR) Block including two new segment types and associated SDP
   parameters that allow the reporting of QoE metrics for use in a range
   of RTP applications.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-xrblock-rtcp-xr-qoe

[Qin] This version (-09) addresses comments received from WGLC, PM-DIR and SDP-DIR Review.
The diff is:
http://www.ietf.org/rfcdiff?url2=draft-ietf-xrblock-rtcp-xr-qoe-09

The main changes are:
   o  Change an existing SDP attribute 'extmap' to new SDP attribute
      'calgextmap' and add new SDP attribute registry.
   o  Add Reference to G.107.1, P.862.1, P.862.2 and P.863 for new
      calculation algorithms.
   o  Add MoS type attribute to distinguish different MoS types.

One open issue may remain, since some people concerns that MoS is just one aspect of QoE,
And suggest changing QoE metrics reporting into MoS metrics reporting.
However Some people disagreed given by MoS is widely used. 
So it is still not clear to me whether we should  change the title or add some text to clarify that
We don't preclude other standards metrics to report media quality information besides MoS metrics reporting.
The current version follows the second approach (See update in the section 1.1).

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 18 Jun 2013 10:56:48 +0000

Hi Qin,

Thanks for the update. 

> One open issue may remain, since some people concerns that MoS is just
> one aspect of QoE, And suggest changing QoE metrics reporting into MoS
> metrics reporting.
> So it is still not clear to me whether we should  change the title or
> add some text to clarify that We don't preclude other standards metrics
> to report media quality information besides MoS metrics reporting.

On the open issue - Ali Begen made the comment in his SDP Directorate review and made the suggestion to change the name of the document. He marked his comment as critical. If possible I would like to hear his opinion on the proposed clarification. 

Speaking as a contributor, I believe that the text in Section 1.1 is not sufficiently explicit in making clear that other metrics may be used provide an estimation of media quality. 

So maybe: 

OLD: 

   The new block type provides information on media quality using one of
   several standard metrics (i.e.,Mean Opinion Score(MoS)).

NEW: 

   The new block type provides information on media quality using one of
   standard metrics (i.e., Mean Opinion Score (MoS)) for QoE. Note that 
   other metrics may be used to determine media quality.

Regards,

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Qin Wu
> Sent: Tuesday, June 18, 2013 11:44 AM
> To: 'xrblock'
> Subject: [xrblock] FW: I-D Action: draft-ietf-xrblock-rtcp-xr-qoe-09.txt
> 
>  This draft is a work item of the Metric Blocks for use with RTCP's
> Extended Report Framework Working Group of the IETF.
> 
> One open issue may remain, since some people concerns that MoS is just
> one aspect of QoE, And suggest changing QoE metrics reporting into MoS
> metrics reporting.
> So it is still not clear to me whether we should  change the title or
> add some text to clarify that We don't preclude other standards metrics
> to report media quality information besides MoS metrics reporting.
> _______________________________________________
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Tue, 18 Jun 2013 11:15:36 +0000

>> However Some people disagreed given by MoS is widely used.

Only for certain apps not all media apps. I am not a MOS guy but for the media apps I am interested it, MOS does not give me anything useful for measuring QoE. 

>> The current version follows the second approach (See update in the

I will leave this to the discretion of the WG but my comment still stands. I have my doubts about newer non-MOS methods being registered to be used by this block. IOW, this document might be a good solution for the applications that you use the metrics you already registered but for others, I am quite doubtful. So, changing the title will be more accurate. "QoE" is quite a buzz word, which probably does not belong to an RFC title.

If you disagree with this, at least you could offer some text explaining this. Dan's suggestion is a good start.

---

From: Qin Wu <[email-masked]>
Date: Mon, 24 Jun 2013 09:10:17 +0000

I am okay to replace QoE metrics in the draft with MoS metrics.
I believe this addresses your comment.

Regards!
-Qin