Subject: [yang-doctors] anima/yang-doctors: cross stds boddy extension mechanism ?

From: Toerless Eckert <[email-masked]>
Date: Tue, 27 Jun 2017 17:07:49 +0200

Dear Yang doctors

In our draft-ietf-anima-voucher we are looking for an optional extension mechanism
wheeby a yang data structure we define in the draft shuold optionally be able
to have a substructure that we would like to possibly be defined by a different
standards body than the IETF. Do we have such an extension mechanism ? If not
in Yang natively, maybe via a mechanism of specific encodings ? We are planning
to mandate JSON as the encoding for our protocols using the data model.

Thanks
    Toerless

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 27 Jun 2017 17:17:33 +0200 (CEST)

Hi,

Toerless Eckert <[email-masked]> wrote:
> standards body than the IETF. Do we have such an extension mechanism ?

Unfortunately not :(   YANG has the "augment" statement, but it can
not augment a structure that has been defined with the extension
"rc:yang-data".  (For this reason, I have proposed that YANG should
have a core statement to define structures, instead of having to rely
on rc:yang-data, but this requires a new YANG version...)

Of course, one *could* define another extension statement
"augment-yang-data" for this purpose, but it's probably not a good
idea; we should be careful with defining extensions... 

/martin

> If not
> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors
>