Subject: [yang-doctors] Do we need a YANG doctor lunch meeting at the IETF meeting?

From: Benoit Claise <[email-masked]>
Date: Tue, 20 Jun 2017 18:26:12 +0200

Regards, Benoit

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 20 Jun 2017 10:32:35 -0700

I would like to have a discussion around what advise we are giving to folks on the new NMDA architecture, and bring up any issues that folks are seeing as they move their models to the new architecture.

> On Jun 20, 2017, at 9:26 AM, Benoit Claise <[email-masked]> wrote:
> 
> Regards, Benoit
> 
> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors

Mahesh Jethanandani
[email-masked]

---

From: Benoit Claise <[email-masked]>
Date: Tue, 20 Jun 2017 21:43:05 +0200

Ok. A room has been booked for Tuesday lunch break.

Regards, B.
> .

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 20 Jun 2017 21:48:03 +0200

I wonder whether we need a general informal 'NMDA Q&A' session that is
open to everybody who is interested and where we briefly explain the
current NMDA model and then answer any questions people may have.

There are two NETMOD meetings (Mo afternoon and We afternoon). If NMDA
WG discussions go into the second meeting, we could use say a Monday
evening bar session (if someone sponsors beer even better - but not
required).

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Benoit Claise <[email-masked]>
Date: Tue, 20 Jun 2017 21:52:27 +0200

I like that.
We use to have that kind of session on Sunday afternoon, part of the EDU 
effort.

Regards, Benoit

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 20 Jun 2017 23:00:47 +0200

I was thinking about something low overhead and informal and ideally
as interactive as possible (few slides, more focus on questions and
answers)...

/js

---

From: Andy Bierman <[email-masked]>
Date: Tue, 20 Jun 2017 14:26:50 -0700

Hi,

IMO there is not much to discuss about RD until there are protocol
definitions.
Understanding how operators will handle the migration is just as important
as
how YANG authors will handle the migration.

I am still not hearing enthusiasm from customer types about RD.
Maybe some big routers are so distributed that they need to be
designed as if they were controller platforms. I think normal and smaller
devices do not experience long delays between intended and applied.
These vendors are not seeing any value in RD.

Andy

On Tue, Jun 20, 2017 at 2:00 PM, Juergen Schoenwaelder <
[email-masked]> wrote:

> > > > I would like to have a discussion around what advise we are giving
> to folks on the new NMDA architecture, and bring up any issues that folks
> are seeing as they move their models to the new architecture.
> > > >

---

From: Andy Bierman <[email-masked]>
Date: Tue, 20 Jun 2017 15:33:52 -0700

Hi,

I have a topic that is probably not workable but the issue is very common.

It would be nice if YANG library repositories were more consistent and
official.
There is currently a ban against packaging YANG modules (e.g., RPM or
Debian)
because of concerns the IETF Trust copyright will be violated somehow.
Maybe this could be changed somehow.

The packages could correlate to the YANG catalog, e.g. an
ietf-routing_1.0.deb package.
I have been advocating YANG packages for a few years. IMO it is hopelessly
futile to
attempt to manage a device as a random collection of individual modules.

I have been working on Yocto/bitbake recently and the amount of high-quality
tools (see OpenEmbedded) is quite impressive. We could have something like
a bitbake recipe
that describes the YANG requirements for some service or feature package.
Vendors could
append the recipes to optimize for their platforms. Recipes could point at
open-source code
or even vendor libraries that provides instrumentation for a YANG package.
We need distributed recipes, not a centralized catalog server, although
they could work together.

Andy

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 21 Jun 2017 11:57:13 +0200

> attempt to manage a device as a random collection of individual

I would support this. I believe it is necessary to sort of "emancipate"
YANG library, i.e. treat it as metadata that can exist on its own rather
than plain state data provided by a server, or perhaps as a module-level
data modelling language.

Also, I believe it would be extremely helpful to step back and somehow
streamline and simplify all what we have, and in particular integrate
YANG library with datastores and the "use-schema" part of schema mount
into a coherent whole that is (relatively) easy to understand. Not doing
so and just increasing complexity along several axes has IMO the
potential to kill the YANG business as such.

I already made a concrete initial proposal in Chicago:

https://www.ietf.org/mail-archive/web/netmod/current/msg18045.html

Lada

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: Kent Watsen <[email-masked]>
Date: Wed, 21 Jun 2017 14:09:34 +0000

> than plain state data provided by a server, or perhaps as a module-level

I don't follow, how can this metadata be independent of a server?  Are you
thinking that it may be useful for rc:yang-data?

> https://www.ietf.org/mail-archive/web/netmod/current/msg18045.html

This is a good proposal.  It is also something that the NMDA-authors have
been iterating towards as well: 
  - a list of all modules supported by the server (regardless of datastore)
  - a list of module-sets (what you call "schema") that has leafrefs to modules
  - a list of datastores that has leafrefs to module-sets

Kent

---

From: Andy Bierman <[email-masked]>
Date: Wed, 21 Jun 2017 07:12:20 -0700

> potential to kill the YANG business as such.

I think the YANG catalog module attempts to provide off-box metadata.
The OpenEmbedded project is far superior to anything the IETF could do
on its own, but serves as an existence proof that building blocks can
be managed somehow (layers, feature-groups, packages for yocto).

Networking equipment is still built with a monolithic mindset, so it
will be difficult for vendors to provide real modularity. The first-level
goal
is to let YANG designers and operators organize YANG APIs at a higher
level than individual YANG modules.

I think the YANG catalog work is properly motivated and heading
in the right direction to define the packages.

Andy

---

From: Benoit Claise <[email-masked]>
Date: Wed, 21 Jun 2017 16:44:45 +0200

Hi
> IMO there is not much to discuss about RD until there are protocol 
Since we have provided guidelines on how to design new YANG modules in 
the IETF, there is something to discuss: how to help the YANG module 
authors migrate, if help is needed.

Regards, Benoit
> Understanding how operators will handle the migration is just as 
> important as
> On Tue, Jun 20, 2017 at 2:00 PM, Juergen Schoenwaelder 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     > > > I would like to have a discussion around what advise we are
>     giving to folks on the new NMDA architecture, and bring up any
>     issues that folks are seeing as they move their models to the new
>     architecture.
>     > > >
>     > > > > On Jun 20, 2017, at 9:26 AM, Benoit Claise
>     <[email-masked] <mailto:[email-masked]>> wrote:
>     > > > >
>     > > > > Regards, Benoit
>     > > > >
>     > > > > [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/yang-doctors>
>     > > > Mahesh Jethanandani
>     > > > [email-masked] <mailto:[email-masked]>
>     > > >
>     > > > [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/yang-doctors>
>     >
>     > [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/yang-doctors>
>
>     --
>     Fax:   +49 421 200 3103         <http://www.jacobs-university.de/
>     <http://www.jacobs-university.de/>>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/yang-doctors>
>
>

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 21 Jun 2017 17:19:53 +0200

> On 21 Jun 2017, at 16:09, Kent Watsen <[email-masked]> wrote:
> 
> 
> 

YANG modules can also be served by NETCONF/RESTCONF servers, but I think we understand they exist independently - they are published in RFCs, processed by tools etc. So, the information provided by (extended) YANG library could be thought of as a specification of an entire data model consisting of a number of YANG modules. It too could be published etc.

I think what Andy proposed is more about conformance requirements, which is probably a little bit different - e.g., you want to specify a range of module revisions that are compatible. What I have in mind is more a specification of a concrete data model including any number of modules in specific revisions but also datastores and schema-mount info. So tools can eventually construct data models for all datastores, no matter how they are constructed.

>  - a list of datastores that has leafrefs to module-sets

Yes, exactly.

Thanks, Lada

---

From: Benoit Claise <[email-masked]>
Date: Thu, 22 Jun 2017 11:46:40 +0200

Ok, I booked a room for Tuesday lunch time.
Since it concerns Joe Clarke, cc'ing Joe Clarke.

Regards, Benoit
> I have been advocating YANG packages for a few years. IMO it is 
> hopelessly futile to
> tools (see OpenEmbedded) is quite impressive. We could have something 
> like a bitbake recipe
> that describes the YANG requirements for some service or feature 
> package.  Vendors could
> append the recipes to optimize for their platforms. Recipes could 
> point at open-source code
> We need distributed recipes, not a centralized catalog server, 
> although they could work together.

>
>
>
>
> Andy
>
>
>
>
>
>
> On Tue, Jun 20, 2017 at 9:26 AM, Benoit Claise <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Regards, Benoit
>

---

From: Benoit Claise <[email-masked]>
Date: Thu, 22 Jun 2017 11:53:01 +0200

Andy,
>
>
> On Wed, Jun 21, 2017 at 2:57 AM, Ladislav Lhotka <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Andy Bierman <[email-masked] <mailto:[email-masked]>> writes:
>
>     > Hi,
>     >
>     hopelessly
You will get a presentation of it during the OPS-AREA meeting.
> will be difficult for vendors to provide real modularity. The 
> first-level goal
Yes.
This is the notion of release bundle in 
draft-openconfig-netmod-model-catalog/

Note that they YANG module behind yangcatalog.org diverged from 
draft-openconfig-netmod-model-catalog, for good reasons.
Joe and I are preparing an IETF draft to explain those.

How many YANG doctors will we see in the hackathon ...

Regards, Benoit
>     <https://www.ietf.org/mail-archive/web/netmod/current/msg18045.html>
>
>     Lada
>
>
>
> Andy
>
>
>     >
>     package.
>     > On Tue, Jun 20, 2017 at 9:26 AM, Benoit Claise

---

From: Benoit Claise <[email-masked]>
Date: Thu, 22 Jun 2017 11:57:07 +0200

> I think what Andy proposed is more about conformance requirements, which is probably a little bit different - e.g., you want to specify a range of module revisions that are compatible. What I have…
both make sense IMO.

Regards, B.

---

From: Kent Watsen <[email-masked]>
Date: Thu, 22 Jun 2017 12:51:04 +0000

> How many YANG doctors will we see in the hackathon ...

I'll be there for the hackathon. 

K.

---

From: "Giles Heron (giheron)" <[email-masked]>
Date: Thu, 22 Jun 2017 13:05:07 +0000

Likewise will try to go over for that (need to check budget etc.)

> On 22 Jun 2017, at 13:51, Kent Watsen <[email-masked]> wrote:
> 
> 
>

---

From: Radek Krejčí <[email-masked]>
Date: Fri, 23 Jun 2017 08:45:24 +0200

I should be there,

Radek

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 23 Jun 2017 10:05:19 +0200

> On 23 Jun 2017, at 08:45, Radek Krejčí <[email-masked]> wrote:
> 
> I should be there,
> 
> Radek
> 

Me too.

Lada

---

From: "Mehmet Ersue" <[email-masked]>
Date: Fri, 23 Jun 2017 16:40:23 +0200

looks good

Cheers,
Mehmet

> -----Original Message-----
> From: yang-doctors [mailto:[email-masked]] On Behalf Of
> Radek Krejcí
> Sent: Friday, June 23, 2017 8:45 AM
> To: Benoit Claise <[email-masked]>
> Cc: YANG Doctors <[email-masked]>; Joe Clarke (jclarke)
> <[email-masked]>
> Subject: Re: [yang-doctors] Do we need a YANG doctor lunch meeting at the
> IETF meeting?
> 
> I should be there,
> 
> Radek
> 
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 26 Jun 2017 18:39:23 +0200

> How many YANG doctors will we see in the hackathon ...

I will most likely arrive Sunday afternoon, too late for the
hackathon.

/js

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 26 Jun 2017 16:45:53 -0700

I arrive Sat. afternoon.

> On Jun 26, 2017, at 9:39 AM, Juergen Schoenwaelder <[email-masked]> wrote:
> 

Mahesh Jethanandani
[email-masked]

---

From: Andy Bierman <[email-masked]>
Date: Mon, 26 Jun 2017 16:56:01 -0700

Hi,

me too, but not going to the hackathon.

Andy

On Mon, Jun 26, 2017 at 4:45 PM, Mahesh Jethanandani <
[email-masked]> wrote:

> I arrive Sat. afternoon.
>
> > On Jun 26, 2017, at 9:39 AM, Juergen Schoenwaelder <

---

From: Benoit Claise <[email-masked]>
Date: Tue, 27 Jun 2017 09:22:52 +0200

As the subject says: Meeting move from Tuesday lunch to Thursday lunch
Tuesday, there is a 3GPP/IETF/5G collaboration meeting I need to attend.

Regards, B.
>> It would be nice if YANG library repositories were more consistent 
>> and official.

---

From: "Mehmet Ersue" <[email-masked]>
Date: Tue, 27 Jun 2017 13:16:44 +0200

same

Cheers,

Mehmet

From: yang-doctors [mailto:[email-masked]] On Behalf Of Andy Bierman
Sent: Tuesday, June 27, 2017 1:56 AM
To: Mahesh Jethanandani <[email-masked]>
Cc: YANG Doctors <[email-masked]>; Joe Clarke (jclarke) <[email-masked]>
Subject: Re: [yang-doctors] Do we need a YANG doctor lunch meeting at the IETF meeting?

Hi,

Andy

On Mon, Jun 26, 2017 at 4:45 PM, Mahesh Jethanandani <[email-masked] <mailto:[email-masked]> > wrote:

I arrive Sat. afternoon.

> On Jun 26, 2017, at 9:39 AM, Juergen Schoenwaelder <[email-masked] <mailto:[email-masked]> > wrote:
>

Mahesh Jethanandani