Subject: Re: [yang-doctors] Do we need a YANG doctor lunch meeting at the IETF meeting? Meeting move from Tuesday lunch to Thursday lunch

From: "Mehmet Ersue" <[email-masked]>
Date: Sun, 16 Jul 2017 14:26:51 +0200

Which room?

Cheers,

Mehmet

From: yang-doctors [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Tuesday, June 27, 2017 9:23 AM
To: Andy Bierman <[email-masked]>
Cc: YANG Doctors <[email-masked]>; Joe Clarke (jclarke) <[email-masked]>
Subject: Re: [yang-doctors] Do we need a YANG doctor lunch meeting at the IETF meeting? Meeting move from Tuesday lunch to Thursday lunch

As the subject says: Meeting move from Tuesday lunch to Thursday lunch
Tuesday, there is a 3GPP/IETF/5G collaboration meeting I need to attend.

Regards, B.

Ok, I booked a room for Tuesday lunch time.
Since it concerns Joe Clarke, cc'ing Joe Clarke.

Regards, Benoit

Hi, 

I have a topic that is probably not workable but the issue is very common.

It would be nice if YANG library repositories were more consistent and official.

There is currently a ban against packaging YANG modules (e.g., RPM or Debian)

because of concerns the IETF Trust copyright will be violated somehow.

Maybe this could be changed somehow.

The packages could correlate to the YANG catalog, e.g. an ietf-routing_1.0.deb package.

I have been advocating YANG packages for a few years. IMO it is hopelessly futile to

attempt to manage a device as a random collection of individual modules.

I have been working on Yocto/bitbake recently and the amount of high-quality

tools (see OpenEmbedded) is quite impressive. We could have something like a bitbake recipe

that describes the YANG requirements for some service or feature package.  Vendors could

append the recipes to optimize for their platforms. Recipes could point at open-source code

or even vendor libraries that provides instrumentation for a YANG package.

We need distributed recipes, not a centralized catalog server, although they could work together.

 

Andy

 

On Tue, Jun 20, 2017 at 9:26 AM, Benoit Claise <[email-masked] <mailto:[email-masked]> > wrote:

Regards, Benoit

_______________________________________________
yang-doctors mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/yang-doctors

_______________________________________________
yang-doctors mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/yang-doctors

---

From: Benoit Claise <[email-masked]>
Date: Thu, 20 Jul 2017 07:41:30 +0200

12:15, Paris Room (Lobby Level (L))
And don't forget to bring your own lunch.

Regards, B.
>
> Which room?
>
> Cheers,
>
> Mehmet
>
> *From:*yang-doctors [mailto:[email-masked]] *On Behalf 
> Of *Benoit Claise
> *Sent:* Tuesday, June 27, 2017 9:23 AM
> *To:* Andy Bierman <[email-masked]>
> *Cc:* YANG Doctors <[email-masked]>; Joe Clarke (jclarke) 
> <[email-masked]>
> *Subject:* Re: [yang-doctors] Do we need a YANG doctor lunch meeting 
> at the IETF meeting? Meeting move from Tuesday lunch to Thursday lunch
>
>         On Tue, Jun 20, 2017 at 9:26 AM, Benoit Claise
>         <[email-masked] <mailto:[email-masked]>> wrote:
>
>             Regards, Benoit
>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 20 Jul 2017 02:19:40 -0700

Hi,

I don't think I will be able to attend this meeting.
I want to attend the opensource routing meeting at the same time as this
meeting.
Whatever recommendations for NMDA that you decide is fine with me.
Looking forward to text to put into 6087bis.

Andy

On Wed, Jul 19, 2017 at 10:41 PM, Benoit Claise <[email-masked]> wrote:

> *From:* yang-doctors [mailto:[email-masked]
> <[email-masked]>] *On Behalf Of *Benoit Claise
> *To:* Andy Bierman <[email-masked]> <[email-masked]>
> *Cc:* YANG Doctors <[email-masked]> <[email-masked]>; Joe
> Clarke (jclarke) <[email-masked]> <[email-masked]>
> *Subject:* Re: [yang-doctors] Do we need a YANG doctor lunch meeting at
> the IETF meeting? Meeting move from Tuesday lunch to Thursday lunch
>
>
>
> On Tue, Jun 20, 2017 at 9:26 AM, Benoit Claise <[email-masked]> wrote:
>
> Regards, Benoit
>
> [email-masked]
> [email-masked]

---

From: Benoit Claise <[email-masked]>
Date: Thu, 20 Jul 2017 11:50:10 +0200

Actually, the main agenda item was yours below: packages.

Regards, B.

> I want to attend the opensource routing meeting at the same time as 
> this meeting.
> On Wed, Jul 19, 2017 at 10:41 PM, Benoit Claise <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>>     *From:*yang-doctors [mailto:[email-masked]
>>     <mailto:[email-masked]>] *On Behalf Of *Benoit Claise
>>     *To:* Andy Bierman <[email-masked]> <mailto:[email-masked]>
>>     *Cc:* YANG Doctors <[email-masked]>
>>     <mailto:[email-masked]>; Joe Clarke (jclarke)
>>     <[email-masked]> <mailto:[email-masked]>
>>     *Subject:* Re: [yang-doctors] Do we need a YANG doctor lunch
>>     meeting at the IETF meeting? Meeting move from Tuesday lunch to
>>     Thursday lunch
>>
>>             We need distributed recipes, not a centralized catalog
>>             server, although they could work together.
>>
>>
>>
>>             Andy
>>
>>                 <https://www.ietf.org/mailman/listinfo/yang-doctors>
>>
>>
>>
>>
>>
>>         <https://www.ietf.org/mailman/listinfo/yang-doctors>
>>
>
>