Subject: [yang-doctors] MIB/YANG and non ASCII chars

From: Benoit Claise <[email-masked]>
Date: Sun, 16 Jul 2017 10:29:24 +0200

Dear all,

Are SMICng, pyang, yanglint (and other validators) compliant?

Regards, Benoit

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sun, 16 Jul 2017 11:41:06 +0200

> Are SMICng, pyang, yanglint (and other validators) compliant?

SMIv2 does generally not support non ASCII chars. While there are some
data types that can carry non ASCII chars, the language itself does
not support non ASCII chars.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Benoit Claise <[email-masked]>
Date: Sun, 16 Jul 2017 12:30:32 +0200

> not support non ASCII chars.
what about contact names or description?

Regards, B.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sun, 16 Jul 2017 12:46:57 +0200

> what about contact names or description?

Including contact names or descriptions.

/js

---

From: Radek Krejčí <[email-masked]>
Date: Sun, 16 Jul 2017 14:38:05 +0200

Hi,
yanglint should be UTF8 compliant as YANG specification requires.

Radek

Dne 16.7.2017 v 10:29 Benoit Claise napsal(a):
> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 16 Jul 2017 15:10:15 +0200

Hi Benoit,

I just talked with Bill Fenner about bap / abnf-checker, and it will
have to be updated once there's document specifying how to handle
unicode in abnf.  There's currently this candidate document:

draft-seantek-unicode-in-abnf:
<https://tools.ietf.org/html/draft-seantek-unicode-in-abnf-03>

Best,

	Henrik

---

From: Sandy Ginoza <[email-masked]>
Date: Mon, 17 Jul 2017 10:00:00 +0200

Hi all,

Thanks for your quick replies and info!  It sounds like none of these are an issue right now, which is great news.

Thanks!
Sandy

1. MIBs: non-ASCII not allowed
2. YANG: checker is compliant 
3. ABNF: doc & checker need to be updated to handle UTF-8

> On Jul 16, 2017, at 3:10 PM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Benoit,
>