Subject: [yang-doctors] Fwd: [netmod] YANG module security considerations

From: Benoit Claise <[email-masked]>
Date: Thu, 21 Dec 2017 10:40:52 +0100

YANG doctors,

I have not seen any reaction to this proposal on the NETMOD mailing list.

On one side, Lada's proposal is more accurate
One the other side, some consistency in the Security Considerations for 
all YANG module makes sense.

Is it worth updating the Security Considerations template?
What do you think?

Regards, Benoit

-------- Forwarded Message --------
Subject: 	[netmod] YANG module security considerations
Date: 	Fri, 01 Dec 2017 13:13:02 +0100
From: 	Ladislav Lhotka <[email-masked]>
Organization: 	CZ.NIC
To: 	NETMOD WG <[email-masked]>

Hi,

the security considerations template text [1] that has already been used in a
number of documents is apparently incorrect - YANG modules aren't accessed by NM
protocols. Hence

OLD

The YANG module defined in this document is designed to be accessed via network
management protocols such as ...

NEW

The YANG module specified in this document defines a schema for data that is
designed to be accessed via network management protocols such as ...

[1] https://trac.ietf.org/trac/ops/wiki/yang-security-guidelines

Lada

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod
.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 21 Dec 2017 10:48:01 +0100

Benoit,

I suggest you change the template and we move on.

/js

On Thu, Dec 21, 2017 at 10:40:52AM +0100, Benoit Claise wrote:
> One the other side, some consistency in the Security Considerations for all
> YANG module makes sense.
> 

> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 21 Dec 2017 11:04:18 +0100

> I have not seen any reaction to this proposal on the NETMOD mailing list. 

Acee replied in support of the change.

Lada

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 21 Dec 2017 11:07:16 +0100 (CET)

> I suggest you change the template and we move on.

I also support the change.

/martin

---

From: Benoit Claise <[email-masked]>
Date: Thu, 21 Dec 2017 11:14:15 +0100

Ok.

1. Template changed at 
https://trac.ietf.org/trac/ops/wiki/yang-security-guidelines
2. Let me inform NETMOD and the RFC editor for the YANG modules being 
currently processed.
3. If you are an author, change your document.
4. When doing YANG doctor reviews, inform the authors of the new template.

Regards, Benoit