Subject: [yang-doctors] 2 yang beginner questions

From: Toerless Eckert <[email-masked]>
Date: Sat, 31 Mar 2018 05:07:39 +0200

a) Is there some yang-users mailing list where i wouldn't have to bother
   yang-doctors precious time with beginner questions, but rather seek
   help from folks who may like me just be learning up yang themselves 
   (and be a bit ahead) ?

   Typically the most easiest way to learn something is to be subscribed
   to a list where other beginners ask questions and get them answered too ;-)

b) https://tools.ietf.org/html/draft-ietf-anima-voucher-07

   I am confused about the best way to express an OR condition.

   container voucher {
      leaf expires-on {
         must "not(../nonce)"
      }
      leaf nonce {
         must "not(../expires-on)"
      }
   }

   What we do WANT to achieve is that you may have at least one of 
   the leaf expires-on or nonce. Having both is fine too (inclusive or).
   Just not having either is not permitted.

   Is this the correct syntax to do that ? Is that the preferred syntax to do this ?

Thanks
    Toerless

---

From: Andy Bierman <[email-masked]>
Date: Fri, 30 Mar 2018 20:14:02 -0700

>    Is this the correct syntax to do that ? Is that the preferred syntax to
  container voucher {
      must "expires-on or nonce";
      leaf expires-on {
      ...
      }
      leaf nonce {
       ....
      }
   }

>     Toerless
Andy

> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors
>

---

From: "Mehmet Ersue" <[email-masked]>
Date: Sat, 31 Mar 2018 13:57:42 +0200

Dear Toerless,

at IETF we have only the netmod and yang-doctors maillists.
AFAIK so far on both lists people are keen of answering any kind of
questions.

In case you didn't know the "YANG Doctor's FAQ Page" just check it.
You can reach it via: 
https://datatracker.ietf.org/group/yangdoctors/about/

Cheers,
Mehmet

> -----Original Message-----
> From: yang-doctors <[email-masked]> On Behalf Of Toerless
> Eckert
> Sent: Saturday, March 31, 2018 5:08 AM
> To: [email-masked]
> Subject: [yang-doctors] 2 yang beginner questions
> 
>    to a list where other beginners ask questions and get them answered too
;-
> )
>    Is this the correct syntax to do that ? Is that the preferred syntax to
do this
> ?