Subject: [yang-doctors] FW: [CCAMP] I-D Action: draft-ietf-ccamp-mw-yang-07.txt

From: Jonas Ahlberg <[email-masked]>
Date: Mon, 2 Jul 2018 16:24:26 +0000

Hi all,

A new version of the draft-ietf-ccamp-mw-yang-07.txt has been submitted.

We had hoped to be able to resolve the 2 yang errors reported from the validation at submission, but still no success.
The issue we have is that neither the validation tool at http://www.yangvalidator.com/ nor when running pyang locally reports those errors.

The only minor change we've done is to update the range for some of the power related leafs in the microwave-radio-link module.

Regards
JonasA 

-----Original Message-----
From: CCAMP <[email-masked]> On Behalf Of [email-masked]
Sent: den 2 juli 2018 16:53
To: [email-masked]
Cc: [email-masked]
Subject: [CCAMP] I-D Action: draft-ietf-ccamp-mw-yang-07.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Common Control and Measurement Plane WG of the IETF.

        Title           : A YANG Data Model for Microwave Radio Link
        Authors         : Jonas Ahlberg
                          Ye Min
                          Xi Li
                          Daniela Spreafico
                          Marko Vaupotic
	Filename        : draft-ietf-ccamp-mw-yang-07.txt
	Pages           : 51
	Date            : 2018-07-02

Abstract:
   This document defines a YANG data model for control and management of
   the radio link interfaces, and their connectivity to packet
   (typically Ethernet) interfaces in a microwave/millimeter wave node.
   The data nodes for management of the interface protection
   functionality is broken out into a separate and generic YANG data
   model in order to make it available also for other interface types.

RFC Ed.  Note

   // RFC Ed.: replace all XXXX throughout the document with actual RFC
   numbers and remove this note

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ccamp-mw-yang/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ccamp-mw-yang-07
https://datatracker.ietf.org/doc/html/draft-ietf-ccamp-mw-yang-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-mw-yang-07

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 2 Jul 2018 09:29:14 -0700

Jonas,

The two errors are not as a result of bugs in your YANG module. It is an issue with the tool. As you suggest, you do not see the errors when run locally. I would ignore them for now.

Cheers.

> On Jul 2, 2018, at 9:24 AM, Jonas Ahlberg <[email-masked]> wrote:
> 
> Hi all,
> 
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors

Mahesh Jethanandani
[email-masked]

---

From: Benoit Claise <[email-masked]>
Date: Mon, 2 Jul 2018 18:34:48 +0200

Jonas,

It passes correctly in my toolchain.
http://www.claise.be/IETFYANGPageCompilation.html
Let me open a bug with the tools team.

Regards, Benoit
> .

---

From: Benoit Claise <[email-masked]>
Date: Mon, 2 Jul 2018 18:44:16 +0200

Actually, IANA updated [email-masked] 
<https://www.iana.org/assignments/yang-parameters/[email-masked]> 
at 
https://www.iana.org/assignments/yang-parameters/yang-parameters.xhtml 
and made a mistake: a } is missing at the end of the file
Let me follow up with IANA.

Regards, B.
>> We had hoped to be able to resolve the 2 yang errors reported from 
>> the validation at submission, but still no success.
>> The issue we have is that neither the validation tool at 
>> http://www.yangvalidator.com/ nor when running pyang locally reports 
>> those errors.
>>
>> The only minor change we've done is to update the range for some of 
>> the power related leafs in the microwave-radio-link module.
>>
>> Regards
>> JonasA
>>
>> Please note that it may take a couple of minutes from the time of 
>> submission until the htmlized version and diff are available at 
>> tools.ietf.org.
>>

---

From: Jonas Ahlberg <[email-masked]>
Date: Tue, 3 Jul 2018 07:59:08 +0000

Hi Benoit,

Thank you for the help and support!

Regards
JonasA

From: Benoit Claise <[email-masked]>
Sent: den 2 juli 2018 18:44
To: Benoit Claise <bclaise=[email-masked]>; Jonas Ahlberg <[email-masked]>; [email-masked]' <[email-masked]>; [email-masked]
Subject: Re: [yang-doctors] FW: [CCAMP] I-D Action: draft-ietf-ccamp-mw-yang-07.txt

Actually, IANA updated [email-masked]<https://www.iana.org/assignments/yang-parameters/[email-masked]> at https://www.iana.org/assignments/yang-parameters/yang-parameters.xhtml and made a mistake: a } is missing at the end of the file
Let me follow up with IANA.

Regards, B.
Jonas,

Regards, Benoit

Hi all,

Regards
JonasA

-----Original Message-----
From: CCAMP <[email-masked]><mailto:[email-masked]> On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: den 2 juli 2018 16:53
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [CCAMP] I-D Action: draft-ietf-ccamp-mw-yang-07.txt

Abstract:

RFC Ed.  Note

_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp

_______________________________________________
yang-doctors mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/yang-doctors
.

_______________________________________________
yang-doctors mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/yang-doctors
.

---

From: Benoit Claise <[email-masked]>
Date: Tue, 3 Jul 2018 21:09:49 +0200

Hi,

[email-masked] 
<https://www.iana.org/assignments/yang-parameters/[email-masked]>contains 
the fix.

Regards, Benoit
<https://www.iana.org/assignments/yang-parameters/[email-masked]>
> *From:*Benoit Claise <[email-masked]>
> *Sent:* den 2 juli 2018 18:44
> *To:* Benoit Claise <bclaise=[email-masked]>; Jonas 
> Ahlberg <[email-masked]>; [email-masked]' 
> <[email-masked]>; [email-masked]
> *Subject:* Re: [yang-doctors] FW: [CCAMP] I-D Action: 
> draft-ietf-ccamp-mw-yang-07.txt
>
>         We had hoped to be able to resolve the 2 yang errors reported
>         from the validation at submission, but still no success.
>         http://www.yangvalidator.com/ <http://www.yangvalidator.com/>
>         nor when running pyang locally reports those errors.
>
>         The only minor change we've done is to update the range for
>         some of the power related leafs in the microwave-radio-link
>         module.
>
>         Regards
>         JonasA
>
>         From: CCAMP <[email-masked]>
>         <mailto:[email-masked]> On Behalf Of
>         [email-masked] <mailto:[email-masked]>
>         To: [email-masked] <mailto:[email-masked]>
>         Cc: [email-masked] <mailto:[email-masked]>
>         Please note that it may take a couple of minutes from the time
>         of submission until the htmlized version and diff are
>         available at tools.ietf.org.
>
>         [email-masked] <mailto:[email-masked]>
>         [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: Benoit Claise <[email-masked]>
Date: Thu, 5 Jul 2018 00:24:29 +0200

> <https://www.iana.org/assignments/yang-parameters/[email-masked]>contains 
And the tracker cron job did its job.
https://datatracker.ietf.org/doc/draft-ietf-ccamp-mw-yang/ => no more 
issues.

Regards, Benoit
>>         Please note that it may take a couple of minutes from the
>>         time of submission until the htmlized version and diff are