Subject: [yang-doctors] Yangdoctors last call review of draft-ietf-i2rs-yang-l2-network-topology-13

From: Ladislav Lhotka via Datatracker <[email-masked]>
Date: Tue, 23 Jun 2020 06:52:02 -0700

Reviewer: Ladislav Lhotka
Review result: Ready with Nits

I already reviewed revision -04 of this document with the conclusion that from
YANG point of view it is ready to be published. It is still the case with the
current revision -13. All my earlier comments have been addressed.

I appreciate the example in Appendix B, it is really useful. However, I
discovered several problems with the JSON instance data:

- In all 6 entries of the "ietf-network-topology:link" list, commas are missing
after the "source" object.

- The identifier "ietf-l2-topology:l2-termination-point-attributes" is split
between two lines (7 times), which makes it invalid. While this is explained in
the introductory text, I would suggest to find another way of satisfying the 72
character limit that doesn't affect the instance data validity. One option is
to use the convention of draft-ietf-netmod-artwork-folding-12, but it is also
possible to simply dedent the offending lines.

- According to the rules of RFC 7951, the identifier of "termination-point"
list needs to be qualified with module name, i.e.
"ietf-network-topology:termination-point".

- The format of "mac-address" leaves doesn't match the regex pattern of their
types: semicolons rather than dashes have to be used as octet separators.

---

From: <[email-masked]>
Date: Thu, 25 Jun 2020 08:58:55 +0000

Hi Lada, 

Thank you for the review. 

We have already fixed the first two comments in our local copy. We updated the text to fix the two remaining ones: 

FWIW, the updated text can be seen at: 
https://github.com/boucadair/draft-ietf-i2rs-yang-l2-network-topology/blob/master/draft-ietf-i2rs-yang-l2-network-topology-14.txt 

diff:
https://github.com/boucadair/draft-ietf-i2rs-yang-l2-network-topology/blob/master/diff-IETF-LC.pdf 

Cheers,
Med

> -----Message d'origine-----
> De : Ladislav Lhotka via Datatracker [mailto:[email-masked]]
> Envoyé : mardi 23 juin 2020 15:52
> À : [email-masked]
> Cc : [email-masked]; draft-ietf-i2rs-yang-l2-network-
> [email-masked]; [email-masked]
> Objet : Yangdoctors last call review of draft-ietf-i2rs-yang-l2-network-
> topology-13
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.