Subject: [Yang-multicast] IGMP Yang

From: Anish Peter <[email-masked]>
Date: Tue, 15 Dec 2015 11:57:51 +0530

Hi Folks,
  I have created tables in the wiki for igmp config. Please populate the 
table.
  One of the point for discussion is igmp/mld being vrf aware. GMP 
(IGMP/MLD) being a per interface protocol an implementation of the same 
need not be vrf aware. But few of the configs could be global. This is 
the background for the first gmp table to indicate if your preference is 
to have igmp yang tree to be vrf based or not.
  Hence the possible points for augmentation consideration are
1. augment /if:interfaces/if:interface/ip:ipv4:
2. augment /rt:routing/rt:routing-instance/rt:routing-protocols:
3. augment /rt:routing/rt:routing-protocols

Thanks,
Anish

---

From: Xufeng Liu <[email-masked]>
Date: Wed, 16 Dec 2015 12:45:31 +0000

Attached please find the slides.

Thanks,

- Xufeng

From: Yang-multicast [mailto:[email-masked]] On Behalf Of Anish Peter
Sent: Tuesday, December 15, 2015 1:28 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Yang-multicast] IGMP Yang

Hi Folks,
 I have created tables in the wiki for igmp config. Please populate the table.
 One of the point for discussion is igmp/mld being vrf aware. GMP (IGMP/MLD) being a per interface protocol an implementation of the same need not be vrf aware. But few of the configs could be global. This is the background for the first gmp table to indicate if your preference is to have igmp yang tree to be vrf based or not.
 Hence the possible points for augmentation consideration are
1. augment /if:interfaces/if:interface/ip:ipv4:
2. augment /rt:routing/rt:routing-instance/rt:routing-protocols:
3. augment /rt:routing/rt:routing-protocols

Thanks,
Anish