Subject: [Yang-multicast] Discussion Slides

From: Xufeng Liu <[email-masked]>
Date: Wed, 8 Jun 2016 03:35:14 +0000

In the last week's meeting, Bob, Anish, Pete, and I briefly discussed MSDP model and MVPN model. Because of the lack of Webex host privilege, we could not share screen so we did not go for too much details, but we did have a few comments to MVPN to share with you in the next meeting.

Thanks for the information put onto the Wiki page. I have gathered the information and got the write-up for the yang file. Attached please find the summary. The yang file and corresponding tree view have been checked into our Github. The data from the Wiki page has been used to create the model file, except the following two items:

-        connect-source seems to be a per-peer attribute, so it is moved into the peer list entry.

-        Based on the Cisco manual, the policy is an optional parameter for default-peer, so it is added as an optional feature.

Please review and comment.

Thanks,

- Xufeng

---

From: Xufeng Liu <[email-masked]>
Date: Wed, 8 Jun 2016 03:40:18 +0000

Resend with the correct slides.

Thanks,

- Xufeng

From: Xufeng Liu
Sent: Tuesday, June 7, 2016 11:35 PM
To: [email-masked]
Subject: Discussion Slides

Thanks,

- Xufeng

---

From: Xufeng Liu <[email-masked]>
Date: Wed, 8 Jun 2016 19:39:39 +0000

Meeting notes (2016-06-08):
Attendees: Anish, Bob, Xufeng, Mehash

MSDP:

-        Make connect-source both global and per-peer (comment from Mehash)

-        Add if-feature to rpc msdp-clear-sa-cache (comment from Anish)

-        Anish will further check the mesh group and provide examples if needed.

MVPN:

-        Bob to prepare the summary of comments.

-        Will continue the discussions in the next meeting, since Yisong could not attend the meeting because of the holiday in China.

Logistics:

-        Today is a holiday in China so that some could not attend the meeting.

-        Bob and Mehash will not be able to attend next week, so we agreed to cancel next week's meeting and resume in two weeks.

Thanks,

- Xufeng
P.S. Slides have been uploaded to the Wiki page; model files have been updated and checked in to GitHub.

From: Xufeng Liu

Thanks,

- Xufeng

---

From: Xufeng Liu <[email-masked]>
Date: Wed, 15 Jun 2016 12:38:35 +0000

Please be reminded that we do not have the meeting today, and we will meet next Wednesday, Jun 22.

Thanks,

- Xufeng

From: Xufeng Liu
Sent: Wednesday, June 8, 2016 3:40 PM
To: [email-masked]
Subject: RE: Discussion Slides

MSDP:

MVPN:

Logistics:

Thanks,

- Xufeng

From: Xufeng Liu
Sent: Tuesday, June 7, 2016 11:35 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Discussion Slides

Thanks,

- Xufeng

---

From: Robert Kebler <[email-masked]>
Date: Tue, 21 Jun 2016 15:05:26 +0000

Hi,
Here are my comments:

mvpn-tunnel-interfaces

      These are specific to a particular implementation.  It allows the necessary encapsulation and decap, but is very specific to the implementation.  I don't think this should be part of the standard.

Some terminology.  I think the terminology that is generally used in the specs:

share mdt -> default MDT

switch-mdt -> data mdt

I would prefer to use the above terminology for Rosen MVPNs.

We want to allow the ability to configure both a Rosen MDT and also a BGP-MPLS PMSI at the same time.  I'm not saying anything in here would forbid that, just want to make sure that we keep that in mind.

How to configure wildcard S-PMSIs?  That is, a (*,G), (S,*), or (*,*) s-pmsi?

rw mvpn-ipmsi-tunnel* [tunnel-mode]

         +--rw tunnel-mode         enumeration

         +--rw te-p2mp-template?   String

The te-p2mp-template is only useful if the tunnel-mode is rsvp p2mp.  For other tunnel modes, they may have their own attributes.  For example, IR tunnels would have own attributes, and pim tunnels would have own attributes.  Does it make sense to have this flat structure?  Or should the specific tunnel mode attribute be under the tunnel mode that it it used for?

Out of curiosity, what is the hold-down time?  We have something similar but just want to make sure it is describing the same.

Thanks,
Bob

From: Yang-multicast [mailto:[email-masked]] On Behalf Of Xufeng Liu
Sent: Wednesday, June 08, 2016 3:40 PM
To: [email-masked]
Subject: Re: [Yang-multicast] Discussion Slides

MSDP:

MVPN:

Logistics:

Thanks,

- Xufeng

From: Xufeng Liu

Thanks,

- Xufeng

---

From: Xufeng Liu <[email-masked]>
Date: Wed, 22 Jun 2016 00:34:51 +0000

Meeting reminder.

From: Xufeng Liu
Sent: Wednesday, June 15, 2016 8:39 AM
To: [email-masked]
Subject: RE: Discussion Slides

Thanks,

- Xufeng

From: Xufeng Liu

MSDP:

MVPN:

Logistics:

Thanks,

- Xufeng

From: Xufeng Liu

Thanks,

- Xufeng