Subject: [Yang-multicast] Hi everyone! I have submitted draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to involve it and become one of the authors? Thanks a lot !

From: Hongji Zhao <[email-masked]>
Date: Mon, 27 Feb 2017 06:40:25 +0000

Hi everyone!

I have submitted draft-zhao-pim-igmp-mld-snooping-yang-00.  This document defines a YANG data model that can be used to configure and manage Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) Snooping devices.

I would like to get more people from different vendors to involve with the draft to make the draft to be adopted more easily.

If you have any questions and comments about the draft, please send them to me. I would like to include you as one of authors.

Thanks a lot ! :)

Name:                  draft-zhao-pim-igmp-mld-snooping-yang
Revision:              00
Title:                      A Yang Data Model for IGMP and MLD Snooping
Document date:               2017-02-06
Group:                  Individual Submission
Pages:                   27
URL:            https://www.ietf.org/internet-drafts/draft-zhao-pim-igmp-mld-snooping-yang-00.txt
Status:         https://datatracker.ietf.org/doc/draft-zhao-pim-igmp-mld-snooping-yang/
Htmlized:       https://tools.ietf.org/html/draft-zhao-pim-igmp-mld-snooping-yang-00

Abstract:
   This document defines a YANG data model that can be used to configure and manage Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) Snooping devices.

BR/Hongji
赵宏吉

From: Mahesh Sivakumar (masivaku) [mailto:[email-masked]]
Sent: Tuesday, February 21, 2017 2:38 AM
To: Hongji Zhao <[email-masked]>
Subject: Re: Hi Mahesh! I have submitted draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to involve it and become one of the authors? Thanks a lot !

Sure. Happy to help.
We have a design team with vendors from different companies working on the different multicast design drafts.
I would suggest you reach out to that group as well.

Thanks
Mahesh

From: Hongji Zhao <[email-masked]<mailto:[email-masked]>>
Date: Sunday, February 19, 2017 at 5:54 PM
To: Mahesh S <[email-masked]<mailto:[email-masked]>>
Subject: Hi Mahesh! I have submitted draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to involve it and become one of the authors? Thanks a lot !

Hi Mahesh,

Your draft-ietf-pim-igmp-mld-yang-01 is about igmp and mld,  the scope of model mentions that it does not cover other IGMP and MLD related protocols such as IGMP/MLD Snooping[RFC4541].  So I think that maybe I can contribute on igmp and mld snooping.

And draft-zhao-pim-igmp-mld-snooping-yang-00 is about IGMP/MLD Snooping.

Could you please involve this new draft and provide comments!  In that case this new draft can be improved and more perfect.

I would like to get more people from different vendors to involve with the draft to make the draft to be adopted more easily.

If you have any questions about the draft, please send them to me. I would like to include you as one of authors.

Thanks a lot ! :)

Name:                  draft-zhao-pim-igmp-mld-snooping-yang
Revision:              00
Title:                      A Yang Data Model for IGMP and MLD Snooping
Document date:               2017-02-06
Group:                  Individual Submission
Pages:                   27
URL:            https://www.ietf.org/internet-drafts/draft-zhao-pim-igmp-mld-snooping-yang-00.txt
Status:         https://datatracker.ietf.org/doc/draft-zhao-pim-igmp-mld-snooping-yang/
Htmlized:       https://tools.ietf.org/html/draft-zhao-pim-igmp-mld-snooping-yang-00

Abstract:
   This document defines a YANG data model that can be used to configure and manage Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) Snooping devices.

---

From: Marta Seda <[email-masked]>
Date: Thu, 2 Mar 2017 00:12:37 +0000

Hello Zhao,
I’m trying to understand whether this email is a response to what I sent earlier this morning or not (and if IETF is attempting to solve access space).  Let me put into context what I previously sent:

  *   BBF developed in a collaborative environment layer 2 multicast yang.   The multicast model has been reviewed by 5+ companies (William, keep me honest).

If you want to solve access space yang models, you must satisfy the myriad of BBF TRs and ITU standards.  When I refer to access space, I am referring to OLT, ONTs, DPUs, etc (layer 2 devices).  The following functionality is commonly needed to be supported on these devices:

  *   Igmp proxies, transparent snoop and snoop with proxy reporting
  *   Open access (with igmpv2, igmpv3, mld2)
  *   Wholesale features (unregistered join)
  *   Cac (BW and/or channel enforcement)
  *   Support of whitelist (e.g., for operators that don’t use middleware)
  *   Support of packages

With that in mind, let me comment on the tree:

module: ietf-igmp-mld-snooping

      +--rw configuration

      |  +--rw igmp-snooping

      |  |  +--rw global

      |  |  |  +--rw enable?   boolean {global-admin-enable}?  (I don’t follow the logic with global enable – you enable multicast on a per vlan basis and those vlans may have different open access providers attached to them – what are you globally enabling?  What device type do you have in mind for this?)

      |  |  +--rw vlans

      |  |     +--rw vlan* [vlan-id]

      |  |        +--rw vlan-id                       uint16

      |  |        +--rw enable?                       boolean {admin-enable}? (assume it enables igmp/mld per vlan)

      |  |        +--rw forwarding-mode?              Enumeration

      |  |        +--rw explicit-tracking?            String  (with igmpv3, you are expected to send up all unsolicited reports so that the upstream multicast router can do explicit tracking – it is not an access setting.  I normally don’t see explicit tracking as an attribute but instead enabling of snoop proxy (or suppression of reports).  A usecase would be helpful to understand what you have in mind.)

      |  |        +--rw send-query?                   Boolean (RFC4541 has requirements about sending general queries, etc to more rapidly converge however that solution is missing other usecases to speed things up when you are operating as a snoop proxy including sending startup queries and group requests to verify that a channel is still up.  It is a bit too “loose” in my view and RFC 5519 did not address snoopers adequately (probably explains why there are so many variations out there on how to solve quickly converging the network).

      |  |        +--rw mrouter-learning?             Boolean (not applicable to access devices)

      |  |        +--rw mrouter-aging-time?           uint16 (not applicable to access devices)

      |  |        +--rw fast-leave?                   empty {fast-leave}?

      |  |        +--rw last-member-query-interval?   uint16

      |  |        +--rw query-interval?               uint16

      |  |        +--rw max-response-time?            uint16

      |  |        +--rw require-router-alert?         boolean {require-router-alert}? (igmpv1? Who deploys that?)

      |  |        +--rw robustness-variable?          uint8

      |  |        +--rw source-policy?                string {source-policy}? (this is valid only with SSM; other means are needed for open access)

      |  |        +--rw verify-source-subnet?         empty {verify-source-subnet}? (this is valid only with SSM; other means are needed for open access)

      |  |        +--rw version?                      uint8 (this is defined as an integer list so how do you distinguish mld2 from igmpv2?)

      |  |        +--rw ssm-map* [source-addr group-addr-prefix] {ssm-map}?

      |  |        |  +--rw source-addr          ssm-map-ipv4-addr-type

      |  |        |  +--rw group-addr-prefix    inet:ipv4-prefix

      |  |        +--rw static-mrouter-interface*     if:interface-ref

      |  |        +--rw static-l2-multicast-group* [group]

      |  |           +--rw group        inet:ipv4-address

      |  |           +--rw interface?   if:interface-ref  (why are you pointing to a reference – are you trying to limit the static group to a specific port as opposed to the service provider)

Missing in this model to satisfy access l2 space:

  *   Igmp proxies (probably in another yang module)
  *   I couldn’t tell how you configure transparent snoop and snoop with proxy reporting
  *   Open access (with igmpv2, igmpv3 ASM)
  *   Wholesale features (unregistered join)
  *   Cac (BW and/or channel enforcement)
  *   Support of whitelist (e.g., for operators that don’t use middleware)
  *   Support of packages

Can you explain what product space are you attempting to address?

Regards,

Marta

From: Yang-multicast [mailto:[email-masked]] On Behalf Of Hongji Zhao
Sent: Sunday, February 26, 2017 10:40 PM
To: [email-masked]
Cc: Mahesh Sivakumar (masivaku) <[email-masked]>
Subject: [Yang-multicast] Hi everyone! I have submitted draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to involve it and become one of the authors? Thanks a lot !

Hi everyone!

Thanks a lot ! :)

Abstract:

BR/Hongji
赵宏吉

From: Mahesh Sivakumar (masivaku) [mailto:[email-masked]]
Sent: Tuesday, February 21, 2017 2:38 AM
To: Hongji Zhao <[email-masked]<mailto:[email-masked]>>
Subject: Re: Hi Mahesh! I have submitted draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to involve it and become one of the authors? Thanks a lot !

Sure. Happy to help.

Thanks
Mahesh

Hi Mahesh,

Thanks a lot ! :)

Abstract:

---

From: Marta Seda <[email-masked]>
Date: Thu, 2 Mar 2017 00:30:47 +0000

If there is interest, I can walk this group through the BBF yang model (if you have teleconferences).  The current state of BBF multicast yang is draft (it is in BBF bitbucket in the development branch (yang modules are put in the development branch after review from BBF (they can be further developed/bugs addressed)).

Back in November, there we discussions on including the multicast yang in BBF WT-383 straw ballot but then decided to defer it (and pick it up after the BBF face to face meeting in March).  There are a straw ballot comments needing to be resolved related to multicast.

From: Marta Seda
Sent: Wednesday, March 1, 2017 4:13 PM
To: 'Hongji Zhao' <[email-masked]>; [email-masked]
Cc: Mahesh Sivakumar (masivaku) <[email-masked]>; 'William Lupton' <[email-masked]>
Subject: RE: [Yang-multicast] Hi everyone! I have submitted draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to involve it and become one of the authors? Thanks a lot !

Hello Zhao,

      +--rw configuration

      |  +--rw igmp-snooping

      |  |  +--rw global

      |  |  +--rw vlans

      |  |        +--rw vlan-id                       uint16

Regards,

Marta

Hi everyone!

Thanks a lot ! :)

Abstract:

BR/Hongji
赵宏吉

Sure. Happy to help.

Thanks
Mahesh

Hi Mahesh,

Thanks a lot ! :)

Abstract:

---

From: Hongji Zhao <[email-masked]>
Date: Thu, 2 Mar 2017 07:48:02 +0000

Hi Marta,

Thanks a lot for your reply! !

The draft-zhao-pim-igmp-mld-snooping-yang-00 is addressed to routers and switches (eg, Huawei NE40E, Cisco 7600 series routers, etc), I didn’t refer to OLT, ONTs, DPUs.
It is only focused on IGMP and MLD snooping (RFC4541) now. I plan to add Igmp proxy later but not have finished.

Where can I get the BBF WT-383? Or the BBF multicast model reviewed by 5+ companies ? I can have a research.
I also have some questions as below

-          Igmp proxies, transparent snoop and snoop with proxy reporting
-          Open access (with igmpv2, igmpv3, mld2)----------------It is referred on draft-ietf-pim-igmp-mld-yang-02, it is not in the igmp snooping scope.
-          Wholesale features (unregistered join) -------------- Could you please give a further explain?
-          Cac (BW and/or channel enforcement) --------------what is Cac ?
-          Support of whitelist (e.g., for operators that don’t use middleware)---------------Does the whitelist controls the packet forwarding? When matches the whitelist, the packet can be forward?
-          Support of packages -------------------What is packages ?

      +--rw configuration

      |  +--rw igmp-snooping

      |  |  +--rw global

      |  |  |  +--rw enable?   boolean {global-admin-enable}?  (I don’t follow the logic with global enable – you enable multicast on a per vlan basis and those vlans may have different open access providers attached to them – what are you globally enabling?  What device type do you have in mind for this?)  -------By default in the global view igmp snooping is disabled for saving router resources. All the routers about Cisco and Huawei have similar configuration.

      |  |  +--rw vlans

      |  |        +--rw vlan-id                       uint16

      |  |        +--rw enable?                       boolean {admin-enable}? (assume it enables igmp/mld per vlan)------------yes

      |  |        +--rw explicit-tracking?            String  (with igmpv3, you are expected to send up all unsolicited reports so that the upstream multicast router can do explicit tracking – it is not an access setting.  I normally don’t see explicit tracking as an attribute but instead enabling of snoop proxy (or suppression of reports).  A usecase would be helpful to understand what you have in mind.) ----When explicit-tracking is enabled, the user’s IP address who is watching (S,G) channel will be recorded. When the last user leaves, router needn’t to query whether there is listener. It can delete multicast forwarding table directly. Maybe Boolean is better, not string.

      |  |        +--rw send-query?                   Boolean (RFC4541 has requirements about sending general queries, etc to more rapidly converge however that solution is missing other usecases to speed things up when you are operating as a snoop proxy including sending startup queries and group requests to verify that a channel is still up.  It is a bit too “loose” in my view and RFC 5519 did not address snoopers adequately (probably explains why there are so many variations out there on how to solve quickly converging the network).-------What is your suggestion about this item? Delete it? Or add some attributes?

      |  |        +--rw mrouter-learning?             Boolean (not applicable to access devices)-----------------After enable mrouter-learning manually, switch can learn router port dynamically. The router port which connects to multicast router can also be assign statically.
      |  |        +--rw mrouter-aging-time?           uint16 (not applicable to access devices)---------------ok

      |  |        +--rw require-router-alert?         boolean {require-router-alert}? (igmpv1? Who deploys that?) -----------igmp v2, v3

      |  |        +--rw source-policy?                string {source-policy}? (this is valid only with SSM; other means are needed for open access)--------Are you suggesting to move it under ssm-map ?

      |  |        +--rw verify-source-subnet?         empty {verify-source-subnet}? (this is valid only with SSM; other means are needed for open access)--------Are you suggesting to move it under ssm-map ?

      |  |        +--rw version?                      uint8 (this is defined as an integer list so how do you distinguish mld2 from igmpv2?) ----The leaf is under the container igmp-snooping or mld-snooping, so I can distinguish them.

      |  |           +--rw interface?   if:interface-ref  (why are you pointing to a reference – are you trying to limit the static group to a specific port as opposed to the service provider)
----I just use if:interface-ref defined in ietf-interfaces@2014-05-08

…
typedef interface-ref {
    type leafref {
      path "/if:interfaces/if:interface/if:name";
    }
    description
      "This type is used by data models that need to reference
       configured interfaces.";
  }

BR/Hongji
赵宏吉

From: Marta Seda [mailto:[email-masked]]
Sent: Thursday, March 02, 2017 8:31 AM
To: Hongji Zhao <[email-masked]>; [email-masked]
Cc: Mahesh Sivakumar (masivaku) <[email-masked]>; 'William Lupton' <[email-masked]>
Subject: RE: [Yang-multicast] Hi everyone! I have submitted draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to involve it and become one of the authors? Thanks a lot !

From: Marta Seda
Sent: Wednesday, March 1, 2017 4:13 PM
To: 'Hongji Zhao' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Mahesh Sivakumar (masivaku) <[email-masked]<mailto:[email-masked]>>; 'William Lupton' <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Yang-multicast] Hi everyone! I have submitted draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to involve it and become one of the authors? Thanks a lot !

Hello Zhao,
I’m trying to understand whether this email is a response to what I sent earlier this morning or not (and if IETF is attempting to solve access space).  Let me put into context what I previously sent:
-          BBF developed in a collaborative environment layer 2 multicast yang.   The multicast model has been reviewed by 5+ companies (William, keep me honest).

If you want to solve access space yang models, you must satisfy the myriad of BBF TRs and ITU standards.  When I refer to access space, I am referring to OLT, ONTs, DPUs, etc (layer 2 devices).  The following functionality is commonly needed to be supported on these devices:
-          Igmp proxies, transparent snoop and snoop with proxy reporting
-          Open access (with igmpv2, igmpv3, mld2)
-          Wholesale features (unregistered join)
-          Cac (BW and/or channel enforcement)
-          Support of whitelist (e.g., for operators that don’t use middleware)
-          Support of packages

      +--rw configuration

      |  +--rw igmp-snooping

      |  |  +--rw global

      |  |  +--rw vlans

      |  |        +--rw vlan-id                       uint16

Missing in this model to satisfy access l2 space:
-          Igmp proxies (probably in another yang module)
-          I couldn’t tell how you configure transparent snoop and snoop with proxy reporting
-          Open access (with igmpv2, igmpv3 ASM)
-          Wholesale features (unregistered join)
-          Cac (BW and/or channel enforcement)
-          Support of whitelist (e.g., for operators that don’t use middleware)
-          Support of packages

Regards,

Marta

From: Yang-multicast [mailto:[email-masked]] On Behalf Of Hongji Zhao
Sent: Sunday, February 26, 2017 10:40 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Mahesh Sivakumar (masivaku) <[email-masked]<mailto:[email-masked]>>
Subject: [Yang-multicast] Hi everyone! I have submitted draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to involve it and become one of the authors? Thanks a lot !

Hi everyone!

Thanks a lot ! :)

Abstract:

BR/Hongji
赵宏吉

Sure. Happy to help.

Thanks
Mahesh

Hi Mahesh,

Thanks a lot ! :)

Abstract:

---

From: Hongji Zhao <[email-masked]>
Date: Tue, 7 Mar 2017 07:24:29 +0000

Hi Marta,

Will you attend this IETF meeting? My friend Chin Chen will go. And he can communicate with you then.  ☺

BR/Hongji
赵宏吉

From: Hongji Zhao
Sent: Thursday, March 02, 2017 3:48 PM
To: 'Marta Seda' <[email-masked]>; [email-masked]
Cc: Mahesh Sivakumar (masivaku) <[email-masked]>; 'William Lupton' <[email-masked]>
Subject: RE: [Yang-multicast] Hi everyone! I have submitted draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to involve it and become one of the authors? Thanks a lot !

Hi Marta,

      +--rw configuration

      |  +--rw igmp-snooping

      |  |  +--rw global

      |  |  +--rw vlans

      |  |        +--rw vlan-id                       uint16

…
typedef interface-ref {
    type leafref {

BR/Hongji
赵宏吉

To: Hongji Zhao <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

From: Marta Seda

Hello Zhao,

      +--rw configuration

      |  +--rw igmp-snooping

      |  |  +--rw global

      |  |  +--rw vlans

      |  |        +--rw vlan-id                       uint16

Regards,

Marta

Hi everyone!

Thanks a lot ! :)

Abstract:

BR/Hongji
赵宏吉

Sure. Happy to help.

Thanks
Mahesh

Hi Mahesh,

Thanks a lot ! :)

Abstract:

---

From: Benoit Claise <[email-masked]>
Date: Wed, 8 Mar 2017 12:21:57 +0100

Hi,

There are two drafts:
     draft-zhao-pim-igmp-mld-snooping-yang
     draft-zhao-igmp-mld-snooping-yang
Both wants to extract [email-masked].
This creates a collision.

Which draft should replaced the other one? I could flag this in the 
datatracker?

Regards, Benoit
>
> Hi everyone!
>
> I have submitted draft-zhao-pim-igmp-mld-snooping-yang-00.  This 
> document defines a YANG data model that can be used to configure and 
> manage Internet Group Management Protocol (IGMP) and Multicast 
> Listener Discovery (MLD) Snooping devices.
>
> I would like to get more people from different vendors to involve with 
> the draft to make the draft to be adopted more easily.
>
> If you have any questions and comments about the draft, please send 
> them to me. I would like to include you as one of authors.
>
> Thanks a lot ! :)
>
> URL: 
> https://www.ietf.org/internet-drafts/draft-zhao-pim-igmp-mld-snooping-yang-00.txt
>
> Status: 
> https://datatracker.ietf.org/doc/draft-zhao-pim-igmp-mld-snooping-yang/
>
> Htmlized: 
> https://tools.ietf.org/html/draft-zhao-pim-igmp-mld-snooping-yang-00
>
> Abstract:
>
>    This document defines a YANG data model that can be used to 
> configure and manage Internet Group Management Protocol (IGMP) and 
> Multicast Listener Discovery (MLD) Snooping devices.
>
> BR/Hongji
>
> 赵宏吉
>
> *From:* Mahesh Sivakumar (masivaku) [mailto:[email-masked]]
> *Sent:* Tuesday, February 21, 2017 2:38 AM
> *To:* Hongji Zhao <[email-masked]>
> *Subject:* Re: Hi Mahesh! I have submitted 
> draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to involve it 
> and become one of the authors? Thanks a lot !
>
> Sure. Happy to help.
>
> *From: *Hongji Zhao <[email-masked] 
> <mailto:[email-masked]>>
> *Date: *Sunday, February 19, 2017 at 5:54 PM
> *To: *Mahesh S <[email-masked] <mailto:[email-masked]>>
> *Subject: *Hi Mahesh! I have submitted 
> draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to involve it 
> and become one of the authors? Thanks a lot !
>
> Hi Mahesh,
>
> Your draft-ietf-pim-igmp-mld-yang-01 is about igmp and mld, the scope 
> of model mentions that it does not cover other IGMP and MLD related 
> protocols such as IGMP/MLD Snooping[RFC4541].  So I think that maybe I 
> can contribute on igmp and mld snooping.
>
> Could you please involve this new draft and provide comments!  In that 
> case this new draft can be improved and more perfect.
>
> I would like to get more people from different vendors to involve with 
> the draft to make the draft to be adopted more easily.
>
> If you have any questions about the draft, please send them to me. I 
> would like to include you as one of authors.
>
> Thanks a lot ! :)
>
> URL: 
> https://www.ietf.org/internet-drafts/draft-zhao-pim-igmp-mld-snooping-yang-00.txt
>
> Status: 
> https://datatracker.ietf.org/doc/draft-zhao-pim-igmp-mld-snooping-yang/
>
> Htmlized: 
> https://tools.ietf.org/html/draft-zhao-pim-igmp-mld-snooping-yang-00
>
> Abstract:
>
>    This document defines a YANG data model that can be used to 
> configure and manage Internet Group Management Protocol (IGMP) and 
> Multicast Listener Discovery (MLD) Snooping devices.
>
>
>
> _______________________________________________
> Yang-multicast mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-multicast

---

From: Hongji Zhao <[email-masked]>
Date: Thu, 9 Mar 2017 01:43:46 +0000

Hi Benoit,

draft-zhao-pim-igmp-mld-snooping-yang-00 should be kept.

draft-zhao-igmp-mld-snooping-yang has the wrong name. I would like to delete it, but I don’t know how to do.

Thanks a lot !

BR/Hongji
赵宏吉

From: Benoit Claise [mailto:[email-masked]]
Sent: Wednesday, March 08, 2017 7:22 PM
To: Hongji Zhao <[email-masked]>; [email-masked]
Cc: Mahesh Sivakumar (masivaku) <[email-masked]>
Subject: Re: [Yang-multicast] Hi everyone! I have submitted draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to involve it and become one of the authors? Thanks a lot !

Hi,

There are two drafts:
    draft-zhao-pim-igmp-mld-snooping-yang
    draft-zhao-igmp-mld-snooping-yang
Both wants to extract [email-masked]<mailto:[email-masked]>.
This creates a collision.

Which draft should replaced the other one? I could flag this in the datatracker?

Regards, Benoit
Hi everyone!

Thanks a lot ! :)

Abstract:

BR/Hongji
赵宏吉

From: Mahesh Sivakumar (masivaku) [mailto:[email-masked]]
Sent: Tuesday, February 21, 2017 2:38 AM
To: Hongji Zhao <[email-masked]><mailto:[email-masked]>
Subject: Re: Hi Mahesh! I have submitted draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to involve it and become one of the authors? Thanks a lot !

Sure. Happy to help.

Thanks
Mahesh

Hi Mahesh,

Thanks a lot ! :)

Abstract:

[email-masked]<mailto:[email-masked]>

---

From: Hongji Zhao <[email-masked]>
Date: Thu, 9 Mar 2017 02:01:30 +0000

Hi Marta,

My colleague Chin Chen will attend IETF Chicago session. If you are there and available, prefer have a f2f meeting.

Thanks a lot ! ☺

BR/Hongji
赵宏吉

From: Hongji Zhao

Hi Marta,

      +--rw configuration

      |  +--rw igmp-snooping

      |  |  +--rw global

      |  |  +--rw vlans

      |  |        +--rw vlan-id                       uint16

…
typedef interface-ref {
    type leafref {

BR/Hongji
赵宏吉

From: Marta Seda

Hello Zhao,

      +--rw configuration

      |  +--rw igmp-snooping

      |  |  +--rw global

      |  |  +--rw vlans

      |  |        +--rw vlan-id                       uint16

Regards,

Marta

Hi everyone!

Thanks a lot ! :)

Abstract:

BR/Hongji
赵宏吉

Sure. Happy to help.

Thanks
Mahesh

Hi Mahesh,

Thanks a lot ! :)

Abstract:

---

From: Benoit Claise <[email-masked]>
Date: Thu, 9 Mar 2017 09:00:34 +0100

Solved:

Regards, Benoit
> *From:*Benoit Claise [mailto:[email-masked]]
> *Sent:* Wednesday, March 08, 2017 7:22 PM
> *To:* Hongji Zhao <[email-masked]>; [email-masked]
> *Cc:* Mahesh Sivakumar (masivaku) <[email-masked]>
> *Subject:* Re: [Yang-multicast] Hi everyone! I have submitted 
> Both wants to extract [email-masked] 
> <mailto:[email-masked]>.
>     document defines a YANG data model that can be used to configure
>     and manage Internet Group Management Protocol (IGMP) and Multicast
>     I would like to get more people from different vendors to involve
>     with the draft to make the draft to be adopted more easily.
>
>     If you have any questions and comments about the draft, please
>     send them to me. I would like to include you as one of authors.
>
>     Thanks a lot ! :)
>
>     <mailto:[email-masked]>
>     draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to
>     involve it and become one of the authors? Thanks a lot !
>
>     Sure. Happy to help.
>
>     We have a design team with vendors from different companies
>     working on the different multicast design drafts.
>
>     draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to
>     involve it and become one of the authors? Thanks a lot !
>
>     Hi Mahesh,
>
>     Your draft-ietf-pim-igmp-mld-yang-01 is about igmp and mld,  the
>     scope of model mentions that it does not cover other IGMP and MLD
>     related protocols such as IGMP/MLD Snooping[RFC4541].  So I think
>     that maybe I can contribute on igmp and mld snooping.
>
>     Could you please involve this new draft and provide comments!  In
>     that case this new draft can be improved and more perfect.
>
>     I would like to get more people from different vendors to involve
>     with the draft to make the draft to be adopted more easily.
>
>     If you have any questions about the draft, please send them to me.
>     I would like to include you as one of authors.
>
>     Thanks a lot ! :)
>
>     [email-masked] <mailto:[email-masked]>
>

---

From: Hongji Zhao <[email-masked]>
Date: Thu, 9 Mar 2017 09:28:49 +0000

Hi Benoit,

Thanks a lot !

Do you have any comments about this draft?

BR/Hongji
赵宏吉

Sent: Thursday, March 09, 2017 4:01 PM

Solved:

Regards, Benoit
Hi Benoit,

Thanks a lot !

BR/Hongji
赵宏吉

From: Benoit Claise [mailto:[email-masked]]
Sent: Wednesday, March 08, 2017 7:22 PM
To: Hongji Zhao <[email-masked]><mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Mahesh Sivakumar (masivaku) <[email-masked]><mailto:[email-masked]>
Subject: Re: [Yang-multicast] Hi everyone! I have submitted draft-zhao-pim-igmp-mld-snooping-yang-00. Would you like to involve it and become one of the authors? Thanks a lot !

Hi,

There are two drafts:

Regards, Benoit
Hi everyone!

Thanks a lot ! :)

Abstract:

BR/Hongji
赵宏吉

Sure. Happy to help.

Thanks
Mahesh

Hi Mahesh,

Thanks a lot ! :)

Abstract: