Subject: Re: Why minimum packet size "m"?

From: JJ Krawczyk <[email-masked]>
Date: Mon, 17 Jul 2000 11:48:08 -0400

It has to do with calculating how much bandwidth you need to reserve for 
the link-level framing for the flow.  For example, you could have two flows 
whose IP data flows at a rate "r" with one sending the data in 30 bytes 
frames while the other sends the data in 1000 byte frames.  If you are 
sending both flows out an Ethernet link, the former flow will need more 
bandwidth given that you have to transmit a header after every 30 bytes 
(not to mention the minimum packet size issue).

-jj

At 07:43 AM 7/17/2000 -0700, Shahram Davari wrote:
>Hi All,
>
>Could some one please tell me what is the logic behind using minimum packet
>size "m" during policing of GS and CLS packets?
>
>Is it trying to solve some implementation issues, such as granularity of
>token bucket or the minimum allocated buffer size in the routers? or there
>is any theoretical issue that it is trying to solve?
>
>I appreciate your response.
>
>Thanks,
>
>Shahram Davari
>Systems Engineer
>Product Research
>PMC-Sierra, Inc. (Ottawa)
>555 Legget drive,
>Suit 834, Tower B,
>Ottawa, ON K2K 2X3, Canada
>Phone: +1 (613) 271-4018
>Fax  : +1 (613) 271-7007
>

---

From: Anoop Ghanwani <[email-masked]>
Date: Mon, 17 Jul 2000 10:05:54 -0700

One reason to have a packet use up at least "m" credits 
would be to ensure that your forwarding engine can keep
up with the packet rate.  If a minimum packet size is not
used, a router could get bogged down by seeing too many
small packets from a session.  For example, if a router
can do wire-speed forwarding/policing with 256-byte
packets or larger, then a good size for "m" would be 256.
Setting "m" smaller would mean that there are scenarios
where the router won't be able to provide the contracted
guarantees.

There may be other reasons that I'm not aware of.

-Anoop 
--
Anoop Ghanwani,  CoSine Communications, Redwood City, CA
Ph: 650-628-4225  Fax: 650-637-4752  [email-masked] 

> -----Original Message-----
> From: Shahram Davari [mailto:[email-masked]]
> Sent: Monday, July 17, 2000 7:44 AM
> To: [email-masked]'
> Subject: Why minimum packet size "m"?
> 
> 
> Hi All,
>