Subject: guaranteed service delay formula

From: Bob Braden <[email-masked]>
Date: Wed, 31 May 2000 16:26:27 GMT

----- Begin Included Message -----

>From [email-masked] Wed May 31 03:28:56 2000
Date:   Wed, 31 May 2000 12:20:07 +0200
From: Simon Schneider <[email-masked]>
X-Mailer: Mozilla 4.7 [de] (WinNT; I)
X-Accept-Language: de
MIME-Version: 1.0
To: [email-masked]
Subject: guaranteed service delay formula
Content-Transfer-Encoding: 7bit
Sender: [email-masked]
Precedence: bulk
X-Lines: 13

Hi,
I'm currently working with RFC2212 - Guaranteed Service. I'm especially
interested in the formula for the end-to-end delay:

[(b-M)/R*(p-R)/(p-r)]+(M+Ctot)/R+Dtot .

Unfortunately, there's no deeper explanation of this formula in the RFC.
Can anyone explain to me how this formula is derived from the parameters
? What is the intuitive meaning of it ?

Thank you,
cheers, Simon

----- End Included Message -----

---

From: Roch Guerin <[email-masked]>
Date: Thu, 01 Jun 2000 07:34:56 -0400

> ? What is the intuitive meaning of it ?

General background goes back to the PGPS papers by
Parekh and Gallager (see ref [7]).  A generalization
of the approach can be found in a paper on Latency
Rate Servers by Stiliadis and Varma (Aug. 99 issue of
IEEE/ACM Trans. Networking, I think), and you can find
some additional info in a Sigcomm'96 paper by
Georgiadis et al. that can be found at
http://www.acm.org/sigs/sigcomm/sigcomm96/papers/georgiadis.html

Basic intuition is that if your traffic is characterized
by a dual token bucket with peak rate p, max pkt size of
M (the burst size for the peak rate bucket), token rate r,
and burst size of b, and you are guaranteeing it a clearing
rate at each node (scheduler), then your end-to-end delay
consists of two terms:  the time it takes to clear the 
initial burst, and then a packetization and scheduler specific
"error" terms at each node.

the term (b-M)/R*(p-R)/(p-r) + M/R corresponds to the first
component, and the Ctot/R+Dtot to the second component.
Read up on the above refs for more detailed explanations.

Roch