Subject: Why minimum packet size "m"?

From: Shahram Davari <[email-masked]>
Date: Mon, 17 Jul 2000 07:43:56 -0700

Hi All,

Could some one please tell me what is the logic behind using minimum packet
size "m" during policing of GS and CLS packets? 

Is it trying to solve some implementation issues, such as granularity of
token bucket or the minimum allocated buffer size in the routers? or there
is any theoretical issue that it is trying to solve?

I appreciate your response.

Thanks,

Shahram Davari
Systems Engineer
Product Research
PMC-Sierra, Inc. (Ottawa) 
555 Legget drive,
Suit 834, Tower B,
Ottawa, ON K2K 2X3, Canada
Phone: +1 (613) 271-4018
Fax  : +1 (613) 271-7007

---

From: Markus Jork <[email-masked]>
Date: Mon, 17 Jul 2000 11:46:08 -0400

> is any theoretical issue that it is trying to solve?

The amount of link layer overhead depends on the IP packet sizes used.
Depending on the link layer technology, a 1000 kbytes/s IP packet stream
consisting of 100 bytes packets will typically need more link layer bandwidth
than a 1000 kbytes/s stream of 500 byte IP packets.
Knowing the minimum packet size helps admission control because it
doesn't need to make worst case assumptions about the actual link layer
bandwidth used up by a reservation.

Markus

---

From: Roch Guerin <[email-masked]>
Date: Mon, 17 Jul 2000 12:31:08 -0400

Shahram,

The reason I'm aware of (there may be others) is that this 
limit is there to allow you to incorporate a per packet
cost that is not necessarily related to its size.  Basically,
this reflects the fact that bandwidth may not be the only
resource that can be consumed.  For example, each packet may
require a certain number of processor/ASIC cycles, such as 
what would be required in, say, a packet classification or
header lookup operation.  Your ASIC or CPU may be able to
process up to a certain number of packets/sec, and this may 
not allow full link utilization if packets are too small.
Specifying a minimal packet size let's you capture this.

Roch